summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-09-25 06:05:06 +0000
committerMike Frysinger <vapier@gentoo.org>2010-09-25 06:05:06 +0000
commit9ebc02898280e4d9931897f11e4347d27b2ef4db (patch)
treeae11264479b7506ed9d997404c0bf585eda1c692 /net-misc/whois
parentVersion bump (fixes bug #316577, thanks to Artur Frysiak for reporting), upda... (diff)
downloadgentoo-2-9ebc02898280e4d9931897f11e4347d27b2ef4db.tar.gz
gentoo-2-9ebc02898280e4d9931897f11e4347d27b2ef4db.tar.bz2
gentoo-2-9ebc02898280e4d9931897f11e4347d27b2ef4db.zip
Version bump #338611 by Agostino Sarubbo.
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/whois')
-rw-r--r--net-misc/whois/ChangeLog7
-rw-r--r--net-misc/whois/whois-5.0.7.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/net-misc/whois/ChangeLog b/net-misc/whois/ChangeLog
index 50f484368461..0e4a18b34dd6 100644
--- a/net-misc/whois/ChangeLog
+++ b/net-misc/whois/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/whois
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.145 2010/09/19 19:21:09 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/ChangeLog,v 1.146 2010/09/25 06:05:06 vapier Exp $
+
+*whois-5.0.7 (25 Sep 2010)
+
+ 25 Sep 2010; Mike Frysinger <vapier@gentoo.org> +whois-5.0.7.ebuild:
+ Version bump #338611 by Agostino Sarubbo.
19 Sep 2010; Mike Frysinger <vapier@gentoo.org> whois-5.0.5.ebuild:
Stabilize for ia64/s390/sh #329663.
diff --git a/net-misc/whois/whois-5.0.7.ebuild b/net-misc/whois/whois-5.0.7.ebuild
new file mode 100644
index 000000000000..1ede53ab7969
--- /dev/null
+++ b/net-misc/whois/whois-5.0.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-5.0.7.ebuild,v 1.1 2010/09/25 06:05:06 vapier Exp $
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+MY_P=${P/-/_}
+DESCRIPTION="improved Whois Client"
+HOMEPAGE="http://www.linux.it/~md/software/"
+SRC_URI="mirror://debian/pool/main/w/whois/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="nls"
+RESTRICT="test" #59327
+
+RDEPEND="net-dns/libidn"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.7.2-config-file.patch
+
+ if use nls ; then
+ sed -i -e 's:#\(.*pos\):\1:' Makefile
+ else
+ sed -i -e '/ENABLE_NLS/s:define:undef:' config.h
+ fi
+}
+
+src_configure() { :;} # expected no-op
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS} ${CPPFLAGS}" HAVE_LIBIDN=1 || die
+}
+
+src_install() {
+ emake BASEDIR="${ED}" prefix=/usr install || die
+ insinto /etc
+ doins whois.conf
+ dodoc README debian/changelog
+
+ if [[ ${USERLAND} != "GNU" ]]; then
+ mv "${ED}"/usr/share/man/man1/{whois,mdwhois}.1
+ mv "${ED}"/usr/bin/{whois,mdwhois}
+ fi
+}