summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2012-03-07 13:46:24 +0000
committerThomas Kahle <tomka@gentoo.org>2012-03-07 13:46:24 +0000
commitffe4a742f470030a807777796084bf21b351dfd7 (patch)
tree9802a711fc765dbfe31364feb43446fb29f5d59f /net-misc/wicd
parentLatest qt-webkit no longer has a dbus USE flag, thus drop the USE dependency. (diff)
downloadgentoo-2-ffe4a742f470030a807777796084bf21b351dfd7.tar.gz
gentoo-2-ffe4a742f470030a807777796084bf21b351dfd7.tar.bz2
gentoo-2-ffe4a742f470030a807777796084bf21b351dfd7.zip
Fix language support (bug 407035), thanks Michael
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wicd')
-rw-r--r--net-misc/wicd/ChangeLog7
-rw-r--r--net-misc/wicd/wicd-1.7.1-r3.ebuild131
2 files changed, 137 insertions, 1 deletions
diff --git a/net-misc/wicd/ChangeLog b/net-misc/wicd/ChangeLog
index 6582d47334df..dfce54caf84e 100644
--- a/net-misc/wicd/ChangeLog
+++ b/net-misc/wicd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/wicd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.114 2012/02/27 21:04:11 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/ChangeLog,v 1.115 2012/03/07 13:46:24 tomka Exp $
+
+*wicd-1.7.1-r3 (07 Mar 2012)
+
+ 07 Mar 2012; Thomas Kahle <tomka@gentoo.org> +wicd-1.7.1-r3.ebuild:
+ Fix language support (bug 407035), thanks Michael
*wicd-1.7.1-r2 (27 Feb 2012)
diff --git a/net-misc/wicd/wicd-1.7.1-r3.ebuild b/net-misc/wicd/wicd-1.7.1-r3.ebuild
new file mode 100644
index 000000000000..b3faf6e9cf65
--- /dev/null
+++ b/net-misc/wicd/wicd-1.7.1-r3.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wicd/wicd-1.7.1-r3.ebuild,v 1.1 2012/03/07 13:46:24 tomka Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="ncurses? xml"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+
+inherit eutils distutils systemd
+
+DESCRIPTION="A lightweight wired and wireless network manager for Linux"
+HOMEPAGE="http://wicd.sourceforge.net/"
+SRC_URI="http://launchpad.net/wicd/1.7/${PV}/+download/${P}.tar.gz
+ mac4lin? ( http://dev.gentoo.org/~anarchy/dist/wicd-mac4lin-icons.tar.xz )
+ ambiance? ( http://freetimesblog.altervista.org/blog/wp-content/uploads/downloads/2010/05/Icone-Wicd-Lucid.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X ambiance +gtk ioctl libnotify mac4lin ncurses nls +pm-utils"
+
+DEPEND="dev-python/Babel"
+# Maybe virtual/dhcp would work, but there are enough problems with
+# net-misc/dhcp that I want net-misc/dhcpcd to be guarenteed to be considered
+# first if none are installed.
+RDEPEND="
+ dev-python/dbus-python
+ X? ( gtk? ( dev-python/pygtk
+ || (
+ x11-misc/ktsuss
+ x11-libs/gksu
+ kde-base/kdesu
+ )
+ )
+ )
+ || (
+ net-misc/dhcpcd
+ net-misc/dhcp
+ net-misc/pump
+ )
+ net-wireless/wireless-tools
+ net-wireless/wpa_supplicant
+ || (
+ sys-apps/net-tools
+ sys-apps/ethtool
+ )
+ !gtk? ( dev-python/pygobject:2 )
+ ioctl? ( dev-python/python-iwscan dev-python/python-wpactrl )
+ libnotify? ( dev-python/notify-python )
+ ncurses? (
+ dev-python/urwid
+ dev-python/pygobject:2
+ )
+ pm-utils? ( >=sys-power/pm-utils-1.1.1 )
+ "
+DOCS="CHANGES NEWS AUTHORS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.7.1_beta2-init.patch
+ epatch "${FILESDIR}"/${PN}-init-sve-start.patch
+ # Add a template for hex psk's and wpa (Bug 306423)
+ epatch "${FILESDIR}"/${PN}-1.7.1_pre20111210-wpa-psk-hex-template.patch
+ # get rid of opts variable to fix bug 381885
+ sed -i "/opts/d" "in/init=gentoo=wicd.in" || die
+ # Make init script provide net per bug 405775
+ epatch "${FILESDIR}"/${PN}-1.7.1-provide-net.patch
+ # Need to ensure that generated scripts use Python 2 at run time.
+ sed -e "s:self.python = '/usr/bin/python':self.python = '/usr/bin/python2':" \
+ -i setup.py || die "sed failed"
+ # Compile the translations
+ ./setup.py compile_translations || die
+ # Asturian is known to fail, so we just give them japanese :)
+ # (https://bugs.launchpad.net/wicd/+bug/928589)
+ cp translations/ja/LC_MESSAGES/wicd.mo translations/ast/LC_MESSAGES/wicd.mo || die
+ python_copy_sources
+}
+
+src_configure() {
+ local myconf
+ use gtk || myconf="${myconf} --no-install-gtk"
+ use libnotify || myconf="${myconf} --no-use-notifications"
+ use ncurses || myconf="${myconf} --no-install-ncurses"
+ use pm-utils || myconf="${myconf} --no-install-pmutils"
+ configuration() {
+ $(PYTHON) ./setup.py configure --no-install-docs --resume=/usr/share/wicd/scripts/ --suspend=/usr/share/wicd/scripts/ --verbose ${myconf}
+ }
+ python_execute_function -s configuration
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/lib/wicd/configurations \
+ || die "keepdir failed, critical for this app"
+ keepdir /etc/wicd/scripts/{postconnect,disconnect,preconnect} \
+ || die "keepdir failed, critical for this app"
+ keepdir /var/log/wicd \
+ || die "keepdir failed, critical for this app"
+ use nls || rm -rf "${D}"/usr/share/locale
+ systemd_dounit "${S}/other/wicd.service"
+
+ if use mac4lin; then
+ rm -rf "${D}"/usr/share/pixmaps/wicd || die "Failed to remove old icons"
+ mv "${WORKDIR}"/wicd "${D}"/usr/share/pixmaps/
+ fi
+ if use ambiance; then
+ # Overwrite tray icons with ambiance icon
+ rm "${WORKDIR}/Icone Wicd Lucid"/signal*
+ cp "${WORKDIR}/Icone Wicd Lucid"/*.png "${D}"/usr/share/pixmaps/wicd/
+ fi
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You may need to restart the dbus service after upgrading wicd."
+ echo
+ elog "To start wicd at boot, add /etc/init.d/wicd to a runlevel and:"
+ elog "- Remove all net.* initscripts (except for net.lo) from all runlevels"
+ elog "- Add these scripts to the RC_PLUG_SERVICES line in /etc/rc.conf"
+ elog "(For example, rc_hotplug=\"!net.eth* !net.wlan*\")"
+ # Maintainer's note: the consolekit use flag short circuits a dbus rule and
+ # allows the connection. Else, you need to be in the group.
+ if ! has_version sys-auth/pambase[consolekit]; then
+ ewarn "Wicd-1.6 and newer requires your user to be in the 'users' group. If"
+ ewarn "you are not in that group, then modify /etc/dbus-1/system.d/wicd.conf"
+ fi
+}