summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-11-07 18:14:46 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-11-07 18:14:46 +0000
commita5acb8e9c74d9486a1841be1d4c72da0c7c78386 (patch)
tree6e57e4d4c25f666e25ddc766ddfc20776223c293 /net-misc/wput
parentUpdating deps wrt to bug #118746 (diff)
downloadgentoo-2-a5acb8e9c74d9486a1841be1d4c72da0c7c78386.tar.gz
gentoo-2-a5acb8e9c74d9486a1841be1d4c72da0c7c78386.tar.bz2
gentoo-2-a5acb8e9c74d9486a1841be1d4c72da0c7c78386.zip
fix patch
(Portage version: 2.1.2_rc1-r4)
Diffstat (limited to 'net-misc/wput')
-rw-r--r--net-misc/wput/ChangeLog6
-rw-r--r--net-misc/wput/files/wput-0.6-gentoo.diff50
2 files changed, 13 insertions, 43 deletions
diff --git a/net-misc/wput/ChangeLog b/net-misc/wput/ChangeLog
index 7c0f62c3e009..92c42092968a 100644
--- a/net-misc/wput/ChangeLog
+++ b/net-misc/wput/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wput
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/ChangeLog,v 1.13 2006/11/07 00:38:57 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/ChangeLog,v 1.14 2006/11/07 18:14:46 genstef Exp $
+
+ 07 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+ files/wput-0.6-gentoo.diff:
+ fix patch
07 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
files/wput-0.6-gentoo.diff:
diff --git a/net-misc/wput/files/wput-0.6-gentoo.diff b/net-misc/wput/files/wput-0.6-gentoo.diff
index 1f2a39f29168..312172348d02 100644
--- a/net-misc/wput/files/wput-0.6-gentoo.diff
+++ b/net-misc/wput/files/wput-0.6-gentoo.diff
@@ -1,52 +1,18 @@
-diff -urN wput/Makefile wput/Makefile
---- wput/Makefile 2006-04-04 19:06:27.000000000 +0100
-+++ wput/Makefile 2006-11-06 06:24:58.000000000 +0000
-@@ -15,8 +15,10 @@
+diff -urN wput/Makefile.in wput/Makefile.in
+--- wput/Makefile.in 2006-04-04 18:16:52.000000000 +0100
++++ wput/Makefile.in 2006-11-07 17:31:10.000000000 +0000
+@@ -15,8 +15,12 @@
install: all
cd po && $(MAKE) $(MAKEDEFS) $@
- install -m0755 wput $(bindir)
- install -m0644 doc/wput.1.gz $(mandir)
-+ mkdir -p $(DESTDIR)/$(bindir)
-+ mkdir -p $(DESTDIR)/$(mandir)
++
++ install -d $(DESTDIR)/$(bindir)
+ install -m0755 wput $(DESTDIR)/$(bindir)
++ install -d $(DESTDIR)/$(mandir)
+ install -m0644 doc/wput.1.gz $(DESTDIR)/$(mandir)
++
@echo "----------------"
@echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
@echo "Further documentation is located in the doc/USAGE.* files."
-diff -urN wput/src/ftp.c wput/src/ftp.c
---- wput/src/ftp.c 2006-04-07 23:14:47.000000000 +0100
-+++ wput/src/ftp.c 2006-11-06 06:21:24.000000000 +0000
-@@ -88,7 +88,7 @@
- * path and change there again */
- /* error-levels: ERR_RECONNECT, ERR_FAILED, ERR_SKIP (failed for '/'), 1 */
- int try_do_cwd(ftp_con * ftp, char * path, int mkd) {
-- int res;
-+ int res = -1;
- if(!strcmp(path, "."))
- return mkd;
- if(!strcmp(path, ".."))
-@@ -201,7 +201,7 @@
- }
-
- int open_input_file(_fsession * fsession) {
-- int fd;
-+ int fd = -1;
- int oflags = O_RDONLY;
- char * cmd;
- FILE * pipe;
-diff -urN wput/src/ftp-ls.c wput/src/ftp-ls.c
---- wput/src/ftp-ls.c 2006-04-06 22:09:18.000000000 +0100
-+++ wput/src/ftp-ls.c 2006-11-06 06:21:24.000000000 +0000
-@@ -44,6 +44,11 @@
- #include <sys/types.h>
- #include <errno.h>
-
-+#ifndef _XOPEN_SOURCE
-+# define _XOPEN_SOURCE
-+#endif
-+#include <time.h>
-+
- #include "wget.h"
- #include "utils.h"
- #include "ftp.h"