summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2005-08-21 03:18:45 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2005-08-21 03:18:45 +0000
commit5ce33d072e869a73a611a38165febaffb7a99daf (patch)
tree6e2adbac1038a86a1554bd6a2727ac4acae8722f /net-misc/x25_utils/x25_utils-2.3.93.ebuild
parentNew snapshot of kdrive, a pack of tiny X servers. Perhaps the most interestin... (diff)
downloadgentoo-2-5ce33d072e869a73a611a38165febaffb7a99daf.tar.gz
gentoo-2-5ce33d072e869a73a611a38165febaffb7a99daf.tar.bz2
gentoo-2-5ce33d072e869a73a611a38165febaffb7a99daf.zip
initial commit, including gcc3 and 64-Bit patches.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'net-misc/x25_utils/x25_utils-2.3.93.ebuild')
-rw-r--r--net-misc/x25_utils/x25_utils-2.3.93.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/x25_utils/x25_utils-2.3.93.ebuild b/net-misc/x25_utils/x25_utils-2.3.93.ebuild
new file mode 100644
index 000000000000..4cafdeb49066
--- /dev/null
+++ b/net-misc/x25_utils/x25_utils-2.3.93.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x25_utils/x25_utils-2.3.93.ebuild,v 1.1 2005/08/21 03:18:45 sbriesen Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="Utilities to configure X.25 networks"
+HOMEPAGE="http://www.baty.hanse.de/"
+SRC_URI="http://www.baty.hanse.de/linux-x25/utils/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="sys-libs/ncurses"
+
+pkg_setup() {
+ CONFIG_CHECK="X25"
+ linux-info_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # patch Makefile to catch errors
+ sed -i -e "s:\(\$\$i\);:\1 || exit;:g" Makefile
+
+ # patch telnet/telnetd
+ epatch "${FILESDIR}/${P}.patch"
+}
+
+src_compile() {
+ emake -j1 O="${CFLAGS} -Wno-trigraphs" || die "emake failed"
+}
+
+src_install() {
+ newbin telnet/telnet x25telnet
+ newsbin telnetd/telnetd x25.telnetd
+ dosbin route/x25route trace/x25trace
+ newman telnet/telnet.1 x25telnet.1
+ newman telnetd/telnetd.8 x25.telnetd.8
+ doman route/x25route.8 trace/x25trace.8
+ newdoc trace/Changes Changes.x25trace
+ newdoc telnet/README README.telnet
+ dodoc Changes README
+}