summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-05 13:15:01 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-05 13:15:01 +0000
commitafd95f071d658587a5b7e3a13444cedb7017cc0e (patch)
treef249ef9ed117389e6c61136893efdf8301ae3b51 /net-misc/x2goclient
parentStable for amd64 wrt bug #498698 (diff)
downloadgentoo-2-afd95f071d658587a5b7e3a13444cedb7017cc0e.tar.gz
gentoo-2-afd95f071d658587a5b7e3a13444cedb7017cc0e.tar.bz2
gentoo-2-afd95f071d658587a5b7e3a13444cedb7017cc0e.zip
Allow to build plugin and install provider sample files, bug #500302
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/x2goclient')
-rw-r--r--net-misc/x2goclient/ChangeLog8
-rw-r--r--net-misc/x2goclient/x2goclient-4.0.1.3-r1.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/net-misc/x2goclient/ChangeLog b/net-misc/x2goclient/ChangeLog
index 5c282d915c6f..59d96dc64d4c 100644
--- a/net-misc/x2goclient/ChangeLog
+++ b/net-misc/x2goclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/x2goclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.26 2014/01/22 08:49:25 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.27 2014/02/05 13:15:01 voyageur Exp $
+
+*x2goclient-4.0.1.3-r1 (05 Feb 2014)
+
+ 05 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +x2goclient-4.0.1.3-r1.ebuild:
+ Allow to build plugin and install provider sample files, bug #500302
*x2goclient-4.0.1.3 (22 Jan 2014)
diff --git a/net-misc/x2goclient/x2goclient-4.0.1.3-r1.ebuild b/net-misc/x2goclient/x2goclient-4.0.1.3-r1.ebuild
new file mode 100644
index 000000000000..84bfd8ae305b
--- /dev/null
+++ b/net-misc/x2goclient/x2goclient-4.0.1.3-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.1.3-r1.ebuild,v 1.1 2014/02/05 13:15:01 voyageur Exp $
+
+EAPI=5
+inherit eutils nsplugins qt4-r2
+
+DESCRIPTION="The X2Go Qt client"
+HOMEPAGE="http://www.x2go.org"
+SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap nsplugin"
+
+DEPEND=">=net-libs/libssh-0.6.0_rc1
+ net-print/cups
+ dev-qt/qtcore:4[ssl]
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ net-misc/nx"
+
+CLIENT_BUILD=${WORKDIR}/${P}.client_build
+PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build
+
+src_prepare() {
+ if ! use ldap; then
+ sed -e "s/-lldap//" -i x2goclient.pro || die
+ sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
+ fi
+
+ mkdir -p "${CLIENT_BUILD}"
+ use nsplugin && mkdir -p "${PLUGIN_BUILD}"
+}
+
+src_configure() {
+ cd "${CLIENT_BUILD}"
+ eqmake4 "${S}"/x2goclient.pro
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
+ fi
+}
+
+src_compile() {
+ cd "${CLIENT_BUILD}"
+ qt4-r2_src_compile
+
+ if use nsplugin;
+ then
+ cd "${PLUGIN_BUILD}"
+ qt4-r2_src_compile
+ fi
+}
+
+src_install() {
+ dobin "${CLIENT_BUILD}"/${PN}
+
+ insinto /usr/share/pixmaps/x2goclient
+ doins -r icons/*
+
+ domenu desktop/${PN}.desktop
+ doman man/man?/*
+
+ if use nsplugin;
+ then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe "${PLUGIN_BUILD}"/libx2goplugin.so
+ fi
+
+ emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
+}