summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-29 10:48:13 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-29 10:48:13 +0000
commit0212ffdfffd860f47497505824214ce9a38153ea (patch)
treee691f035a04451a1fd1c5bd4a925c04db7f5c909 /net-misc
parentadd a warning about conflicting patches (diff)
downloadgentoo-2-0212ffdfffd860f47497505824214ce9a38153ea.tar.gz
gentoo-2-0212ffdfffd860f47497505824214ce9a38153ea.tar.bz2
gentoo-2-0212ffdfffd860f47497505824214ce9a38153ea.zip
Version bump #94261 by Tobias Sager.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/files/digest-openssh-4.1_p14
-rw-r--r--net-misc/openssh/openssh-4.1_p1.ebuild155
3 files changed, 165 insertions, 1 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 5f47268485c3..c0fe8efde152 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.121 2005/05/28 01:28:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.122 2005/05/29 10:48:13 vapier Exp $
+
+*openssh-4.1_p1 (29 May 2005)
+
+ 29 May 2005; Mike Frysinger <vapier@gentoo.org> +openssh-4.1_p1.ebuild:
+ Version bump #94261 by Tobias Sager.
28 May 2005; Mike Frysinger <vapier@gentoo.org>
+files/openssh-4.0_p1-smartcard-ldap-happy.patch,
diff --git a/net-misc/openssh/files/digest-openssh-4.1_p1 b/net-misc/openssh/files/digest-openssh-4.1_p1
new file mode 100644
index 000000000000..6dcf0cd3181f
--- /dev/null
+++ b/net-misc/openssh/files/digest-openssh-4.1_p1
@@ -0,0 +1,4 @@
+MD5 959c663e709c981f07a3315bfd64f3d0 openssh-4.1p1.tar.gz 894234
+MD5 576d620efda55ded77c973de54803246 openssh-lpk-4.0p1-0.3.4.patch 44122
+MD5 8d4ef926ec329c8ae551fd0133ba91e6 openssh-4.1p1+x509-5.1.diff.gz 117293
+MD5 79f5648305c8b8a1bc1414e8f6c6134c openssh-4.0p1+SecurID_v1.3.1.patch 610662
diff --git a/net-misc/openssh/openssh-4.1_p1.ebuild b/net-misc/openssh/openssh-4.1_p1.ebuild
new file mode 100644
index 000000000000..2cca345acfd8
--- /dev/null
+++ b/net-misc/openssh/openssh-4.1_p1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-4.1_p1.ebuild,v 1.1 2005/05/29 10:48:13 vapier Exp $
+
+inherit eutils flag-o-matic ccc pam
+
+# Make it more portable between straight releases
+# and _p? releases.
+PARCH=${P/_/}
+
+SFTPLOG_PATCH_VER="1.2"
+X509_PATCH="${PARCH}+x509-5.1.diff.gz"
+SELINUX_PATCH="openssh-3.9_p1-selinux.diff"
+SECURID_PATCH="" #${PARCH}+SecurID_v1.3.1.patch
+LDAP_PATCH="openssh-lpk-4.0p1-0.3.4.patch" #${PARCH/-/-lpk-}-0.3.4.patch
+
+DESCRIPTION="Port of OpenBSD's free SSH release"
+HOMEPAGE="http://www.openssh.com/"
+SRC_URI="mirror://openbsd/OpenSSH/portable/${PARCH}.tar.gz
+ ldap? ( http://www.opendarwin.org/en/projects/openssh-lpk/files/${LDAP_PATCH} )
+ X509? ( http://roumenpetrov.info/openssh/x509-5.1/${X509_PATCH} )"
+# smartcard? ( http://www.omniti.com/~jesus/projects/${SECURID_PATCH} )
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6 static pam tcpd kerberos skey selinux chroot X509 ldap smartcard nocxx sftplogging"
+
+RDEPEND="pam? ( virtual/pam )
+ kerberos? ( virtual/krb5 )
+ selinux? ( sys-libs/libselinux )
+ skey? ( >=app-admin/skey-1.1.5-r1 )
+ ldap? ( net-nds/openldap )
+ >=dev-libs/openssl-0.9.6d
+ >=sys-libs/zlib-1.1.4
+ smartcard? ( dev-libs/opensc )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ !nocxx? ( sys-apps/groff )
+ sys-devel/autoconf"
+PROVIDE="virtual/ssh"
+
+S=${WORKDIR}/${PARCH}
+
+src_unpack() {
+ unpack ${PARCH}.tar.gz
+ cd "${S}"
+
+ #epatch "${FILESDIR}"/openssh-3.9_p1-largekey.patch.bz2
+ epatch "${FILESDIR}"/openssh-3.9_p1-kerberos-detection.patch #80811
+
+ use X509 && epatch ${DISTDIR}/${X509_PATCH}
+ use sftplogging && epatch ${FILESDIR}/openssh-4.0_p1-sftplogging-1.2-gentoo.patch.bz2
+ use skey && epatch ${FILESDIR}/openssh-3.9_p1-skey.patch.bz2
+ use chroot && epatch ${FILESDIR}/openssh-3.9_p1-chroot.patch
+ use selinux && epatch ${FILESDIR}/${SELINUX_PATCH}.bz2
+ use smartcard && epatch ${FILESDIR}/openssh-3.9_p1-opensc.patch.bz2
+ if ! use X509 ; then
+ if [[ -n ${SECURID_PATCH} ]] && use smartcard ; then
+ epatch ${DISTDIR}/${SECURID_PATCH}
+ use ldap && epatch ${FILESDIR}/openssh-4.0_p1-smartcard-ldap-happy.patch
+ fi
+ use ldap && epatch ${DISTDIR}/${LDAP_PATCH}
+ elif use smartcard || use ldap ; then
+ ewarn "Sorry, x509 and smartcard/ldap don't get along"
+ fi
+
+ sed -i '/LD.*ssh-keysign/s:$: -Wl,-z,now:' Makefile.in || die "setuid"
+
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ local myconf
+
+ addwrite /dev/ptmx
+
+ # make sure .sbss is large enough
+ use skey && use alpha && append-ldflags -mlarge-data
+ if use ldap ; then
+ filter-flags -funroll-loops
+ append-ldflags -lldap -llber
+ append-flags -DWITH_LDAP_PUBKEY
+ fi
+ use selinux && append-flags "-DWITH_SELINUX"
+
+ if use static ; then
+ append-ldflags -static
+ use pam && ewarn "Disabling pam support becuse of static flag"
+ myconf="${myconf} --without-pam"
+ else
+ myconf="${myconf} $(use_with pam)"
+ fi
+
+ use ipv6 || myconf="${myconf} --with-ipv4-default"
+
+ econf \
+ --with-ldflags="${LDFLAGS}" \
+ --disable-strip \
+ --sysconfdir=/etc/ssh \
+ --libexecdir=/usr/$(get_libdir)/misc \
+ --datadir=/usr/share/openssh \
+ --disable-suid-ssh \
+ --with-privsep-path=/var/empty \
+ --with-privsep-user=sshd \
+ --with-md5-passwords \
+ $(use_with kerberos kerberos5 /usr) \
+ $(use_with tcpd tcp-wrappers) \
+ $(use_with skey) \
+ $(use_with smartcard opensc) \
+ ${myconf} \
+ || die "bad configure"
+
+ emake || die "compile problem"
+}
+
+src_install() {
+ make install-nokeys DESTDIR="${D}" || die
+ fperms 600 /etc/ssh/sshd_config
+ dobin contrib/ssh-copy-id
+ newinitd "${FILESDIR}"/sshd.rc6 sshd
+ keepdir /var/empty
+
+ newpamd "${FILESDIR}"/sshd.pam_include sshd
+ dosed "/^#Protocol /s:.*:Protocol 2:" /etc/ssh/sshd_config
+ use pam \
+ && dosed "/^#UsePAM /s:.*:UsePAM yes:" /etc/ssh/sshd_config \
+ && dosed "/^#PasswordAuthentication /s:.*:PasswordAuthentication no:" /etc/ssh/sshd_config
+
+ doman contrib/ssh-copy-id.1
+ dodoc ChangeLog CREDITS OVERVIEW README* TODO sshd_config
+}
+
+pkg_postinst() {
+ enewgroup sshd 22
+ enewuser sshd 22 /bin/false /var/empty sshd
+
+ ewarn "Remember to merge your config files in /etc/ssh/ and then"
+ ewarn "restart sshd: '/etc/init.d/sshd restart'."
+ ewarn
+ einfo "As of version 3.4 the default is to enable the UsePrivelegeSeparation"
+ einfo "functionality, but please ensure that you do not explicitly disable"
+ einfo "this in your configuration as disabling it opens security holes"
+ einfo
+ einfo "This revision has removed your sshd user id and replaced it with a"
+ einfo "new one with UID 22. If you have any scripts or programs that"
+ einfo "that referenced the old UID directly, you will need to update them."
+ einfo
+ if use pam ; then
+ einfo "Please be aware users need a valid shell in /etc/passwd"
+ einfo "in order to be allowed to login."
+ einfo
+ fi
+}