summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-13 20:33:03 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-13 20:33:03 +0000
commit1476b19f6315ef695c968b9abc792555de110bf9 (patch)
treedc87d09506b4ec2fc4e6d438f9b3e1980c14ba31 /net-misc
parentcouple of new binaries (diff)
downloadgentoo-2-1476b19f6315ef695c968b9abc792555de110bf9.tar.gz
gentoo-2-1476b19f6315ef695c968b9abc792555de110bf9.tar.bz2
gentoo-2-1476b19f6315ef695c968b9abc792555de110bf9.zip
couple of new binaries
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/Manifest4
-rw-r--r--net-misc/putty/files/digest-putty-20030902-r11
-rw-r--r--net-misc/putty/putty-20030902-r1.ebuild62
4 files changed, 71 insertions, 3 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 440c1c77706d..1a35dd065c2e 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.5 2003/09/13 20:24:10 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.6 2003/09/13 20:32:59 taviso Exp $
+
+*putty-20030902-r1 (13 Sep 2003)
+
+ 13 Sep 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030902-r1.ebuild:
+ including pscp and psftp
13 Sep 2003; Tavis Ormandy <taviso@gentoo.org> putty-20030902.ebuild:
stable
diff --git a/net-misc/putty/Manifest b/net-misc/putty/Manifest
index 216e3aaedcc8..1f5a52a8b366 100644
--- a/net-misc/putty/Manifest
+++ b/net-misc/putty/Manifest
@@ -1,6 +1,6 @@
MD5 561dd55eaf9c7887374e37ad83ccaac9 putty-20030902.ebuild 1366
-MD5 546b676af506681a7e701c2386a9288e putty-20030902-r1.ebuild 1379
-MD5 d71eaec4a081668144fc0273965c611f ChangeLog 878
+MD5 855997603715758e80d8b97f21e2b2c2 putty-20030902-r1.ebuild 1382
+MD5 8c5ab71aa7d453a30b2fdb553171e74c ChangeLog 1015
MD5 f05c1530fb8ab3d11c216ab2efb29484 putty-20030603.ebuild 1418
MD5 a95f430323d2b9413a9ae45efb4d616c metadata.xml 549
MD5 bcc49e4648a2fa3b47fb42141928e0e0 files/digest-putty-20030603 70
diff --git a/net-misc/putty/files/digest-putty-20030902-r1 b/net-misc/putty/files/digest-putty-20030902-r1
new file mode 100644
index 000000000000..002c2e7ce459
--- /dev/null
+++ b/net-misc/putty/files/digest-putty-20030902-r1
@@ -0,0 +1 @@
+MD5 b5153e87291b69ae477fe75491e1dc30 putty-cvs-20030902.tar.gz 835580
diff --git a/net-misc/putty/putty-20030902-r1.ebuild b/net-misc/putty/putty-20030902-r1.ebuild
new file mode 100644
index 000000000000..6312b7a47000
--- /dev/null
+++ b/net-misc/putty/putty-20030902-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-20030902-r1.ebuild,v 1.1 2003/09/13 20:32:59 taviso Exp $
+
+DESCRIPTION="UNIX port of the famous Windows Telnet and SSH client"
+
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="mirror://gentoo/putty-cvs-${PV}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+IUSE="doc"
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ virtual/x11"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5.8.0
+ >=sys-apps/sed-4
+ =x11-libs/gtk+-1.2*
+ virtual/x11"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+ # generate the makefiles
+ einfo "Generating Makefiles..."
+ ${S}/mkfiles.pl || die "failed to create makefiles."
+
+ # change the CFLAGS to those requested by user.
+ einfo "Setting CFLAGS..."
+ sed -i "s/-O2/${CFLAGS}/g" ${S}/unix/Makefile.gtk
+
+ # build putty.
+ einfo "Building putty..."
+ cd ${S}/unix; emake -f Makefile.gtk
+}
+
+src_install() {
+
+ cd ${S}/unix
+
+ # man pages...
+ doman plink.1 pterm.1 putty.1 puttytel.1
+
+ # binaries...
+ dobin plink pterm putty puttytel psftp pscp
+
+ cd ${S}
+
+ # docs...
+ dodoc README README.txt LICENCE CHECKLST.txt LATEST.VER website.url MODULE
+ use doc && dodoc doc/*
+
+ prepallman
+
+ if test ! -c /dev/ptmx; then
+ ewarn
+ ewarn "The pterm application requires UNIX98 PTY support to operate."
+ ewarn
+ fi
+}