summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-04-29 13:35:36 +0000
committerJeroen Roovers <jer@gentoo.org>2009-04-29 13:35:36 +0000
commit58fc8220dc0b6a5d5d4562b6b29fbe6d8683da67 (patch)
tree4dceccc449e6b566a51b691aa3eb1c853859948d /net-misc
parentunmask libXfont 1.4.0 (diff)
downloadgentoo-2-58fc8220dc0b6a5d5d4562b6b29fbe6d8683da67.tar.gz
gentoo-2-58fc8220dc0b6a5d5d4562b6b29fbe6d8683da67.tar.bz2
gentoo-2-58fc8220dc0b6a5d5d4562b6b29fbe6d8683da67.zip
Version bumps based on contribution by Tim Harder (bug #267848).
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/socat/ChangeLog11
-rw-r--r--net-misc/socat/socat-1.7.1.0.ebuild45
-rw-r--r--net-misc/socat/socat-2.0.0_beta3.ebuild45
3 files changed, 99 insertions, 2 deletions
diff --git a/net-misc/socat/ChangeLog b/net-misc/socat/ChangeLog
index 2d3ba6923cf4..1c31125b2d9d 100644
--- a/net-misc/socat/ChangeLog
+++ b/net-misc/socat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/socat
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.42 2008/11/19 09:40:29 armin76 Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/ChangeLog,v 1.43 2009/04/29 13:35:36 jer Exp $
+
+*socat-2.0.0_beta3 (29 Apr 2009)
+*socat-1.7.1.0 (29 Apr 2009)
+
+ 29 Apr 2009; Jeroen Roovers <jer@gentoo.org> +socat-1.7.1.0.ebuild,
+ +socat-2.0.0_beta3.ebuild:
+ Version bumps based on contribution by Tim Harder (bug #267848).
19 Nov 2008; Raúl Porcel <armin76@gentoo.org> socat-1.6.0.1.ebuild:
alpha/ia64/x86 stable wrt #247089
diff --git a/net-misc/socat/socat-1.7.1.0.ebuild b/net-misc/socat/socat-1.7.1.0.ebuild
new file mode 100644
index 000000000000..f265c8592189
--- /dev/null
+++ b/net-misc/socat/socat-1.7.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-1.7.1.0.ebuild,v 1.1 2009/04/29 13:35:36 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ virtual/libc"
+
+src_configure() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_test() {
+ TMPDIR="${T}" emake test || die 'self test failed'
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT EXAMPLES \
+ FAQ FILES PORTING README SECURITY VERSION
+ docinto examples
+ dodoc *.sh
+ dohtml doc/*.html doc/*.css
+}
diff --git a/net-misc/socat/socat-2.0.0_beta3.ebuild b/net-misc/socat/socat-2.0.0_beta3.ebuild
new file mode 100644
index 000000000000..ca7886728d25
--- /dev/null
+++ b/net-misc/socat/socat-2.0.0_beta3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/socat/socat-2.0.0_beta3.ebuild,v 1.1 2009/04/29 13:35:36 jer Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/"
+MY_P=${P/_beta/-b}
+S="${WORKDIR}/${MY_P}"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="ssl readline ipv6 tcpd"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6 )
+ readline? ( >=sys-libs/ncurses-5.1 >=sys-libs/readline-4.1 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ virtual/libc"
+
+src_configure() {
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_test() {
+ TMPDIR="${T}" emake test || die 'self test failed'
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ dodoc BUGREPORTS CHANGES DEVELOPMENT EXAMPLES \
+ FAQ FILES PORTING README SECURITY VERSION
+ docinto examples
+ dodoc *.sh
+ dohtml doc/*.html doc/*.css
+}