summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2007-10-17 23:32:58 +0000
committerSteve Dibb <beandog@gentoo.org>2007-10-17 23:32:58 +0000
commit610a232dae71f79bf26b719cff3d0c5aeec59fde (patch)
tree25e04211cd9e866a0e90f25659e732975717cd77 /net-misc
parentbump to 2.6.5 and fix some quoting (diff)
downloadgentoo-2-610a232dae71f79bf26b719cff3d0c5aeec59fde.tar.gz
gentoo-2-610a232dae71f79bf26b719cff3d0c5aeec59fde.tar.bz2
gentoo-2-610a232dae71f79bf26b719cff3d0c5aeec59fde.zip
Fix DEPEND/RDEPEND
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tightvnc/ChangeLog7
-rw-r--r--net-misc/tightvnc/files/digest-tightvnc-1.3.9-r13
-rw-r--r--net-misc/tightvnc/tightvnc-1.3.9-r1.ebuild112
3 files changed, 121 insertions, 1 deletions
diff --git a/net-misc/tightvnc/ChangeLog b/net-misc/tightvnc/ChangeLog
index e26cd01505ab..f046a55145e6 100644
--- a/net-misc/tightvnc/ChangeLog
+++ b/net-misc/tightvnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/tightvnc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.113 2007/06/27 16:36:18 lavajoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/ChangeLog,v 1.114 2007/10/17 23:32:58 beandog Exp $
+
+*tightvnc-1.3.9-r1 (17 Oct 2007)
+
+ 17 Oct 2007; Steve Dibb <beandog@gentoo.org> +tightvnc-1.3.9-r1.ebuild:
+ Fix DEPEND/RDEPEND
27 Jun 2007; Joe Peterson <lavajoe@gentoo.org> files/1.3.9-fbsd.patch,
tightvnc-1.3.9.ebuild:
diff --git a/net-misc/tightvnc/files/digest-tightvnc-1.3.9-r1 b/net-misc/tightvnc/files/digest-tightvnc-1.3.9-r1
new file mode 100644
index 000000000000..f2933102cd1c
--- /dev/null
+++ b/net-misc/tightvnc/files/digest-tightvnc-1.3.9-r1
@@ -0,0 +1,3 @@
+MD5 49a0748ea52793f2e3069e05af28f716 tightvnc-1.3.9_unixsrc.tar.bz2 1792459
+RMD160 79d858466b7fab740b4d66d6b0963533f48a5163 tightvnc-1.3.9_unixsrc.tar.bz2 1792459
+SHA256 99aaca636535f9127f3a435ee71aef6821f821e6319bc6e9b2c775fefd34325a tightvnc-1.3.9_unixsrc.tar.bz2 1792459
diff --git a/net-misc/tightvnc/tightvnc-1.3.9-r1.ebuild b/net-misc/tightvnc/tightvnc-1.3.9-r1.ebuild
new file mode 100644
index 000000000000..778ea6615cbd
--- /dev/null
+++ b/net-misc/tightvnc/tightvnc-1.3.9-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tightvnc/tightvnc-1.3.9-r1.ebuild,v 1.1 2007/10/17 23:32:58 beandog Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="java tcpd server"
+
+S="${WORKDIR}/vnc_unixsrc"
+DESCRIPTION="A great client/server software package allowing remote network access to graphical desktops."
+SRC_URI="mirror://sourceforge/vnc-tight/${P}_unixsrc.tar.bz2"
+HOMEPAGE="http://www.tightvnc.com/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="~media-libs/jpeg-6b
+ server? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc
+ x11-apps/rgb
+ x11-apps/xauth
+ x11-apps/xsetroot
+ )
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXt
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r2 )
+ java? ( || ( >=virtual/jdk-1.3.1 >=virtual/jre-1.3.1 ) )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ server? (
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/printproto
+ )
+ >=x11-misc/imake-1
+ x11-misc/gccmakedep
+ x11-misc/makedepend
+ !net-misc/vnc"
+
+src_unpack() {
+
+ if ! use server;
+ then
+ echo
+ einfo "The 'server' USE flag will build tightvnc's server."
+ einfo "If '-server' is chosen only the client is built to save space."
+ einfo "Stop the build now if you need to add 'server' to USE flags.\n"
+ ebeep
+ epause 5
+ fi
+
+ unpack ${A} && cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.3.8-pathfixes.patch" # fixes bug 78385 and 146099
+ epatch "${FILESDIR}/${PN}-1.3.8-imake-tmpdir.patch" # fixes bug 23483
+ epatch "${FILESDIR}/${PN}-1.3.8-darwin.patch" # fixes bug 89908
+ use mips && epatch "${FILESDIR}/${PN}-1.3.8-mips.patch"
+ epatch "${FILESDIR}"/server-CVE-2007-1003.patch
+ epatch "${FILESDIR}"/server-CVE-2007-1351-1352.patch
+ epatch "${FILESDIR}"/${PV}-fbsd.patch
+
+}
+
+src_compile() {
+ xmkmf -a || die "xmkmf failed"
+
+ make CDEBUGFLAGS="${CFLAGS}" World || die
+
+ if use server; then
+ cd Xvnc && ./configure || die "Configure failed."
+ if use tcpd; then
+ local myextra="-lwrap"
+ make EXTRA_LIBRARIES="${myextra}" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_DEFINES="-DUSE_LIBWRAP=1" || die
+ else
+ make CDEBUGFLAGS="${CFLAGS}" || die
+ fi
+ fi
+
+}
+
+src_install() {
+ # the web based interface and the java viewer need the java class files
+ if use java; then
+ insinto /usr/share/tightvnc/classes
+ doins classes/*
+ fi
+
+ dodir /usr/share/man/man1 /usr/bin
+ ./vncinstall "${D}"/usr/bin "${D}"/usr/share/man || die "vncinstall failed"
+
+ if use server; then
+ newconfd "${FILESDIR}"/tightvnc.confd vnc
+ newinitd "${FILESDIR}"/tightvnc.initd vnc
+ else
+ rm -f "${D}"/usr/bin/vncserver
+ rm -f "${D}"/usr/share/man/man1/{Xvnc,vncserver}*
+ fi
+
+ doicon "${FILESDIR}"/vncviewer.png
+ make_desktop_entry vncviewer vncviewer vncviewer.png Network
+
+ dodoc ChangeLog README WhatsNew
+ use java && dodoc "${FILESDIR}"/README.JavaViewer
+ newdoc vncviewer/README README.vncviewer
+}