summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-02-08 11:26:06 +0000
committerRoy Marples <uberlord@gentoo.org>2006-02-08 11:26:06 +0000
commit8589b3fb1568d0c9edc15d20ee9314942dab8695 (patch)
treed6e027727578382f405b2061567e24774657c130 /net-misc
parentStable on ppc-macos, wrt #117111. (diff)
downloadgentoo-2-8589b3fb1568d0c9edc15d20ee9314942dab8695.tar.gz
gentoo-2-8589b3fb1568d0c9edc15d20ee9314942dab8695.tar.bz2
gentoo-2-8589b3fb1568d0c9edc15d20ee9314942dab8695.zip
Punted old versions
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvpn/files/openvpn61
-rw-r--r--net-misc/openvpn/openvpn-1.5.0-r1.ebuild49
-rw-r--r--net-misc/openvpn/openvpn-1.6.0.ebuild49
-rw-r--r--net-misc/openvpn/openvpn-2.0.5.ebuild113
4 files changed, 0 insertions, 272 deletions
diff --git a/net-misc/openvpn/files/openvpn b/net-misc/openvpn/files/openvpn
deleted file mode 100644
index e0b7c14f36cf..000000000000
--- a/net-misc/openvpn/files/openvpn
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/sbin/runscript
-
-VPNDIR="/etc/openvpn"
-
-depend() {
- need net
-}
-
-checktundevice() {
- if [ -h /dev/net/tun ] && [ -c /dev/misc/net/tun ]; then
- ebegin Detected broken /dev/net/tun symlink, fixing...
- rm /dev/net/tun
- ln -s /dev/misc/net/tun /dev/net/tun
- eend $?
- fi
-}
-
-start() {
- checktundevice || return 1
-
- cd ${VPNDIR}
- for VPN in *
- do
- if [ -d ${VPN} ] && [ -e ${VPN}/local.conf ]; then
- if [ -f ${VPN}/onlinecheck ]; then
- ping -c 3 `head -n 1 ${VPN}/onlinecheck` >& /dev/null
- else
- false
- fi
-
- if [ $? -gt 0 ]; then
- ebegin "Starting openvpn for ${VPN}"
- start-stop-daemon --start --pidfile /var/run/openvpn-${VPN}.pid \
- --startas /usr/sbin/openvpn -- --config ${VPN}/local.conf \
- --writepid /var/run/openvpn-${VPN}.pid \
- --daemon --cd ${VPN}
- eend $?
- else
- einfo "Connection ${VPN} already online. Skipping..."
- fi
- else
- ewarn "Expected ${VPNDIR}/${VPN} to be a directory containing a local.conf."
- fi
- done
-}
-
-stop() {
- cd ${VPNDIR}
- for VPN in *
- do
- if [ -e /var/run/openvpn-${VPN}.pid ]; then
- ebegin "Stopping openvpn for ${VPN}"
- start-stop-daemon --oknodo --stop --pidfile /var/run/openvpn-${VPN}.pid
- rm /var/run/openvpn-${VPN}.pid
- eend 0
- else
- ewarn "${VPN} has no pidfile!"
- fi
- done
- return 0
-}
diff --git a/net-misc/openvpn/openvpn-1.5.0-r1.ebuild b/net-misc/openvpn/openvpn-1.5.0-r1.ebuild
deleted file mode 100644
index c52f1240e7f3..000000000000
--- a/net-misc/openvpn/openvpn-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.5.0-r1.ebuild,v 1.12 2005/05/01 09:02:35 luckyduck Exp $
-
-inherit gnuconfig
-
-
-DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
-SRC_URI="mirror://sourceforge/openvpn/${P}.tar.gz"
-HOMEPAGE="http://openvpn.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc sparc ~alpha ~amd64"
-IUSE="ssl threads"
-
-RDEPEND=">=dev-libs/lzo-1.07
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-DEPEND="${RDEPEND} virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
- gnuconfig_update
-}
-
-src_compile() {
- econf \
- $(use_enable ssl) \
- $(use_enable ssl crypto) \
- $(use_enable threads pthread) \
- || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
- dodoc ChangeLog INSTALL PORTS README
- exeinto /etc/init.d
- doexe ${FILESDIR}/openvpn
-}
-
-pkg_postinst() {
- einfo "The init.d script that comes with OpenVPN expects directories"
- einfo "/etc/openvpn/*/ with a local.conf and any supporting files, "
- einfo "such as keys."
- ewarn "This version of OpenVPN is NOT COMPATIBLE with 1.4.2!"
- ewarn "If you need compatibility with 1.4.2 please emerge that version."
-}
diff --git a/net-misc/openvpn/openvpn-1.6.0.ebuild b/net-misc/openvpn/openvpn-1.6.0.ebuild
deleted file mode 100644
index 3d044f2774ff..000000000000
--- a/net-misc/openvpn/openvpn-1.6.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.6.0.ebuild,v 1.9 2005/05/07 02:48:00 jforman Exp $
-
-inherit gnuconfig
-
-
-DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
-SRC_URI="mirror://sourceforge/openvpn/${P}.tar.gz"
-HOMEPAGE="http://openvpn.sourceforge.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ~ppc sparc ~alpha ~ppc-macos amd64"
-IUSE="ssl threads"
-
-RDEPEND=">=dev-libs/lzo-1.07
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-DEPEND="${RDEPEND} virtual/os-headers"
-
-src_unpack() {
- unpack ${A}
- gnuconfig_update
-}
-
-src_compile() {
- econf \
- $(use_enable ssl) \
- $(use_enable ssl crypto) \
- $(use_enable threads pthread) \
- || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
-
- dodoc ChangeLog INSTALL PORTS README
- exeinto /etc/init.d
- doexe ${FILESDIR}/openvpn
-}
-
-pkg_postinst() {
- einfo "The init.d script that comes with OpenVPN expects directories"
- einfo "/etc/openvpn/*/ with a local.conf and any supporting files,"
- einfo "such as keys."
- ewarn "This version of OpenVPN is NOT COMPATIBLE with 1.4.2!"
- ewarn "If you need compatibility with 1.4.2 please emerge that version."
-}
diff --git a/net-misc/openvpn/openvpn-2.0.5.ebuild b/net-misc/openvpn/openvpn-2.0.5.ebuild
deleted file mode 100644
index 63c5fe4c0e34..000000000000
--- a/net-misc/openvpn/openvpn-2.0.5.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.5.ebuild,v 1.9 2005/11/06 14:37:43 uberlord Exp $
-
-inherit eutils gnuconfig multilib
-
-DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application compatible with many OSes."
-SRC_URI="http://openvpn.net/release/openvpn-${PV}.tar.gz"
-HOMEPAGE="http://openvpn.net/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ppc ppc-macos sparc x86"
-IUSE="examples iproute2 minimal pam passwordsave selinux ssl static threads"
-
-RDEPEND=">=dev-libs/lzo-1.07
- kernel_linux? (
- iproute2? ( sys-apps/iproute2 ) !iproute2? ( sys-apps/net-tools )
- )
- !minimal? ( pam? ( virtual/pam ) )
- selinux? ( sec-policy/selinux-openvpn )
- ssl? ( >=dev-libs/openssl-0.9.6 )"
-DEPEND="${RDEPEND}
- virtual/os-headers"
-
-src_unpack() {
- unpack "${A}"
- gnuconfig_update
- cd "${S}"
- epatch "${FILESDIR}/${PN}"-2.0.4-darwin.patch
-}
-
-src_compile() {
- local myconf=""
- # We cannot use use_enable with iproute2 as the Makefile stupidly
- # enables it with --disable-iproute2
- use iproute2 && myconf="${myconf} --enable-iproute2"
- use minimal && myconf="${myconf} --disable-plugins"
-
- econf ${myconf} \
- $(use_enable passwordsave password-save) \
- $(use_enable ssl) \
- $(use_enable ssl crypto) \
- $(use_enable threads pthread) \
- || die "configure failed"
-
- use static && sed -e -i '/^LIBS/s/LIBS = /LIBS = -static /' Makefile
-
- emake || die "make failed"
-
- if ! use minimal ; then
- cd plugin
- for i in $( ls 2>/dev/null ); do
- [[ ${i} == "README" || ${i} == "examples" ]] && continue
- [[ ${i} == "auth-pam" ]] && ! use pam && continue
- einfo "Building ${i} plugin"
- cd "${i}"
- emake || die "make failed"
- cd ..
- done
- cd ..
- fi
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
-
- # install documentation
- dodoc AUTHORS ChangeLog INSTALL PORTS README
-
- # Empty dir
- dodir /etc/openvpn
- keepdir /etc/openvpn
-
- # Install the init script
- newinitd "${FILESDIR}/openvpn" openvpn
-
- # Install easy-rsa stuff
- exeinto "/usr/share/${PN}/easy-rsa"
- doexe easy-rsa/2.0/*-* easy-rsa/2.0/pkitool
- insinto "/usr/share/${PN}/easy-rsa"
- doins easy-rsa/2.0/{README,openssl.cnf,vars}
-
- # install examples, controlled by the respective useflag
- if use examples ; then
- # dodoc does not supportly support directory traversal, #15193
- insinto /usr/share/doc/${PF}/examples
- doins -r sample-{config-files,keys,scripts} contrib
- prepalldocs
- fi
-
- # Install plugins
- if ! use minimal ; then
- exeinto "/usr/$(get_libdir)/${PN}"
- doexe plugin/*/*.so
- fi
-}
-
-pkg_postinst() {
- ewarn "This version of OpenVPN is NOT COMPATIBLE with older versions!"
- ewarn "If you need compatibility with a version < 2 please emerge"
- ewarn "that one."
- einfo ""
- einfo "The init.d script that comes with OpenVPN expects directories"
- einfo "/etc/openvpn/*/ with a local.conf and any supporting files,"
- einfo "such as keys."
- einfo ""
- ewarn "If you've used 2.0 already make sure to move your configuration"
- ewarn "files into a subdirectory of /etc/openvpn, for example to:"
- ewarn "/etc/openvpn/myconf and rename your configfile to local.conf"
- ewarn ""
- ebeep
-}