summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-03 01:00:11 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-03 01:00:11 +0000
commit95572b79c9f4c7e3626b77e5121ba7de56986451 (patch)
tree27803a4d8f33e3e4206b2f104a89dd80c6ded7e4 /net-misc
parentrestore egetshell as some packages in the tree have been parsing getent direc... (diff)
downloadgentoo-2-95572b79c9f4c7e3626b77e5121ba7de56986451.tar.gz
gentoo-2-95572b79c9f4c7e3626b77e5121ba7de56986451.tar.bz2
gentoo-2-95572b79c9f4c7e3626b77e5121ba7de56986451.zip
Use new egetshell helper rather than calling getent directly.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openssh/ChangeLog7
-rw-r--r--net-misc/openssh/openssh-5.5_p1-r2.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.6_p1-r2.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.7_p1-r1.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.8_p1-r1.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.8_p2-r1.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.8_p2.ebuild4
-rw-r--r--net-misc/openssh/openssh-5.9_p1-r3.ebuild4
8 files changed, 20 insertions, 15 deletions
diff --git a/net-misc/openssh/ChangeLog b/net-misc/openssh/ChangeLog
index 030605ffe8b4..e163dc61a449 100644
--- a/net-misc/openssh/ChangeLog
+++ b/net-misc/openssh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/openssh
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.427 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/ChangeLog,v 1.428 2011/11/03 01:00:11 vapier Exp $
+
+ 03 Nov 2011; Mike Frysinger <vapier@gentoo.org> openssh-5.5_p1-r2.ebuild,
+ openssh-5.6_p1-r2.ebuild, openssh-5.7_p1-r1.ebuild, openssh-5.8_p1-r1.ebuild,
+ openssh-5.8_p2.ebuild, openssh-5.8_p2-r1.ebuild, openssh-5.9_p1-r3.ebuild:
+ Use new egetshell helper rather than calling getent directly.
02 Nov 2011; Mike Frysinger <vapier@gentoo.org> openssh-5.5_p1-r2.ebuild,
openssh-5.6_p1-r2.ebuild, openssh-5.7_p1-r1.ebuild, openssh-5.8_p1-r1.ebuild,
diff --git a/net-misc/openssh/openssh-5.5_p1-r2.ebuild b/net-misc/openssh/openssh-5.5_p1-r2.ebuild
index 3d6557fbd5b1..dcb672212822 100644
--- a/net-misc/openssh/openssh-5.5_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-5.5_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.5_p1-r2.ebuild,v 1.10 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.5_p1-r2.ebuild,v 1.11 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -227,7 +227,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"
diff --git a/net-misc/openssh/openssh-5.6_p1-r2.ebuild b/net-misc/openssh/openssh-5.6_p1-r2.ebuild
index 5e6db4b0b93e..451ca3b0a835 100644
--- a/net-misc/openssh/openssh-5.6_p1-r2.ebuild
+++ b/net-misc/openssh/openssh-5.6_p1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.6_p1-r2.ebuild,v 1.12 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.6_p1-r2.ebuild,v 1.13 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -219,7 +219,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"
diff --git a/net-misc/openssh/openssh-5.7_p1-r1.ebuild b/net-misc/openssh/openssh-5.7_p1-r1.ebuild
index a99c10b04d06..c75e64228ff7 100644
--- a/net-misc/openssh/openssh-5.7_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-5.7_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.7_p1-r1.ebuild,v 1.5 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.7_p1-r1.ebuild,v 1.6 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -207,7 +207,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"
diff --git a/net-misc/openssh/openssh-5.8_p1-r1.ebuild b/net-misc/openssh/openssh-5.8_p1-r1.ebuild
index c537bc1c9e4d..3a8ce699430c 100644
--- a/net-misc/openssh/openssh-5.8_p1-r1.ebuild
+++ b/net-misc/openssh/openssh-5.8_p1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1-r1.ebuild,v 1.7 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p1-r1.ebuild,v 1.8 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -206,7 +206,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"
diff --git a/net-misc/openssh/openssh-5.8_p2-r1.ebuild b/net-misc/openssh/openssh-5.8_p2-r1.ebuild
index 971e2cab1d17..df68f0408abb 100644
--- a/net-misc/openssh/openssh-5.8_p2-r1.ebuild
+++ b/net-misc/openssh/openssh-5.8_p2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p2-r1.ebuild,v 1.2 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p2-r1.ebuild,v 1.3 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -206,7 +206,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"
diff --git a/net-misc/openssh/openssh-5.8_p2.ebuild b/net-misc/openssh/openssh-5.8_p2.ebuild
index 8025dc38f1e7..846d11f9c672 100644
--- a/net-misc/openssh/openssh-5.8_p2.ebuild
+++ b/net-misc/openssh/openssh-5.8_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p2.ebuild,v 1.3 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.8_p2.ebuild,v 1.4 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -206,7 +206,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"
diff --git a/net-misc/openssh/openssh-5.9_p1-r3.ebuild b/net-misc/openssh/openssh-5.9_p1-r3.ebuild
index f2de8356415a..a430a662b829 100644
--- a/net-misc/openssh/openssh-5.9_p1-r3.ebuild
+++ b/net-misc/openssh/openssh-5.9_p1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.9_p1-r3.ebuild,v 1.2 2011/11/02 23:09:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openssh/openssh-5.9_p1-r3.ebuild,v 1.3 2011/11/03 01:00:11 vapier Exp $
EAPI="2"
inherit eutils flag-o-matic multilib autotools pam
@@ -212,7 +212,7 @@ src_test() {
local t tests skipped failed passed shell
tests="interop-tests compat-tests"
skipped=""
- shell=$(egetent passwd ${UID} | cut -d: -f7)
+ shell=$(egetshell ${UID})
if [[ ${shell} == */nologin ]] || [[ ${shell} == */false ]] ; then
elog "Running the full OpenSSH testsuite"
elog "requires a usable shell for the 'portage'"