summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-05-13 14:52:34 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-05-13 14:52:34 +0000
commit955e99fb1782fdb803582f9bb689c35453d2aa9c (patch)
tree2dbd067e2e016d43e77b2a320ccbca7788c11e20 /net-misc
parentold (diff)
downloadgentoo-2-955e99fb1782fdb803582f9bb689c35453d2aa9c.tar.gz
gentoo-2-955e99fb1782fdb803582f9bb689c35453d2aa9c.tar.bz2
gentoo-2-955e99fb1782fdb803582f9bb689c35453d2aa9c.zip
Bugfix release from upstream, closes bug #318535 by Thomas Stein. Many thanks to Oliver Jaksch for his patch rediffing & scavenging activities. /etc/asterisk will no longer be polluted with any sample files if the samples USE-flag is unset, closes bug #286574 by Jeremy Johnson and bug #305313 by Michael Higgins.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/asterisk/ChangeLog13
-rw-r--r--net-misc/asterisk/asterisk-1.6.2.7.ebuild323
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-gsm-pic.patch60
-rw-r--r--net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-pri-missing-keyword.patch12
-rw-r--r--net-misc/asterisk/metadata.xml1
5 files changed, 408 insertions, 1 deletions
diff --git a/net-misc/asterisk/ChangeLog b/net-misc/asterisk/ChangeLog
index 86f486635929..4356c7942ec5 100644
--- a/net-misc/asterisk/ChangeLog
+++ b/net-misc/asterisk/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for net-misc/asterisk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/ChangeLog,v 1.254 2010/04/06 08:14:37 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/ChangeLog,v 1.255 2010/05/13 14:52:34 chainsaw Exp $
+
+*asterisk-1.6.2.7 (13 May 2010)
+
+ 13 May 2010; <chainsaw@gentoo.org> +asterisk-1.6.2.7.ebuild,
+ +files/1.6.2/asterisk-1.6.2.7-gsm-pic.patch,
+ +files/1.6.2/asterisk-1.6.2.7-pri-missing-keyword.patch, metadata.xml:
+ Bugfix release from upstream, closes bug #318535 by Thomas Stein. Many
+ thanks to Oliver Jaksch for his patch rediffing & scavenging activities.
+ /etc/asterisk will no longer be polluted with any sample files if the
+ samples USE-flag is unset, closes bug #286574 by Jeremy Johnson and bug
+ #305313 by Michael Higgins.
06 Apr 2010; <chainsaw@gentoo.org> -asterisk-1.6.1.17.ebuild,
-asterisk-1.6.2.5.ebuild:
diff --git a/net-misc/asterisk/asterisk-1.6.2.7.ebuild b/net-misc/asterisk/asterisk-1.6.2.7.ebuild
new file mode 100644
index 000000000000..d046009d2445
--- /dev/null
+++ b/net-misc/asterisk/asterisk-1.6.2.7.ebuild
@@ -0,0 +1,323 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk/asterisk-1.6.2.7.ebuild,v 1.1 2010/05/13 14:52:34 chainsaw Exp $
+
+EAPI=3
+inherit autotools base eutils linux-info
+
+MY_P="${PN}-${PV/_/-}"
+
+DESCRIPTION="Asterisk: A Modular Open Source PBX System"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.digium.com/pub/telephony/asterisk/releases/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="alsa +caps curl dahdi debug freetds iconv jabber ldap keepsrc misdn newt +samples oss postgres radius snmp span speex ssl sqlite static vorbis"
+
+RDEPEND="sys-libs/ncurses
+ dev-libs/popt
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ caps? ( sys-libs/libcap )
+ curl? ( net-misc/curl )
+ dahdi? ( >=net-libs/libpri-1.4.7
+ net-misc/dahdi-tools )
+ freetds? ( dev-db/freetds )
+ iconv? ( virtual/libiconv )
+ jabber? ( dev-libs/iksemel )
+ ldap? ( net-nds/openldap )
+ misdn? ( net-dialup/misdnuser )
+ newt? ( dev-libs/newt )
+ postgres? ( virtual/postgresql-base )
+ radius? ( net-dialup/radiusclient-ng )
+ snmp? ( net-analyzer/net-snmp )
+ span? ( media-libs/spandsp )
+ speex? ( media-libs/speex )
+ sqlite? ( dev-db/sqlite )
+ ssl? ( dev-libs/openssl )
+ vorbis? ( media-libs/libvorbis )"
+
+DEPEND="${RDEPEND}
+ !<net-misc/asterisk-addons-1.6
+ !net-misc/asterisk-chan_unistim
+ !net-misc/zaptel"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/1.6.2/${P}-gsm-pic.patch"
+ "${FILESDIR}/1.6.2/${P}-pri-missing-keyword.patch"
+ "${FILESDIR}/1.6.1/${PN}-1.6.1-uclibc.patch"
+ "${FILESDIR}/1.6.1/${PN}-1.6.1.6-fxsks-hookstate.patch"
+ "${FILESDIR}/1.6.2/${PN}-1.6.2.2-nv-faxdetect.patch"
+)
+
+get_available_modules() {
+ local modules mod x
+
+ # build list of available modules...
+ for x in app cdr codec format func pbx res; do
+
+ for mod in $(find "${S}" -type f -name "${x}_*.c*" -print)
+ do
+ modules="${modules} $(basename ${mod/%.c*})"
+ done
+ done
+
+ echo "${modules}"
+}
+
+pkg_setup() {
+ if [[ -n "${ASTERISK_MODULES}" ]] ; then
+ ewarn "You are overriding ASTERISK_MODULES. We will assume you know what you are doing. There is no support for this option, try without if you see breakage."
+ fi
+ CONFIG_CHECK="~!NF_CONNTRACK_SIP"
+ local WARNING_NF_CONNTRACK_SIP="SIP (NAT) connection tracking is a module written for a single SIP client talking to a
+ remote server. It is not able to track multiple remote SIP clients registering with
+ a local server. Critical SIP packets may be dropped."
+ check_extra_config
+
+ # parse modules list
+ if [[ -n "${ASTERISK_MODULES}" ]]; then
+ local x modules="$(get_available_modules)"
+
+ einfo "Custom list of modules specified, checking..."
+
+ use debug && {
+ einfo "Available modules: ${modules}"
+ einfo " Selected modules: ${ASTERISK_MODULES}"
+ }
+
+ for x in ${ASTERISK_MODULES}; do
+ if [[ "${x}" = "-*" ]]; then
+ MODULES_LIST=""
+ else
+ if has ${x} ${modules}
+ then
+ MODULES_LIST="${MODULES_LIST} ${x}"
+ else
+ eerror "Unknown module: ${x}"
+ fi
+ fi
+ done
+
+ export MODULES_LIST
+ fi
+}
+
+src_prepare() {
+ base_src_prepare
+ AT_M4DIR=autoconf eautoreconf
+}
+
+src_configure() {
+ econf \
+ --libdir="/usr/$(get_libdir)" \
+ --localstatedir="/var" \
+ --with-gsm=internal \
+ --with-popt \
+ --with-z \
+ $(use_with alsa asound) \
+ $(use_with caps cap) \
+ $(use_with curl) \
+ $(use_with dahdi pri) \
+ $(use_with dahdi tonezone) \
+ $(use_with dahdi) \
+ $(use_with freetds tds) \
+ $(use_with iconv) \
+ $(use_with jabber iksemel) \
+ $(use_with misdn isdnnet) \
+ $(use_with misdn suppserv) \
+ $(use_with misdn) \
+ $(use_with newt) \
+ $(use_with oss) \
+ $(use_with postgres) \
+ $(use_with radius) \
+ $(use_with snmp netsnmp) \
+ $(use_with span spandsp) \
+ $(use_with speex) \
+ $(use_with speex speexdsp) \
+ $(use_with sqlite sqlite3) \
+ $(use_with ssl crypto) \
+ $(use_with ssl) \
+ $(use_with vorbis ogg) \
+ $(use_with vorbis) || die "econf failed"
+
+ #
+ # custom module filter
+ # run menuselect to evaluate the list of modules
+ # and rewrite the list afterwards
+ #
+ if [[ -n "${MODULES_LIST}" ]]
+ then
+ local mod category tmp_list failed_list
+
+ ###
+ # run menuselect
+
+ emake menuselect.makeopts || die "emake menuselect.makeopts failed"
+
+ ###
+ # get list of modules with failed dependencies
+
+ failed_list="$(awk -F= '/^MENUSELECT_DEPSFAILED=/{ print $3 }' menuselect.makeopts)"
+
+ ###
+ # traverse our list of modules
+
+ for category in app cdr codec format func pbx res; do
+ tmp_list=""
+
+ # search list of modules for matching ones first...
+ for mod in ${MODULES_LIST}; do
+ # module is from current category?
+ if [[ "${mod/%_*}" = "${category}" ]]
+ then
+ # check menuselect thinks the dependencies are met
+ if has ${mod} ${failed_list}
+ then
+ eerror "${mod}: dependencies required to build this module are not met, NOT BUILDING!"
+ else
+ tmp_list="${tmp_list} ${mod}"
+ fi
+ fi
+ done
+
+ use debug && echo "${category} tmp: ${tmp_list}"
+
+ # replace the module list for $category with our custom one
+ if [[ -n "${tmp_list}" ]]
+ then
+ category="$(echo ${category} | tr '[:lower:]' '[:upper:]')"
+ sed -i -e "s:^\(MENUSELECT_${category}S?\):\1=${tmp_list}:" \
+ menuselect.makeopts || die "failed to set list of ${category} applications"
+ fi
+ done
+ fi
+}
+
+src_compile() {
+ ASTLDFLAGS="${LDFLAGS}" emake || die "emake failed"
+}
+
+src_install() {
+ # setup directory structure
+ #
+ mkdir -p "${D}"usr/lib/pkgconfig
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use samples; then
+ emake DESTDIR="${D}" samples || die "emake samples failed"
+ for conffile in "${D}"etc/asterisk/*.*
+ do
+ fowners asterisk:asterisk $conffile
+ fperms 0660 $conffile
+ done
+ einfo "Sample files have been installed"
+ else
+ einfo "Skipping installation of sample files..."
+ rm -f "${D}"var/lib/asterisk/mohmp3/*
+ rm -f "${D}"var/lib/asterisk/sounds/demo-*
+ rm -f "${D}"var/lib/asterisk/agi-bin/*
+ rm -f "${D}"etc/asterisk/*
+ fi
+ rm -rf "${D}"var/spool/asterisk/voicemail/default
+
+ # keep directories
+ diropts -m 0770 -o asterisk -g asterisk
+ keepdir /etc/asterisk
+ keepdir /var/lib/asterisk
+ keepdir /var/run/asterisk
+ keepdir /var/spool/asterisk
+ keepdir /var/spool/asterisk/{system,tmp,meetme,monitor,dictate,voicemail}
+ diropts -m 0750 -o asterisk -g asterisk
+ keepdir /var/log/asterisk/{cdr-csv,cdr-custom}
+
+ newinitd "${FILESDIR}"/1.6.1/asterisk.initd3 asterisk
+ newconfd "${FILESDIR}"/1.6.0/asterisk.confd asterisk
+
+ # some people like to keep the sources around for custom patching
+ # copy the whole source tree to /usr/src/asterisk-${PVF} and run make clean there
+ if use keepsrc
+ then
+ dodir /usr/src
+
+ ebegin "Copying sources into /usr/src"
+ cp -dPR "${S}" "${D}"/usr/src/${PF} || die "Unable to copy sources"
+ eend $?
+
+ ebegin "Cleaning source tree"
+ emake -C "${D}"/usr/src/${PF} clean &>/dev/null || die "Unable to clean sources"
+ eend $?
+
+ einfo "Clean sources are available in "${ROOT}"usr/src/${PF}"
+ fi
+
+ # install the upgrade documentation
+ #
+ dodoc README UPGRADE* BUGS CREDITS
+
+ # install snmp mib files
+ #
+ if use snmp
+ then
+ insinto /usr/share/snmp/mibs/
+ doins doc/digium-mib.txt doc/asterisk-mib.txt
+ fi
+}
+
+pkg_preinst() {
+ enewgroup asterisk
+ enewuser asterisk -1 -1 /var/lib/asterisk "asterisk,dialout"
+}
+
+pkg_postinst() {
+ #
+ # Announcements, warnings, reminders...
+ #
+ einfo "Asterisk has been installed"
+ echo
+ elog "If you want to know more about asterisk, visit these sites:"
+ elog "http://www.asteriskdocs.org/"
+ elog "http://www.voip-info.org/wiki-Asterisk"
+ echo
+ elog "http://www.automated.it/guidetoasterisk.htm"
+ echo
+ elog "Gentoo VoIP IRC Channel:"
+ elog "#gentoo-voip @ irc.freenode.net"
+ echo
+ echo
+ elog "1.6.1 -> 1.6.2 changes that you may care about:"
+ elog "canreinvite -> directmedia (sip.conf)"
+ elog "extensive T.38 (fax) changes"
+ elog "http://svn.asterisk.org/svn/${PN}/tags/${PV}/UPGRADE.txt"
+ elog "or: bzless ${ROOT}usr/share/doc/${PF}/UPGRADE.txt.bz2"
+}
+
+pkg_config() {
+ einfo "Do you want to reset file permissions and ownerships (y/N)?"
+
+ read tmp
+ tmp="$(echo $tmp | tr '[:upper:]' '[:lower:]')"
+
+ if [[ "$tmp" = "y" ]] ||\
+ [[ "$tmp" = "yes" ]]
+ then
+ einfo "Resetting permissions to defaults..."
+
+ for x in spool run lib log; do
+ chown -R asterisk:asterisk "${ROOT}"var/${x}/asterisk
+ chmod -R u=rwX,g=rwX,o= "${ROOT}"var/${x}/asterisk
+ done
+
+ chown -R root:asterisk "${ROOT}"etc/asterisk
+ chmod -R u=rwX,g=rwX,o= "${ROOT}"etc/asterisk
+
+ einfo "done"
+ else
+ einfo "skipping"
+ fi
+}
diff --git a/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-gsm-pic.patch b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-gsm-pic.patch
new file mode 100644
index 000000000000..20613d443b42
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-gsm-pic.patch
@@ -0,0 +1,60 @@
+diff -uNr asterisk-1.6.2.7.ORIG/codecs/gsm/Makefile asterisk-1.6.2.7/codecs/gsm/Makefile
+--- asterisk-1.6.2.7.ORIG/codecs/gsm/Makefile 2010-03-09 21:39:20.000000000 +0100
++++ asterisk-1.6.2.7/codecs/gsm/Makefile 2010-03-09 21:39:20.000000000 +0100
+@@ -37,28 +37,6 @@
+ ######### ppro's, etc, as well as the AMD K6 and K7. The compile will
+ ######### probably require gcc.
+
+-ifeq (, $(findstring $(OSARCH) , Darwin SunOS ))
+-ifeq (, $(findstring $(PROC) , x86_64 amd64 ultrasparc sparc64 arm armv5b armeb ppc powerpc ppc64 ia64 s390 bfin mipsel mips))
+-ifeq (, $(findstring $(shell uname -m) , ppc ppc64 alpha armv4l s390 ))
+-ifeq ($(shell /usr/bin/sw_vers -productVersion | cut -c1-4),10.6)
+-# Wow... Snow Leopard is BROKEN!
+-OPTIMIZE+=-mtune=native
+-else
+-OPTIMIZE+=-march=$(PROC)
+-endif
+-endif
+-endif
+-endif
+-
+-#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
+-#This works for even old (2.96) versions of gcc and provides a small boost either way.
+-#A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesn't support it.
+-#So we go lowest common available by gcc and go a step down, still a step up from
+-#the default as we now have a better instruction set to work with. - Belgarath
+-ifeq ($(PROC),ultrasparc)
+-OPTIMIZE+=-mcpu=v8 -mtune=$(PROC) -O3
+-endif
+-
+ PG =
+ #PG = -g -pg
+ ######### Profiling flags. If you don't know what that means, leave it blank.
+@@ -213,12 +191,10 @@
+ # XXX Keep a space after each findstring argument
+ # XXX should merge with GSM_OBJECTS
+ ifeq ($(OSARCH),linux-gnu)
+-ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc s390 ))
+-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 s390 bfin mipsel mips ))
++ifneq ($(K6OPT),)
+ GSM_SOURCES+= $(SRC)/k6opt.s
+ endif
+ endif
+-endif
+
+ TOAST_SOURCES = $(SRC)/toast.c \
+ $(SRC)/toast_lin.c \
+@@ -265,12 +241,10 @@
+ $(SRC)/table.o
+
+ ifeq ($(OSARCH),linux-gnu)
+-ifeq (,$(findstring $(shell uname -m) , x86_64 amd64 ppc ppc64 alpha armv4l sparc64 parisc ))
+-ifeq (,$(findstring $(PROC) , arm armv5b armeb powerpc ia64 bfin mipsel mips ))
++ifneq ($(K6OPT),)
+ GSM_OBJECTS+= $(SRC)/k6opt.o
+ endif
+ endif
+-endif
+
+ TOAST_OBJECTS = $(SRC)/toast.o \
+ $(SRC)/toast_lin.o \
diff --git a/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-pri-missing-keyword.patch b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-pri-missing-keyword.patch
new file mode 100644
index 000000000000..d3775d6c69fe
--- /dev/null
+++ b/net-misc/asterisk/files/1.6.2/asterisk-1.6.2.7-pri-missing-keyword.patch
@@ -0,0 +1,12 @@
+diff -uNr asterisk-1.6.2.6.ORIG/include/asterisk/autoconfig.h.in asterisk-1.6.2.6/include/asterisk/autoconfig.h.in
+--- asterisk-1.6.2.6.ORIG/include/asterisk/autoconfig.h.in 2009-09-29 09:53:36.000000000 +0200
++++ asterisk-1.6.2.6/include/asterisk/autoconfig.h.in 2009-09-29 2009-09-29 09:53:36.000000000 +0200
+@@ -616,6 +616,8 @@
+ /* Define to 1 if you have the ISDN PRI library. */
+ #undef HAVE_PRI
+
++#undef HAVE_PRI_PROG_W_CAUSE
++
+ /* Define to 1 if you have the ISDN PRI set_inbanddisconnect library. */
+ #undef HAVE_PRI_INBANDDISCONNECT
+
diff --git a/net-misc/asterisk/metadata.xml b/net-misc/asterisk/metadata.xml
index c924bb86f74c..76d5ef978c54 100644
--- a/net-misc/asterisk/metadata.xml
+++ b/net-misc/asterisk/metadata.xml
@@ -17,5 +17,6 @@
<flag name="newt">Include additional tools that require redhats windowing toolkit</flag>
<flag name="dahdi">Support Digium compatible hardware (formerly known as Zaptel).</flag>
<flag name="span">Enable support for the spandsp codec</flag>
+ <flag name="samples">Install sample sound and configuration files (default: on)</flag>
</use>
</pkgmetadata>