summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2002-02-09 19:45:45 +0000
committerChris Houser <chouser@gentoo.org>2002-02-09 19:45:45 +0000
commitb2b51a15e52aa45b1c10b5e92b038f3a9c032c2e (patch)
tree714aac552229d62370570ce041596d9112cae7d7 /net-misc
parentnew SLOT'ed version, removed old one (diff)
downloadgentoo-2-b2b51a15e52aa45b1c10b5e92b038f3a9c032c2e.tar.gz
gentoo-2-b2b51a15e52aa45b1c10b5e92b038f3a9c032c2e.tar.bz2
gentoo-2-b2b51a15e52aa45b1c10b5e92b038f3a9c032c2e.zip
Included an inital ChangeLog. Now installs a gyach.desktop entry and icon if
the user has gnome in USE. Thanks Matthew Kennedy!
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gyach/ChangeLog18
-rw-r--r--net-misc/gyach/files/digest-gyach-0.7.5-r11
-rw-r--r--net-misc/gyach/files/gyach.desktop7
-rw-r--r--net-misc/gyach/gyach-0.7.5-r1.ebuild30
4 files changed, 56 insertions, 0 deletions
diff --git a/net-misc/gyach/ChangeLog b/net-misc/gyach/ChangeLog
new file mode 100644
index 000000000000..7f40cb1898e4
--- /dev/null
+++ b/net-misc/gyach/ChangeLog
@@ -0,0 +1,18 @@
+# ChangeLog for net-misc/gyach
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+#
+
+*gyach-0.7.5-r1 (4 Feb 2002)
+
+ 4 Feb 2002; Matthew Kennedey <mbkennedy@ieee.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
+ 4 Feb 2002; Matthew Kennedy <mbkennedy@ieee.org> gyach-0.7.5-r1.ebuild :
+
+ Added support for an icon in the gnome desktop if the user has
+ gnome in USE.
diff --git a/net-misc/gyach/files/digest-gyach-0.7.5-r1 b/net-misc/gyach/files/digest-gyach-0.7.5-r1
new file mode 100644
index 000000000000..b6117de0d7e1
--- /dev/null
+++ b/net-misc/gyach/files/digest-gyach-0.7.5-r1
@@ -0,0 +1 @@
+MD5 580df7d14f058eeb566103d148d3a819 gyach-0.7.5.tar.gz 180224
diff --git a/net-misc/gyach/files/gyach.desktop b/net-misc/gyach/files/gyach.desktop
new file mode 100644
index 000000000000..0550c729ac9d
--- /dev/null
+++ b/net-misc/gyach/files/gyach.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Gyach
+Comment=Yahoo! Chat client
+Exec=gyach
+Icon=gyach-icon.xpm
+Terminal=0
+Type=Application
diff --git a/net-misc/gyach/gyach-0.7.5-r1.ebuild b/net-misc/gyach/gyach-0.7.5-r1.ebuild
new file mode 100644
index 000000000000..86552a30fa2b
--- /dev/null
+++ b/net-misc/gyach/gyach-0.7.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Matthew Kennedy <mbkennedy@ieee.com>
+#
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GTK+-based Yahoo! chat client"
+SRC_URI="http://www4.infi.net/~cpinkham/gyach/code/${P}.tar.gz"
+HOMEPAGE="http://www4.infi.net/~cpinkham/gyach/"
+
+DEPEND=">=x11-libs/gtk+-1.2.0"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+ dodoc AUTHORS BUGS COPYING ChangeLog NEWS README* TODO
+
+ # install icon and desktop entry for gnome
+ if [ "`use gnome`" ] ; then
+ insinto /usr/share/pixmaps
+ doins ${D}/usr/share/gyach/pixmaps/gyach-icon.xpm
+ insinto /usr/share/gnome/apps/Internet
+ doins ${FILESDIR}/gyach.desktop
+ fi
+
+}