summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2005-11-03 14:36:55 +0000
committerRoy Marples <uberlord@gentoo.org>2005-11-03 14:36:55 +0000
commitc8cce2d96dbc037e706b3d3edfd8ec40ef0b8399 (patch)
treec6c1eafd153b690b715723b6c5f6f39cbcf907b3 /net-misc
parentPHP security-update. (diff)
downloadgentoo-2-c8cce2d96dbc037e706b3d3edfd8ec40ef0b8399.tar.gz
gentoo-2-c8cce2d96dbc037e706b3d3edfd8ec40ef0b8399.tar.bz2
gentoo-2-c8cce2d96dbc037e706b3d3edfd8ec40ef0b8399.zip
easy-rsa now gets installed properly, #111351
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/openvpn/ChangeLog6
-rw-r--r--net-misc/openvpn/openvpn-2.0.4-r1.ebuild11
-rw-r--r--net-misc/openvpn/openvpn-2.0.4-r2.ebuild11
3 files changed, 15 insertions, 13 deletions
diff --git a/net-misc/openvpn/ChangeLog b/net-misc/openvpn/ChangeLog
index 736745d9cf98..9bd115770611 100644
--- a/net-misc/openvpn/ChangeLog
+++ b/net-misc/openvpn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/openvpn
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.54 2005/11/03 14:05:18 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/ChangeLog,v 1.55 2005/11/03 14:36:55 uberlord Exp $
+
+ 03 Nov 2005; Roy Marples <uberlord@gentoo.org> openvpn-2.0.4-r1.ebuild,
+ openvpn-2.0.4-r2.ebuild:
+ easy-rsa now gets installed properly, #111351
03 Nov 2005; Gustavo Zacarias <gustavoz@gentoo.org>
openvpn-2.0.4-r1.ebuild:
diff --git a/net-misc/openvpn/openvpn-2.0.4-r1.ebuild b/net-misc/openvpn/openvpn-2.0.4-r1.ebuild
index 71f37ce80aca..8938d5ce2d1a 100644
--- a/net-misc/openvpn/openvpn-2.0.4-r1.ebuild
+++ b/net-misc/openvpn/openvpn-2.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.4-r1.ebuild,v 1.3 2005/11/03 14:05:18 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.4-r1.ebuild,v 1.4 2005/11/03 14:36:55 uberlord Exp $
inherit eutils gnuconfig multilib
@@ -74,11 +74,11 @@ src_install() {
# Install the init script
newinitd "${FILESDIR}/openvpn" openvpn
- # Install easy-rsa stuffs
- dodir "/usr/share/${PN}/easy-rsa"
+ # Install easy-rsa stuff
exeinto "/usr/share/${PN}/easy-rsa"
- doexe easy-rsa/2.0/*
- exeopts -m0644
+ doexe easy-rsa/*-*
+ insinto "/usr/share/${PN}/easy-rsa"
+ doins easy-rsa/{README,openssl.cnf,vars}
# install examples, controlled by the respective useflag
if use examples ; then
@@ -90,7 +90,6 @@ src_install() {
# Install plugins
if ! use minimal ; then
- dodir "/usr/$(get_libdir)/${PN}"
exeinto "/usr/$(get_libdir)/${PN}"
doexe plugin/*/*.so
fi
diff --git a/net-misc/openvpn/openvpn-2.0.4-r2.ebuild b/net-misc/openvpn/openvpn-2.0.4-r2.ebuild
index edf88e46363d..738090b9b21f 100644
--- a/net-misc/openvpn/openvpn-2.0.4-r2.ebuild
+++ b/net-misc/openvpn/openvpn-2.0.4-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.4-r2.ebuild,v 1.2 2005/11/02 20:13:59 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-2.0.4-r2.ebuild,v 1.3 2005/11/03 14:36:55 uberlord Exp $
inherit eutils gnuconfig multilib
@@ -74,11 +74,11 @@ src_install() {
# Install the init script
newinitd "${FILESDIR}/openvpn.init" openvpn
- # Install easy-rsa stuffs
- dodir "/usr/share/${PN}/easy-rsa"
+ # Install easy-rsa stuff
exeinto "/usr/share/${PN}/easy-rsa"
- doexe easy-rsa/2.0/*
- exeopts -m0644
+ doexe easy-rsa/*-*
+ insinto "/usr/share/${PN}/easy-rsa"
+ doins easy-rsa/{README,openssl.cnf,vars}
# install examples, controlled by the respective useflag
if use examples ; then
@@ -90,7 +90,6 @@ src_install() {
# Install plugins
if ! use minimal ; then
- dodir "/usr/$(get_libdir)/${PN}"
exeinto "/usr/$(get_libdir)/${PN}"
doexe plugin/*/*.so
fi