summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Lameter <christoph@gentoo.org>2002-08-03 06:52:15 +0000
committerChristoph Lameter <christoph@gentoo.org>2002-08-03 06:52:15 +0000
commitcbd62c758db4e30a059e4d8df82a79d15bad2ad6 (patch)
treec56def80b3079183087cdbf167a1868363d48edb /net-misc
parentadded ppc to keywords (diff)
downloadgentoo-2-cbd62c758db4e30a059e4d8df82a79d15bad2ad6.tar.gz
gentoo-2-cbd62c758db4e30a059e4d8df82a79d15bad2ad6.tar.bz2
gentoo-2-cbd62c758db4e30a059e4d8df82a79d15bad2ad6.zip
Add udhcp ebuild
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/udhcp/ChangeLog9
-rw-r--r--net-misc/udhcp/files/digest-udhcp-0.9.71
-rw-r--r--net-misc/udhcp/udhcp-0.9.7.ebuild26
3 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/udhcp/ChangeLog b/net-misc/udhcp/ChangeLog
new file mode 100644
index 000000000000..4d3e4245bcc8
--- /dev/null
+++ b/net-misc/udhcp/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/udhcp
+# Copyright 2002 TelemetryBox Corporation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udhcp/ChangeLog,v 1.1 2002/08/03 06:52:14 christoph Exp $
+
+*udhcp-0.9.7 (02 Aug 2002)
+
+ 02 Aug 2002; Christoph Lameter <christoph@gentoo.org> udhcp-0.9.7.ebuild
+ Ebuild written
+
diff --git a/net-misc/udhcp/files/digest-udhcp-0.9.7 b/net-misc/udhcp/files/digest-udhcp-0.9.7
new file mode 100644
index 000000000000..fbdd8dfd415b
--- /dev/null
+++ b/net-misc/udhcp/files/digest-udhcp-0.9.7
@@ -0,0 +1 @@
+MD5 99803b9bc432243b96723b2b9f35f67e udhcp-0.9.7.tar.gz 42938
diff --git a/net-misc/udhcp/udhcp-0.9.7.ebuild b/net-misc/udhcp/udhcp-0.9.7.ebuild
new file mode 100644
index 000000000000..233e4066a723
--- /dev/null
+++ b/net-misc/udhcp/udhcp-0.9.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/udhcp/udhcp-0.9.7.ebuild,v 1.1 2002/08/03 06:52:15 christoph Exp $
+
+DESCRIPTION="udhcp Server/Client Package"
+HOMEPAGE="http://udhcp.busybox.net/"
+SRC_URI="http://udhcp.busybox.net/source/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ emake SYSLOG=1|| die
+}
+
+src_install () {
+ dodir /usr/sbin
+ dodir /usr/bin
+ dodir /sbin
+ dodir /etc
+ install -m644 samples/udhcpd.conf ${D}/etc
+ make prefix=${D}/usr SBINDIR=${D}/sbin install || die
+}