summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-05 16:41:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-05 16:41:11 +0000
commitd945937682c3757421d1b19e8bd654b28946363d (patch)
tree7a10f0c0fd20ca2e075e0b8b6573b410f96bca8d /net-misc
parentx86 stable wrt bug #353264 (diff)
downloadgentoo-2-d945937682c3757421d1b19e8bd654b28946363d.tar.gz
gentoo-2-d945937682c3757421d1b19e8bd654b28946363d.tar.bz2
gentoo-2-d945937682c3757421d1b19e8bd654b28946363d.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gwget/ChangeLog8
-rw-r--r--net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch29
-rw-r--r--net-misc/gwget/gwget-1.0.4.ebuild11
3 files changed, 43 insertions, 5 deletions
diff --git a/net-misc/gwget/ChangeLog b/net-misc/gwget/ChangeLog
index 82c5d997e4d4..8ef9f831bd5f 100644
--- a/net-misc/gwget/ChangeLog
+++ b/net-misc/gwget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/gwget
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.23 2010/10/14 18:37:06 eva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/ChangeLog,v 1.24 2011/02/05 16:41:11 ssuominen Exp $
+
+ 05 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> gwget-1.0.4.ebuild,
+ +files/gwget-1.0.4-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
14 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org> -gwget-0.99.ebuild,
-gwget-1.0.2.ebuild, -gwget-1.0.3.ebuild:
diff --git a/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..116cf60b9920
--- /dev/null
+++ b/net-misc/gwget/files/gwget-1.0.4-libnotify-0.7.patch
@@ -0,0 +1,29 @@
+--- src/systray.c
++++ src/systray.c
+@@ -6,6 +6,12 @@
+ #include "systray.h"
+ #include "main_window_cb.h"
+
++#ifdef HAVE_NOTIFY
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++#endif
++
+ static GdkPixbuf *systray_load_icon (const gchar *filename);
+ static GdkPixbuf *systray_pixbuf_new_from_file(const gchar *filename);
+ static void systray_clicked(GtkStatusIcon *status_icon,guint button,guint activate_time,gpointer user_data);
+@@ -224,7 +230,12 @@
+ if (!notify_is_initted ())
+ if (!notify_init ("gwget"))
+ return;
+- NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name,NULL);
++ NotifyNotification *notification = notify_notification_new(primary,secondary,icon_name
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ ,NULL);
++#endif
+ notify_notification_show(notification,NULL);
+ #endif
+
diff --git a/net-misc/gwget/gwget-1.0.4.ebuild b/net-misc/gwget/gwget-1.0.4.ebuild
index c6c8066de35b..8744fc1af6f9 100644
--- a/net-misc/gwget/gwget-1.0.4.ebuild
+++ b/net-misc/gwget/gwget-1.0.4.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.4 2010/10/14 17:02:29 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/gwget/gwget-1.0.4.ebuild,v 1.5 2011/02/05 16:41:11 ssuominen Exp $
EAPI="2"
GCONF_DEBUG="no"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="GTK2 WGet Frontend"
HOMEPAGE="http://gnome.org/projects/gwget/"
@@ -40,6 +40,11 @@ pkg_setup() {
--disable-schemas-install"
}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install