summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-08-22 18:28:23 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-08-22 18:28:23 +0000
commitf3bf4d7f3d87ffdc16c0a3a123f0f2443b34343a (patch)
tree58140ca5860360439d7852643fe31c51dd84a8f8 /net-misc
parentadd a WANT_LIBTOOL knob so people can disable the dep if they really know wha... (diff)
downloadgentoo-2-f3bf4d7f3d87ffdc16c0a3a123f0f2443b34343a.tar.gz
gentoo-2-f3bf4d7f3d87ffdc16c0a3a123f0f2443b34343a.tar.bz2
gentoo-2-f3bf4d7f3d87ffdc16c0a3a123f0f2443b34343a.zip
Add net-misc/leechcraft-core
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/leechcraft-core/ChangeLog11
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-0.4.85.ebuild72
-rw-r--r--net-misc/leechcraft-core/leechcraft-core-9999.ebuild66
-rw-r--r--net-misc/leechcraft-core/metadata.xml6
4 files changed, 155 insertions, 0 deletions
diff --git a/net-misc/leechcraft-core/ChangeLog b/net-misc/leechcraft-core/ChangeLog
new file mode 100644
index 000000000000..707f3da4f597
--- /dev/null
+++ b/net-misc/leechcraft-core/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/leechcraft-core
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/ChangeLog,v 1.1 2011/08/22 18:28:23 maksbotan Exp $
+
+*leechcraft-core-9999 (22 Aug 2011)
+*leechcraft-core-0.4.85 (22 Aug 2011)
+
+ 22 Aug 2011; Maxim Koltsov <maksbotan@gentoo.org>
+ +leechcraft-core-0.4.85.ebuild, +leechcraft-core-9999.ebuild, +metadata.xml:
+ Copied net-misc/leechcraft-core from rion-overlay, thanks to 0xd34df00d
+
diff --git a/net-misc/leechcraft-core/leechcraft-core-0.4.85.ebuild b/net-misc/leechcraft-core/leechcraft-core-0.4.85.ebuild
new file mode 100644
index 000000000000..cb54cd0121e5
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-0.4.85.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-0.4.85.ebuild,v 1.1 2011/08/22 18:28:23 maksbotan Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.39
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-script
+ x11-libs/qt-sql[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ if use debug ; then
+ CMAKE_BUILD_TYPE="RelWithDebInfo"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+ local mycmakeargs="-DLEECHCRAFT_VERSION=${PV}
+ -DENABLE_HTTP=OFF
+ -DENABLE_POSHUKU=OFF
+ -DENABLE_TORRENT=OFF
+ -DENABLE_AGGREGATOR=OFF
+ -DENABLE_NUFELLA=OFF
+ -DENABLE_DBUSMANAGER=OFF
+ -DENABLE_DEADLYRICS=OFF
+ -DENABLE_HISTORYHOLDER=OFF
+ -DENABLE_LMP=OFF
+ -DENABLE_NETWORKMONITOR=OFF
+ -DENABLE_SEEKTHRU=OFF
+ -DENABLE_CHATTER=OFF
+ -DENABLE_FTP=OFF
+ -DENABLE_EISKALTDCPP=OFF
+ -DENABLE_YASD=OFF
+ -DENABLE_ANHERO=OFF
+ -DENABLE_KINOTIFY=OFF
+ -DENABLE_VGRABBER=OFF
+ -DENABLE_NEWLIFE=OFF
+ -DENABLE_PYLC=OFF
+ -DENABLE_POC=OFF
+ -DENABLE_AUSCRIE=OFF
+ -DENABLE_SUMMARY=OFF
+ -DENABLE_TABPP=OFF
+ -DENABLE_SECMAN=OFF
+ -DENABLE_QROSP=OFF
+ -DENABLE_POPISHU=OFF
+ -DENABLE_GLANCE=OFF
+ -DENABLE_SHELLOPEN=OFF"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}
diff --git a/net-misc/leechcraft-core/leechcraft-core-9999.ebuild b/net-misc/leechcraft-core/leechcraft-core-9999.ebuild
new file mode 100644
index 000000000000..069c97e35f41
--- /dev/null
+++ b/net-misc/leechcraft-core/leechcraft-core-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/leechcraft-core/leechcraft-core-9999.ebuild,v 1.1 2011/08/22 18:28:23 maksbotan Exp $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://github.com/0xd34df00d/leechcraft.git"
+EGIT_PROJECT="leechcraft-${PV}"
+
+inherit confutils leechcraft
+
+DESCRIPTION="Core of LeechCraft, the modular network client"
+
+SLOT="0"
+KEYWORDS=""
+IUSE="debug +sqlite postgres"
+
+DEPEND=">=dev-libs/boost-1.39
+ x11-libs/qt-core
+ x11-libs/qt-gui
+ x11-libs/qt-script
+ x11-libs/qt-sql[postgres?,sqlite?]"
+RDEPEND="${DEPEND}
+ x11-libs/qt-svg"
+
+pkg_setup() {
+ confutils_require_any postgres sqlite
+}
+
+src_configure() {
+ local mycmakeargs="-DENABLE_HTTP=OFF
+ -DENABLE_POSHUKU=OFF
+ -DENABLE_TORRENT=OFF
+ -DENABLE_AGGREGATOR=OFF
+ -DENABLE_NUFELLA=OFF
+ -DENABLE_DBUSMANAGER=OFF
+ -DENABLE_DEADLYRICS=OFF
+ -DENABLE_HISTORYHOLDER=OFF
+ -DENABLE_LMP=OFF
+ -DENABLE_NETWORKMONITOR=OFF
+ -DENABLE_SEEKTHRU=OFF
+ -DENABLE_CHATTER=OFF
+ -DENABLE_FTP=OFF
+ -DENABLE_EISKALTDCPP=OFF
+ -DENABLE_YASD=OFF
+ -DENABLE_ANHERO=OFF
+ -DENABLE_KINOTIFY=OFF
+ -DENABLE_VGRABBER=OFF
+ -DENABLE_NEWLIFE=OFF
+ -DENABLE_PYLC=OFF
+ -DENABLE_POC=OFF
+ -DENABLE_AUSCRIE=OFF
+ -DENABLE_SUMMARY=OFF
+ -DENABLE_TABPP=OFF
+ -DENABLE_SECMAN=OFF
+ -DENABLE_QROSP=OFF
+ -DENABLE_POPISHU=OFF
+ -DENABLE_GLANCE=OFF
+ -DENABLE_SHELLOPEN=OFF"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry leechcraft "LeechCraft" leechcraft.png
+}
diff --git a/net-misc/leechcraft-core/metadata.xml b/net-misc/leechcraft-core/metadata.xml
new file mode 100644
index 000000000000..4fba8fcb2f64
--- /dev/null
+++ b/net-misc/leechcraft-core/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>leechcraft</herd>
+<longdescription>Core of LeechCraft, the opensource modular network client providing a full-featured web browser, BitTorrent client and much more.</longdescription>
+</pkgmetadata>