summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-02-03 22:40:04 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-02-03 22:40:04 +0000
commitf93e1d29fc51aea1b6f830d4a36dac5f5043283e (patch)
tree745f36b93ff1ba4a2eb21d9348003eea38e6dd98 /net-misc
parentArg, fixing verbosity control for ecpu_check. (diff)
downloadgentoo-2-f93e1d29fc51aea1b6f830d4a36dac5f5043283e.tar.gz
gentoo-2-f93e1d29fc51aea1b6f830d4a36dac5f5043283e.tar.bz2
gentoo-2-f93e1d29fc51aea1b6f830d4a36dac5f5043283e.zip
Fix bug #80298, see changelog for more information
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/zaptel/ChangeLog7
-rw-r--r--net-misc/zaptel/files/zaptel.rc610
2 files changed, 11 insertions, 6 deletions
diff --git a/net-misc/zaptel/ChangeLog b/net-misc/zaptel/ChangeLog
index 0b527a49ec3c..b4ee40b4569b 100644
--- a/net-misc/zaptel/ChangeLog
+++ b/net-misc/zaptel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/zaptel
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.28 2005/02/02 16:26:00 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/ChangeLog,v 1.29 2005/02/03 22:40:04 stkn Exp $
+
+ 03 Feb 2005; Stefan Knoblich <stkn@gentoo.org> files/zaptel.rc6:
+ Fixed zaptel init script (checkconfig returned wrong values, bug #80298),
+ changed config error messages to use eerror. Using return instead of exit
+ if there's no config file, service won't be in state "started" this way.
02 Feb 2005; Chris Bainbridge <chrb@gentoo.org> zaptel-1.0.4.ebuild:
Removed failure when PPP isn't found. The ebuild now gives a warning but
diff --git a/net-misc/zaptel/files/zaptel.rc6 b/net-misc/zaptel/files/zaptel.rc6
index f7e91e11222a..6c5b4f48e547 100644
--- a/net-misc/zaptel/files/zaptel.rc6
+++ b/net-misc/zaptel/files/zaptel.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/files/zaptel.rc6,v 1.2 2004/07/15 00:16:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zaptel/files/zaptel.rc6,v 1.3 2005/02/03 22:40:04 stkn Exp $
depend() {
need net
@@ -9,11 +9,11 @@ depend() {
checkconfig() {
if [ ! -f /etc/zaptel.conf ]; then
- echo "Please create /etc/zaptel.conf!"
- return 0
+ eerror "Please create /etc/zaptel.conf!"
+ return 1
fi
- return 1
+ return 0
}
create_devices() {
@@ -29,7 +29,7 @@ create_devices() {
start() {
- checkconfig || exit 1
+ checkconfig || return 1
if [ ! -d /dev/zap ] && [ "$ZAP_FORCE_CREATE" != "no" ]; then
einfo "Creating zaptel device nodes"