summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-28 21:46:52 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-28 21:46:52 +0000
commitffc650474624fe11210103381a6fd386a31a83cb (patch)
tree0353e64910de386d6e938d31fdcfc743cf9b2219 /net-misc
parentDelete older ebuild. (diff)
downloadgentoo-2-ffc650474624fe11210103381a6fd386a31a83cb.tar.gz
gentoo-2-ffc650474624fe11210103381a6fd386a31a83cb.tar.bz2
gentoo-2-ffc650474624fe11210103381a6fd386a31a83cb.zip
Version bump. Translation updates.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vinagre/ChangeLog8
-rw-r--r--net-misc/vinagre/vinagre-2.30.3.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/net-misc/vinagre/ChangeLog b/net-misc/vinagre/ChangeLog
index dd8dcd5642d6..3e9a64380e81 100644
--- a/net-misc/vinagre/ChangeLog
+++ b/net-misc/vinagre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/vinagre
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.61 2010/09/11 18:59:42 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/ChangeLog,v 1.62 2010/09/28 21:46:52 eva Exp $
+
+*vinagre-2.30.3 (28 Sep 2010)
+
+ 28 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +vinagre-2.30.3.ebuild:
+ Version bump. Translation updates.
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> vinagre-2.30.2.ebuild:
Marked ppc for bug #324077.
diff --git a/net-misc/vinagre/vinagre-2.30.3.ebuild b/net-misc/vinagre/vinagre-2.30.3.ebuild
new file mode 100644
index 000000000000..51df7c08d72e
--- /dev/null
+++ b/net-misc/vinagre/vinagre-2.30.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vinagre/vinagre-2.30.3.ebuild,v 1.1 2010/09/28 21:46:52 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="VNC Client for the GNOME Desktop"
+HOMEPAGE="http://www.gnome.org/projects/vinagre/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="applet avahi +ssh +telepathy test"
+
+# Telepathy-glib version in tarball is wrong:
+# https://bugzilla.gnome.org/show_bug.cgi?id=614716
+RDEPEND=">=dev-libs/glib-2.17
+ dev-libs/dbus-glib
+ >=x11-libs/gtk+-2.16
+ >=gnome-base/gconf-2.16
+ >=net-libs/gtk-vnc-0.3.10
+ >=gnome-base/gnome-keyring-1
+ x11-libs/libX11
+ applet? ( >=gnome-base/gnome-panel-2 )
+ avahi? (
+ >=dev-libs/libxml2-2.6.31
+ >=net-dns/avahi-0.6.22[dbus,gtk] )
+ ssh? (
+ >=dev-libs/libxml2-2.6.31
+ >=x11-libs/vte-0.20 )
+ telepathy? ( >=net-libs/telepathy-glib-0.10 )"
+
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ >=dev-lang/perl-5
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ test? ( ~app-text/docbook-xml-dtd-4.3 )"
+
+DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-scrollkeeper
+ $(use_enable avahi)
+ $(use_enable applet)
+ $(use_enable ssh)
+ $(use_enable telepathy)"
+}
+
+src_install() {
+ gnome2_src_install
+
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+
+ # Remove it's own installation of DOCS that go to $PN instead of $P and aren't ecompressed
+ rm -rf "${D}"/usr/share/doc/vinagre
+}