summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2007-05-02 23:07:03 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2007-05-02 23:07:03 +0000
commit0c96524d2f82501d483303be9bf881b4c8ced6f8 (patch)
tree71b5647b91317af926e790f877a0fe0bed606c4a /net-nds/ldapvi
parentStable on x86, bug #176841. (diff)
downloadgentoo-2-0c96524d2f82501d483303be9bf881b4c8ced6f8.tar.gz
gentoo-2-0c96524d2f82501d483303be9bf881b4c8ced6f8.tar.bz2
gentoo-2-0c96524d2f82501d483303be9bf881b4c8ced6f8.zip
Add patch to fix memory corruption.
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-nds/ldapvi')
-rw-r--r--net-nds/ldapvi/ChangeLog9
-rw-r--r--net-nds/ldapvi/files/1.6-mem-corruption.diff11
-rw-r--r--net-nds/ldapvi/files/digest-ldapvi-1.6-r13
-rw-r--r--net-nds/ldapvi/ldapvi-1.6-r1.ebuild39
4 files changed, 61 insertions, 1 deletions
diff --git a/net-nds/ldapvi/ChangeLog b/net-nds/ldapvi/ChangeLog
index 3978ac5cfd32..7240836f77db 100644
--- a/net-nds/ldapvi/ChangeLog
+++ b/net-nds/ldapvi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-nds/ldapvi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ldapvi/ChangeLog,v 1.11 2007/01/09 18:52:32 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ldapvi/ChangeLog,v 1.12 2007/05/02 23:07:03 hansmi Exp $
+
+*ldapvi-1.6-r1 (03 May 2007)
+
+ 02 May 2007; Michael Hanselmann <hansmi@gentoo.org>
+ +files/1.6-mem-corruption.diff, +ldapvi-1.6-r1.ebuild:
+ Add post-1.6 patch from GIT to fix memory corruption bug (mentioned as
+ "potential FAQ" on ldapvi's website).
09 Jan 2007; Michael Hanselmann <hansmi@gentoo.org> ldapvi-1.6.ebuild:
Stable on ppc, x86.
diff --git a/net-nds/ldapvi/files/1.6-mem-corruption.diff b/net-nds/ldapvi/files/1.6-mem-corruption.diff
new file mode 100644
index 000000000000..12c3baa86e57
--- /dev/null
+++ b/net-nds/ldapvi/files/1.6-mem-corruption.diff
@@ -0,0 +1,11 @@
+--- ldapvi-1.6/misc.c 2006-11-04 13:53:40.000000000 +0100
++++ ldapvi/ldapvi/misc.c 2007-05-03 00:48:21.000000000 +0200
+@@ -277,7 +277,7 @@
+ }
+
+ n = strlen(home);
+- result = xalloc(n + 1 + strlen(name));
++ result = xalloc(n + 1 + strlen(name) + 1);
+ strcpy(result, home);
+ result[n] = '/';
+ strcpy(result + n + 1, name);
diff --git a/net-nds/ldapvi/files/digest-ldapvi-1.6-r1 b/net-nds/ldapvi/files/digest-ldapvi-1.6-r1
new file mode 100644
index 000000000000..3f8f75d06bf5
--- /dev/null
+++ b/net-nds/ldapvi/files/digest-ldapvi-1.6-r1
@@ -0,0 +1,3 @@
+MD5 09d5443bbc349548bbe016da1f734e9e ldapvi-1.6.tar.gz 113138
+RMD160 e730b09b927ae2d1cbc7f2000eae2b2fb6e766a0 ldapvi-1.6.tar.gz 113138
+SHA256 1c4b8de461ede56c674398640b4a380beb7e2180e386eef180e3db2495672876 ldapvi-1.6.tar.gz 113138
diff --git a/net-nds/ldapvi/ldapvi-1.6-r1.ebuild b/net-nds/ldapvi/ldapvi-1.6-r1.ebuild
new file mode 100644
index 000000000000..8cf510e8aa8e
--- /dev/null
+++ b/net-nds/ldapvi/ldapvi-1.6-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ldapvi/ldapvi-1.6-r1.ebuild,v 1.1 2007/05/02 23:07:03 hansmi Exp $
+
+inherit eutils
+
+DESCRIPTION="Manage LDAP entries with a text editor"
+HOMEPAGE="http://www.lichteblau.com/ldapvi/"
+SRC_URI="http://www.lichteblau.com/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="ssl"
+
+DEPEND="
+ sys-libs/ncurses
+ >=net-nds/openldap-2.2
+ dev-libs/popt
+ >=dev-libs/glib-2
+ sys-libs/readline
+ ssl? ( dev-libs/openssl )
+"
+
+src_unpack() {
+ unpack "${A}" || die
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PV}-mem-corruption.diff"
+}
+
+src_compile() {
+ econf $(use_with ssl libcrypto openssl) || die
+ emake || die
+}
+
+src_install() {
+ dobin ldapvi
+ doman ldapvi.1
+}