summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2010-05-04 02:42:38 +0000
committerChristian Ruppert <idl0r@gentoo.org>2010-05-04 02:42:38 +0000
commit9c4f0d7b91657d2243b3f82994d205a28112288f (patch)
treeeda8744eb53caf0dac1f1ffbe116fd6974570de3 /net-nds/nsscache/nsscache-0.8.8.ebuild
parentInitial import. (diff)
downloadgentoo-2-9c4f0d7b91657d2243b3f82994d205a28112288f.tar.gz
gentoo-2-9c4f0d7b91657d2243b3f82994d205a28112288f.tar.bz2
gentoo-2-9c4f0d7b91657d2243b3f82994d205a28112288f.zip
Version bump to 0.8.8, fixes bug 315851.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-nds/nsscache/nsscache-0.8.8.ebuild')
-rw-r--r--net-nds/nsscache/nsscache-0.8.8.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-nds/nsscache/nsscache-0.8.8.ebuild b/net-nds/nsscache/nsscache-0.8.8.ebuild
new file mode 100644
index 000000000000..9374e6363fcf
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.8.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/nsscache/nsscache-0.8.8.ebuild,v 1.1 2010/05/04 02:42:38 idl0r Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit eutils python distutils
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nssdb nsscache"
+
+DEPEND="dev-python/python-ldap"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( sys-auth/libnss-cache )"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.8.3-starttls.patch
+}
+
+src_install() {
+ distutils_src_install
+ insinto /etc
+ doins "${FILESDIR}/nsscache.conf" # overwrite default with working config.
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+ keepdir /var/lib/nsscache
+}