summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2003-07-11 02:57:19 +0000
committerDonny Davies <woodchip@gentoo.org>2003-07-11 02:57:19 +0000
commita8e73504cd65195f8dd57d35b294a786f0edf9f1 (patch)
tree7fb7ca48f42ab8959590a1595dafe3e6ab3c3a1c /net-nds/yp-tools/yp-tools-2.8.ebuild
parentbump. (diff)
downloadgentoo-2-a8e73504cd65195f8dd57d35b294a786f0edf9f1.tar.gz
gentoo-2-a8e73504cd65195f8dd57d35b294a786f0edf9f1.tar.bz2
gentoo-2-a8e73504cd65195f8dd57d35b294a786f0edf9f1.zip
bump.
Diffstat (limited to 'net-nds/yp-tools/yp-tools-2.8.ebuild')
-rw-r--r--net-nds/yp-tools/yp-tools-2.8.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-nds/yp-tools/yp-tools-2.8.ebuild b/net-nds/yp-tools/yp-tools-2.8.ebuild
new file mode 100644
index 000000000000..8146fb392f6d
--- /dev/null
+++ b/net-nds/yp-tools/yp-tools-2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+IUSE="nls"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Network Information Service tools"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${P}.tar.bz2"
+HOMEPAGE="http://www.linux-nis.org/nis"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf="--sysconfdir=/etc/yp"
+ if [ -z "`use nls`" ]
+ then
+ myconf="${myconf} --disable-nls"
+ mkdir intl
+ touch intl/libintl.h
+ export CPPFLAGS="${CPPFLAGS} -I${S}"
+
+ for i in lib/nicknames.c src/*.c
+ do
+ cp ${i} ${i}.orig
+ sed 's:<libintl.h>:<intl/libintl.h>:' \
+ ${i}.orig > ${i}
+ done
+ fi
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING NEWS README THANKS TODO
+ insinto /etc/yp ; doins etc/nicknames
+ # This messes up boot so we remove it
+ rm -d ${D}/bin/ypdomainname
+ rm -d ${D}/bin/nisdomainname
+ rm -d ${D}/bin/domainname
+}