summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2006-08-15 11:17:41 +0000
committerRoy Marples <uberlord@gentoo.org>2006-08-15 11:17:41 +0000
commitfc7be9906eff7dcbecfc11118a2f9b80749cec5d (patch)
treeef47650f4b1aae97c8e036696ea5b020b0647131 /net-nds/ypbind/ypbind-1.19.1-r1.ebuild
parentAssigned to Gentoo VDR Project. (diff)
downloadgentoo-2-fc7be9906eff7dcbecfc11118a2f9b80749cec5d.tar.gz
gentoo-2-fc7be9906eff7dcbecfc11118a2f9b80749cec5d.tar.bz2
gentoo-2-fc7be9906eff7dcbecfc11118a2f9b80749cec5d.zip
Bump to close #129451.
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'net-nds/ypbind/ypbind-1.19.1-r1.ebuild')
-rw-r--r--net-nds/ypbind/ypbind-1.19.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-nds/ypbind/ypbind-1.19.1-r1.ebuild b/net-nds/ypbind/ypbind-1.19.1-r1.ebuild
new file mode 100644
index 000000000000..c90bbcc97d4e
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.19.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.19.1-r1.ebuild,v 1.1 2006/08/15 11:17:41 uberlord Exp $
+
+MY_P=${PN}-mt-${PV}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Multithreaded NIS bind service (ypbind-mt)"
+HOMEPAGE="http://www.linux-nis.org/nis/ypbind-mt/index.html"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
+IUSE="nls slp"
+
+RDEPEND="slp? ( net-libs/openslp )
+ net-nds/yp-tools
+ net-nds/portmap"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=sys-apps/portage-2.0.51"
+
+src_compile() {
+ econf $(use_enable nls) $(use_enable slp)
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+
+ dodoc AUTHORS ChangeLog README THANKS TODO
+
+ insinto /etc
+ newins etc/yp.conf yp.conf.example
+
+ newconfd ${FILESDIR}/ypbind.confd-r1 ypbind
+ newinitd ${FILESDIR}/ypbind.initd ypbind
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /etc/conf.d/ypbind."
+ einfo "If you are using dhcpcd, be sure to add the -Y option to"
+ einfo "dhcpcd_eth0 (or eth1, etc.) to keep dhcpcd from clobbering"
+ einfo "/etc/yp.conf."
+}