summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-10-06 07:00:03 +0000
committerDonny Davies <woodchip@gentoo.org>2001-10-06 07:00:03 +0000
commite43ca93ca79dca1d3677ac43daffd0d09ba097f2 (patch)
tree98eeaf100d396d0e38ba28a8bbc41afe08faf8bb /net-nds
parentypbind rc5/rc6 support (diff)
downloadgentoo-2-e43ca93ca79dca1d3677ac43daffd0d09ba097f2.tar.gz
gentoo-2-e43ca93ca79dca1d3677ac43daffd0d09ba097f2.tar.bz2
gentoo-2-e43ca93ca79dca1d3677ac43daffd0d09ba097f2.zip
rc5/rc6 support
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/ypbind/files/digest-ypbind-1.7-r61
-rw-r--r--[-rwxr-xr-x]net-nds/ypbind/files/ypbind.rc5 (renamed from net-nds/ypbind/files/ypbind)0
-rw-r--r--net-nds/ypbind/files/ypbind.rc639
-rw-r--r--net-nds/ypbind/ypbind-1.7-r1.ebuild34
-rw-r--r--net-nds/ypbind/ypbind-1.7-r6.ebuild31
5 files changed, 87 insertions, 18 deletions
diff --git a/net-nds/ypbind/files/digest-ypbind-1.7-r6 b/net-nds/ypbind/files/digest-ypbind-1.7-r6
new file mode 100644
index 000000000000..f94aa2fa644f
--- /dev/null
+++ b/net-nds/ypbind/files/digest-ypbind-1.7-r6
@@ -0,0 +1 @@
+MD5 d6f98266a18f25337cd6afdb8282af4f ypbind-mt-1.7.tar.gz
diff --git a/net-nds/ypbind/files/ypbind b/net-nds/ypbind/files/ypbind.rc5
index 82de473eecde..82de473eecde 100755..100644
--- a/net-nds/ypbind/files/ypbind
+++ b/net-nds/ypbind/files/ypbind.rc5
diff --git a/net-nds/ypbind/files/ypbind.rc6 b/net-nds/ypbind/files/ypbind.rc6
new file mode 100644
index 000000000000..d735c2644a54
--- /dev/null
+++ b/net-nds/ypbind/files/ypbind.rc6
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+
+depend() {
+ need net portmap
+}
+
+checkconfig() {
+ if [ -z "$YP_DOMAIN" ] ; then
+ eerror "You need to setup YP_DOMAIN /etc/rc.conf"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting ypbind"
+ ypdomainname "$YP_DOMAIN"
+ start-stop-daemon --start --quiet --exec /usr/sbin/ypbind
+ if [ -n "$?" ] ; then
+ notfound=1
+ for i in 0 1 2 3 4 5 6 7 8 9
+ do
+ ypwhich &>/dev/null && { notfound=0; break; }
+ sleep 1
+ done
+ if [ $notfound -eq 1 ] ; then
+ eend 1 "No NIS server found"
+ fi
+ else
+ eend $?
+ fi
+}
+
+stop() {
+ ebegin "Stopping ypbind"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ypbind
+ # Remove binding files, if ypbind "forgets" it
+ rm -f /var/yp/binding/*
+}
diff --git a/net-nds/ypbind/ypbind-1.7-r1.ebuild b/net-nds/ypbind/ypbind-1.7-r1.ebuild
index 8680d4e874ff..4495f7a2703b 100644
--- a/net-nds/ypbind/ypbind-1.7-r1.ebuild
+++ b/net-nds/ypbind/ypbind-1.7-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.7-r1.ebuild,v 1.1 2001/04/21 11:14:54 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.7-r1.ebuild,v 1.2 2001/10/06 07:00:02 woodchip Exp $
A=ypbind-mt-${PV}.tar.gz
S=${WORKDIR}/ypbind-mt-${PV}
@@ -10,24 +10,22 @@ SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
DEPEND="virtual/glibc"
-RDEPEND="virtual/glibc net-nds/yp-tools net-nds/portmap"
-
-src_compile() {
- try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc \
- --mandir=/usr/share/man
- try make
-}
-
-src_install() {
- try make prefix=${D}/usr sysconfdir=${D}/etc \
- mandir=${D}/usr/share/man install
- exeinto /etc/rc.d/init.d
- doexe ${FILESDIR}/ypbind
- dodoc AUTHORS ChangeLog COPYING README THANKS TODO
- insinto /etc
- doins etc/yp.conf
+RDEPEND="virtual/glibc
+ net-nds/yp-tools
+ net-nds/portmap"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
+ assert "bad configure"
+ make || die
}
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+ insinto /etc ; doins etc/yp.conf
-
+ exeinto /etc/rc.d/init.d
+ newexe ${FILESDIR}/ypbind.rc5 ypbind
+}
diff --git a/net-nds/ypbind/ypbind-1.7-r6.ebuild b/net-nds/ypbind/ypbind-1.7-r6.ebuild
new file mode 100644
index 000000000000..bf7872e20db8
--- /dev/null
+++ b/net-nds/ypbind/ypbind-1.7-r6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-nds/ypbind/ypbind-1.7-r6.ebuild,v 1.1 2001/10/06 07:00:03 woodchip Exp $
+
+A=ypbind-mt-${PV}.tar.gz
+S=${WORKDIR}/ypbind-mt-${PV}
+DESCRIPTION="Multithreaded NIS bind service"
+SRC_URI="ftp://ftp.de.kernel.org/pub/linux/utils/net/NIS/"${A}
+HOMEPAGE="http://www.suse.de/~kukuk/nis/ypbind-mt/index.html"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc
+ net-nds/yp-tools
+ net-nds/portmap"
+
+src_compile() {
+ ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc --mandir=/usr/share/man
+ assert "bad configure"
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr sysconfdir=${D}/etc mandir=${D}/usr/share/man install || die
+ dodoc AUTHORS ChangeLog COPYING README THANKS TODO
+
+ insinto /etc ; doins etc/yp.conf
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/ypbind.rc6 ypbind
+}