summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-11-01 01:44:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-11-01 01:44:11 +0000
commite69e680c6d7e43c334774df93606c2e2da5e28d0 (patch)
tree1e62afe7827b8843f78f35cdfc2388e9e1ca05b4 /net-nds
parentAdded to x86. (Manifest recommit) (diff)
downloadgentoo-2-e69e680c6d7e43c334774df93606c2e2da5e28d0.tar.gz
gentoo-2-e69e680c6d7e43c334774df93606c2e2da5e28d0.tar.bz2
gentoo-2-e69e680c6d7e43c334774df93606c2e2da5e28d0.zip
new version.
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/migrationtools/ChangeLog8
-rw-r--r--net-nds/migrationtools/Manifest6
-rw-r--r--net-nds/migrationtools/files/digest-migrationtools-461
-rw-r--r--net-nds/migrationtools/migrationtools-46.ebuild55
4 files changed, 67 insertions, 3 deletions
diff --git a/net-nds/migrationtools/ChangeLog b/net-nds/migrationtools/ChangeLog
index 52a77be54946..cc4ef46f742d 100644
--- a/net-nds/migrationtools/ChangeLog
+++ b/net-nds/migrationtools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-nds/migrationtools
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/migrationtools/ChangeLog,v 1.9 2004/06/25 00:23:09 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/migrationtools/ChangeLog,v 1.10 2004/11/01 01:44:11 robbat2 Exp $
+
+*migrationtools-46 (31 Oct 2004)
+
+ 31 Oct 2004; Robin H. Johnson <robbat2@gentoo.org>
+ +migrationtools-46.ebuild:
+ new version.
*migrationtools-45 (06 Jun 2004)
diff --git a/net-nds/migrationtools/Manifest b/net-nds/migrationtools/Manifest
index f94e0f142e7a..3fcd3c7a8527 100644
--- a/net-nds/migrationtools/Manifest
+++ b/net-nds/migrationtools/Manifest
@@ -1,6 +1,8 @@
-MD5 4d79cc502ac56aa70f7a6956e143a227 ChangeLog 1042
-MD5 e0e5990445daa201b90143d6d8c0a8ec metadata.xml 393
+MD5 656e0dfcd1f0a20db0cd729461b031c8 migrationtools-46.ebuild 1317
MD5 9fcb1b08a078d3b7646d7820e425a376 migrationtools-44-r1.ebuild 665
MD5 f877d27a61f1055a578b3bba5d9ad2b3 migrationtools-45.ebuild 784
+MD5 4d79cc502ac56aa70f7a6956e143a227 ChangeLog 1042
+MD5 e0e5990445daa201b90143d6d8c0a8ec metadata.xml 393
MD5 be251920a61a40bb429028a3e9f8b77d files/digest-migrationtools-44-r1 68
MD5 7f95cbec231a441eeb6638da670e49ad files/digest-migrationtools-45 68
+MD5 f5023a2d2ae00e24e441191d96200baa files/digest-migrationtools-46 68
diff --git a/net-nds/migrationtools/files/digest-migrationtools-46 b/net-nds/migrationtools/files/digest-migrationtools-46
new file mode 100644
index 000000000000..11b7319be823
--- /dev/null
+++ b/net-nds/migrationtools/files/digest-migrationtools-46
@@ -0,0 +1 @@
+MD5 dc80548f76d6aeba2b51b15751e08b21 MigrationTools-46.tar.gz 21069
diff --git a/net-nds/migrationtools/migrationtools-46.ebuild b/net-nds/migrationtools/migrationtools-46.ebuild
new file mode 100644
index 000000000000..7e3654edbcee
--- /dev/null
+++ b/net-nds/migrationtools/migrationtools-46.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nds/migrationtools/migrationtools-46.ebuild,v 1.1 2004/11/01 01:44:11 robbat2 Exp $
+
+inherit eutils
+
+PN0=MigrationTools
+S=${WORKDIR}/${PN0}-${PV}
+DESCRIPTION="PADL migration tools (scripts) for openldap"
+SRC_URI="http://www.padl.com/download/${PN0}-${PV}.tar.gz"
+HOMEPAGE="http://www.padl.com/OSS/MigrationTools.html"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~hppa ~ppc"
+LICENSE="as-is"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-nds/openldap
+ dev-lang/perl"
+
+src_compile() {
+ einfo "nothing to compile; scripts package"
+}
+
+src_install() {
+ dodoc README
+
+ diropts -m0750
+ dodir /usr/share/migrationtools
+ exeinto /usr/share/migrationtools
+ exeopts -m0750
+ for x in ${S}/migrate_*; do
+ [ -f ${x} ] && doexe ${x}
+ done
+
+ diropts -m0750
+ dodir /usr/share/migrationtools/ads
+ exeinto /usr/share/migrationtools/ads
+ exeopts -m0750
+ for x in ${S}/ads/migrate_*; do
+ [ -f ${x} ] && doexe ${x}
+ done
+}
+
+pkg_postinst() {
+ draw_line " "
+ einfo "The scripts are installed at /usr/share/migrationtools."
+ einfo ""
+ einfo "Please edit /usr/share/migrationtools/migrate_common.ph"
+ einfo "and/or /usr/share/migrationtools/ads/migrate_common.ph"
+ einfo "to start."
+ draw_line " "
+}
+