summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-11-14 10:51:42 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-11-14 10:51:42 +0000
commitf5ffab22b7ff99da7eeebd6c8f0e309cd26924dc (patch)
tree334b5b5930bb2c3d01930d009c75020ff28f9914 /net-nds
parentWindowMaker removed as a DEPEND (diff)
downloadgentoo-2-f5ffab22b7ff99da7eeebd6c8f0e309cd26924dc.tar.gz
gentoo-2-f5ffab22b7ff99da7eeebd6c8f0e309cd26924dc.tar.bz2
gentoo-2-f5ffab22b7ff99da7eeebd6c8f0e309cd26924dc.zip
nls fix
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/yp-tools/yp-tools-2.7-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/net-nds/yp-tools/yp-tools-2.7-r1.ebuild b/net-nds/yp-tools/yp-tools-2.7-r1.ebuild
index 07db719bcbd6..b1c536b7259a 100644
--- a/net-nds/yp-tools/yp-tools-2.7-r1.ebuild
+++ b/net-nds/yp-tools/yp-tools-2.7-r1.ebuild
@@ -1,21 +1,22 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/yp-tools/yp-tools-2.7-r1.ebuild,v 1.3 2002/10/04 06:16:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/yp-tools/yp-tools-2.7-r1.ebuild,v 1.4 2002/11/14 10:51:42 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="NIS Tools"
SRC_URI="ftp://ftp.kernel.org/pub/linux/utils/net/NIS/${P}.tar.bz2"
HOMEPAGE="http://www.linux-nis.org/nis"
-DEPEND="virtual/glibc"
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc sparc64"
+DEPEND="virtual/glibc"
+
src_compile() {
local myconf="--sysconfdir=/etc/yp"
- use nls || ( \
+ if [ -z "`use nls`" ]
+ then
myconf="${myconf} --disable-nls"
mkdir intl
touch intl/libintl.h
@@ -27,8 +28,8 @@ src_compile() {
sed 's:<libintl.h>:<intl/libintl.h>:' \
${i}.orig > ${i}
done
- )
- econf ${myconf} || die
+ fi
+ econf ${myconf}
make || die
}