summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2003-04-02 16:29:17 +0000
committerDan Armak <danarmak@gentoo.org>2003-04-02 16:29:17 +0000
commit8865235f343771ba4f491534f260a2087696d0e1 (patch)
treec8c697896da08051d66dbb96790d0f7734054d1a /net-news/newspost/newspost-2.1.ebuild
parentnew version, closes #15544 (diff)
downloadgentoo-2-8865235f343771ba4f491534f260a2087696d0e1.tar.gz
gentoo-2-8865235f343771ba4f491534f260a2087696d0e1.tar.bz2
gentoo-2-8865235f343771ba4f491534f260a2087696d0e1.zip
new upstream version, closes #16037
Diffstat (limited to 'net-news/newspost/newspost-2.1.ebuild')
-rw-r--r--net-news/newspost/newspost-2.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-news/newspost/newspost-2.1.ebuild b/net-news/newspost/newspost-2.1.ebuild
new file mode 100644
index 000000000000..718f9457099c
--- /dev/null
+++ b/net-news/newspost/newspost-2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/newspost/newspost-2.1.ebuild,v 1.1 2003/04/02 16:29:17 danarmak Exp $
+
+DESCRIPTION="a usenet binary autoposter for unix"
+HOMEPAGE="http://newspost.unixcab.org/"
+SRC_URI="http://newspost.unixcab.org/download/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+# NOTE: This package should work on PPC but not tested!
+# It also has a solaris make file but we don't do solaris.
+# but it should mean that it is 64bit clean.
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/glibc sys-devel/gcc"
+RDEPEND="sys-libs/glibc"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+
+ unpack $A
+ cd $S
+ cp Makefile Makefile.orig
+ sed -e "s:OPT_FLAGS = :OPT_FLAGS = ${CFLAGS}#:" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install () {
+ dobin newspost
+ doman man/man1/newspost.1
+ dodoc README
+ dodoc CHANGES
+ dodoc COPYING
+}