summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-08-19 20:11:10 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-08-19 20:11:10 +0000
commitf43bdda8a44010d3c12d61be079ac1ac46814bf0 (patch)
tree5e922be92ea6b2550d4dec48e1353316b1f9fad5 /net-news/pan/pan-0.13.0.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-f43bdda8a44010d3c12d61be079ac1ac46814bf0.tar.gz
gentoo-2-f43bdda8a44010d3c12d61be079ac1ac46814bf0.tar.bz2
gentoo-2-f43bdda8a44010d3c12d61be079ac1ac46814bf0.zip
New stable version, removed debug stuff, updated deps.
Diffstat (limited to 'net-news/pan/pan-0.13.0.ebuild')
-rw-r--r--net-news/pan/pan-0.13.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-news/pan/pan-0.13.0.ebuild b/net-news/pan/pan-0.13.0.ebuild
new file mode 100644
index 000000000000..484076fafd39
--- /dev/null
+++ b/net-news/pan/pan-0.13.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-news/pan/pan-0.13.0.ebuild,v 1.1 2002/08/19 20:11:10 stroke Exp $
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/SOURCE/${P}.tar.bz2"
+HOMEPAGE="http://pan.rebelbase.com"
+
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc"
+SLOT="0"
+
+DEPEND=">=dev-libs/glib-2.0.6-r1
+ >=x11-libs/gtk+-2.0.6-r1
+ >=dev-libs/libxml2-2.4.23
+ dev-libs/libunicode
+ spell? ( >=app-text/gtkspell-2.0.0 )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+export CONFIG_PROTECT_MASK="/etc/gconf"
+
+src_compile() {
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+ use spell || myconf="$myconf --disable-gtkspell"
+
+ # gtkspell breaks things now.
+ myconf="${myconf} --disable-gtkspell"
+ econf --enable-debug=yes $myconf || die "Configure failure"
+
+ emake || die "Compilation failure"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING CREDITS INSTALL NEWS README TODO
+}