summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-19 20:59:21 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-19 20:59:21 +0000
commitbd39f4f46f9d4bd8d61741488a18d3c9cf32d59c (patch)
tree3ff2993495bf5334e4c8ef0c580533544dd47ca9 /net-news
parentAdded SLOT andn LICENSE (diff)
downloadgentoo-2-bd39f4f46f9d4bd8d61741488a18d3c9cf32d59c.tar.gz
gentoo-2-bd39f4f46f9d4bd8d61741488a18d3c9cf32d59c.tar.bz2
gentoo-2-bd39f4f46f9d4bd8d61741488a18d3c9cf32d59c.zip
New package. Fixes #4041. Submitted by Simon Forman
Diffstat (limited to 'net-news')
-rw-r--r--net-news/nget/ChangeLog13
-rw-r--r--net-news/nget/files/digest-nget-0.19.11
-rw-r--r--net-news/nget/nget-0.19.1.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/net-news/nget/ChangeLog b/net-news/nget/ChangeLog
new file mode 100644
index 000000000000..15504e67279d
--- /dev/null
+++ b/net-news/nget/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-news/nget
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-news/nget/ChangeLog,v 1.1 2002/07/19 20:59:21 rphillips Exp $
+
+*nget-0.19.1 (19 Jul 2002)
+
+ 19 Jul 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-news/nget/files/digest-nget-0.19.1 b/net-news/nget/files/digest-nget-0.19.1
new file mode 100644
index 000000000000..c4f359587043
--- /dev/null
+++ b/net-news/nget/files/digest-nget-0.19.1
@@ -0,0 +1 @@
+MD5 09427aff2dccdb36df7915dda7ee843f nget-0.19.1+uulib.tar.gz 317590
diff --git a/net-news/nget/nget-0.19.1.ebuild b/net-news/nget/nget-0.19.1.ebuild
new file mode 100644
index 000000000000..f925ffd562ca
--- /dev/null
+++ b/net-news/nget/nget-0.19.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-news/nget/nget-0.19.1.ebuild,v 1.1 2002/07/19 20:59:21 rphillips Exp $
+
+NPVER=20011209
+S=${WORKDIR}/${P}
+DESCRIPTION="Network utility to retrieve files from the WWW"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/nget/nget-0.19.1+uulib.tar.gz"
+HOMEPAGE="http://nget.sourceforge.net/"
+RDEPEND="virtual/glibc"
+DEPEND="$RDEPEND dev-libs/popt"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${P}+uulib.tar.gz
+}
+
+src_compile() {
+ local myconf
+# use nls || myconf="--disable-nls"
+# use ssl && myconf="${myconf} --with-ssl"
+# use ssl || myconf="${myconf} --without-ssl --disable-opie --disable-digest"
+# [ -z "$DEBUG" ] && myconf="${myconf} --disable-debug"
+# use ssl && CFLAGS="${CFLAGS} -I/usr/include/openssl"
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info --mandir=/usr/share/man $myconf || die
+ if use static; then
+ make LDFLAGS="--static" || die
+ else
+ make || die
+ fi
+}
+
+src_install() {
+ if use build || use bootcd; then
+ insinto /usr
+ dobin ${S}/src/nget
+ return
+ fi
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info install || die
+ dodoc COPYING ChangeLog FAQ README TODO
+}