summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-25 11:24:06 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-09-25 11:24:06 +0000
commit46b24e599c01e52499553f86d84f9ddc9d59e6d1 (patch)
tree7fd3a63facd6fca9c0d9171e3b6d8b969c782044 /net-nntp/kwooty/kwooty-0.7.2.ebuild
parentAdd patch to fix compilation on Darwin prior OS X Lion, bug #382337 (diff)
downloadgentoo-2-46b24e599c01e52499553f86d84f9ddc9d59e6d1.tar.gz
gentoo-2-46b24e599c01e52499553f86d84f9ddc9d59e6d1.tar.bz2
gentoo-2-46b24e599c01e52499553f86d84f9ddc9d59e6d1.zip
Version bump
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'net-nntp/kwooty/kwooty-0.7.2.ebuild')
-rw-r--r--net-nntp/kwooty/kwooty-0.7.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-nntp/kwooty/kwooty-0.7.2.ebuild b/net-nntp/kwooty/kwooty-0.7.2.ebuild
new file mode 100644
index 000000000000..771f8e41e649
--- /dev/null
+++ b/net-nntp/kwooty/kwooty-0.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/kwooty/kwooty-0.7.2.ebuild,v 1.1 2011/09/25 11:24:06 dilfridge Exp $
+
+EAPI=4
+
+KDE_LINGUAS="cs de"
+inherit kde4-base
+
+DESCRIPTION="Friendly nzb linux usenet binary client"
+HOMEPAGE="http://sourceforge.net/projects/kwooty/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="$(add_kdebase_dep libkworkspace)
+ $(add_kdebase_dep solid)"
+RDEPEND="${DEPEND}
+ app-arch/unrar
+ app-arch/par2cmdline"
+
+DOCS="README.txt"
+
+src_prepare() {
+ sed -i \
+ -e 's:${KDE4WORKSPACE_SOLIDCONTROL_LIBS}:solidcontrol:' \
+ src/CMakeLists.txt || die
+ kde4-base_src_prepare
+}