summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-11-19 19:12:21 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-11-19 19:12:21 +0000
commitfff5084ac2d7944ae651d680692ac1cf03b01927 (patch)
tree8bbcc456e83c73a42c6bcd27538acef5e063823f /net-nntp
parentStable for HPPA (bug #195173). (diff)
downloadgentoo-2-fff5084ac2d7944ae651d680692ac1cf03b01927.tar.gz
gentoo-2-fff5084ac2d7944ae651d680692ac1cf03b01927.tar.bz2
gentoo-2-fff5084ac2d7944ae651d680692ac1cf03b01927.zip
Added a patch kindly provided by ChazeFroy to fix our bug 199581 (upstream: http://bugzilla.gnome.org/show_bug.cgi?id=477860) with respect to recent gtk+ versions.
(Portage version: 2.1.3.19)
Diffstat (limited to 'net-nntp')
-rw-r--r--net-nntp/pan/ChangeLog10
-rw-r--r--net-nntp/pan/files/digest-pan-0.132-r13
-rw-r--r--net-nntp/pan/files/load-pixbuf-in-1024-byte-chunks.diff21
-rw-r--r--net-nntp/pan/pan-0.132-r1.ebuild42
4 files changed, 75 insertions, 1 deletions
diff --git a/net-nntp/pan/ChangeLog b/net-nntp/pan/ChangeLog
index c920c4e9ea87..306bc19598c6 100644
--- a/net-nntp/pan/ChangeLog
+++ b/net-nntp/pan/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-nntp/pan
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.49 2007/08/13 21:50:39 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/ChangeLog,v 1.50 2007/11/19 19:12:20 philantrop Exp $
+
+*pan-0.132-r1 (19 Nov 2007)
+
+ 19 Nov 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/load-pixbuf-in-1024-byte-chunks.diff, +pan-0.132-r1.ebuild:
+ Added a patch kindly provided by ChazeFroy to fix our bug 199581 (upstream:
+ http://bugzilla.gnome.org/show_bug.cgi?id=477860) with respect to recent
+ gtk+ versions.
13 Aug 2007; Tobias Scherbaum <dertobi123@gentoo.org>
pan-0.14.2.91-r2.ebuild:
diff --git a/net-nntp/pan/files/digest-pan-0.132-r1 b/net-nntp/pan/files/digest-pan-0.132-r1
new file mode 100644
index 000000000000..c00523b289b8
--- /dev/null
+++ b/net-nntp/pan/files/digest-pan-0.132-r1
@@ -0,0 +1,3 @@
+MD5 2c337dbd5105b7772a4326d549a45638 pan-0.132.tar.bz2 1466359
+RMD160 8e9bd2b2851cf1794b975ed31317e9ce837a2851 pan-0.132.tar.bz2 1466359
+SHA256 8695cf02f7664ac9aae39fc3edfc513f9856fb0fe19aa19cae006737994da577 pan-0.132.tar.bz2 1466359
diff --git a/net-nntp/pan/files/load-pixbuf-in-1024-byte-chunks.diff b/net-nntp/pan/files/load-pixbuf-in-1024-byte-chunks.diff
new file mode 100644
index 000000000000..9faeb4fc6037
--- /dev/null
+++ b/net-nntp/pan/files/load-pixbuf-in-1024-byte-chunks.diff
@@ -0,0 +1,21 @@
+diff -ru pan-0.132/pan/gui/body-pane.cc pan-0.132.hacked/pan/gui/body-pane.cc
+--- pan-0.132/pan/gui/body-pane.cc 2007-08-01 12:00:00.000000000 -0500
++++ pan-0.132.hacked/pan/gui/body-pane.cc 2007-10-09 00:30:43.000000000 -0500
+@@ -815,8 +815,15 @@
+ GMimeStream * mem_stream (g_mime_stream_mem_new ());
+ g_mime_data_wrapper_write_to_stream (wrapper, mem_stream);
+ GByteArray * buffer (GMIME_STREAM_MEM(mem_stream)->buffer);
+- if (buffer->len)
+- gdk_pixbuf_loader_write (l, (guchar*)buffer->data, buffer->len, &err);
++ size_t c = 0;
++ size_t left = buffer->len;
++ while (left > 0)
++ {
++ size_t len = left < 1024 ? left : 1024; /* KLUDGE magic number */
++ gdk_pixbuf_loader_write (l, ((guchar*)buffer->data) + c, len, &err);
++ left -= len;
++ c += len;
++ }
+ g_object_unref (mem_stream);
+ g_object_unref (wrapper);
+ }
diff --git a/net-nntp/pan/pan-0.132-r1.ebuild b/net-nntp/pan/pan-0.132-r1.ebuild
new file mode 100644
index 000000000000..e76f2b93bfa5
--- /dev/null
+++ b/net-nntp/pan/pan-0.132-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-nntp/pan/pan-0.132-r1.ebuild,v 1.1 2007/11/19 19:12:20 philantrop Exp $
+
+inherit eutils
+
+DESCRIPTION="A newsreader for the Gnome2 desktop"
+HOMEPAGE="http://pan.rebelbase.com/"
+SRC_URI="http://pan.rebelbase.com/download/releases/${PV}/source/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="spell"
+
+RDEPEND=">=dev-libs/glib-2.4.0
+ >=x11-libs/gtk+-2.4.0
+ >=dev-libs/libpcre-5.0
+ >=dev-libs/gmime-2.1.9
+ spell? ( >=app-text/gtkspell-2.0.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.21
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/load-pixbuf-in-1024-byte-chunks.diff
+}
+
+src_compile() {
+ econf $(use_with spell gtkspell) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+}