summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-05-20 23:22:39 +0000
committerVlastimil Babka <caster@gentoo.org>2007-05-20 23:22:39 +0000
commitcb575f59b60afb1f3f50398779ac3c38eab1d66a (patch)
tree0f39726d51168a89d33ced58065603e92776976e /net-p2p/azureus
parentStable for HPPA (bug #175465). (diff)
downloadgentoo-2-cb575f59b60afb1f3f50398779ac3c38eab1d66a.tar.gz
gentoo-2-cb575f59b60afb1f3f50398779ac3c38eab1d66a.tar.bz2
gentoo-2-cb575f59b60afb1f3f50398779ac3c38eab1d66a.zip
Don't force ecj compiler as requested in bug #145338. Go back to using 256m limit for amd64 and 128m for x86. Should now work that ANT_OPTS is exported.
(Portage version: 2.1.2.7)
Diffstat (limited to 'net-p2p/azureus')
-rw-r--r--net-p2p/azureus/ChangeLog7
-rw-r--r--net-p2p/azureus/azureus-2.5.0.4-r1.ebuild9
2 files changed, 11 insertions, 5 deletions
diff --git a/net-p2p/azureus/ChangeLog b/net-p2p/azureus/ChangeLog
index 1e55df52d223..bf3993c0fa5c 100644
--- a/net-p2p/azureus/ChangeLog
+++ b/net-p2p/azureus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/azureus
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.46 2007/04/08 00:50:38 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/ChangeLog,v 1.47 2007/05/20 23:22:39 caster Exp $
+
+ 20 May 2007; Vlastimil Babka <caster@gentoo.org>
+ azureus-2.5.0.4-r1.ebuild:
+ Don't force ecj compiler as requested in bug #145338. Go back to using 256m
+ limit for amd64 and 128m for x86. Should now work that ANT_OPTS is exported.
08 Apr 2007; Joseph Jezak <josejx@gentoo.org> azureus-2.5.0.4.ebuild,
azureus-2.5.0.4-r1.ebuild:
diff --git a/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild b/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild
index c18cc22301df..9981e0e2c0cc 100644
--- a/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild
+++ b/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild,v 1.3 2007/04/08 00:50:38 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/azureus/azureus-2.5.0.4-r1.ebuild,v 1.4 2007/05/20 23:22:39 caster Exp $
inherit eutils fdo-mime java-pkg-2 java-ant-2
@@ -27,7 +27,6 @@ DEPEND="${RDEPEND}
>=virtual/jdk-1.5
dev-util/desktop-file-utils
>=dev-java/ant-core-1.6.2
- || ( =dev-java/eclipse-ecj-3.2* =dev-java/eclipse-ecj-3.1* )
source? ( app-arch/zip )
>=app-arch/unzip-5.0"
@@ -63,8 +62,10 @@ src_unpack() {
}
src_compile() {
- # javac likes to run out of memory during build... use ecj instead
- java-pkg_force-compiler ecj-3.2 ecj-3.1
+ # we started to force ecj because -Xmx seemed to have no effect but that
+ # was because of ANT_OPTS not exported. Bug #145338
+ use x86 && export ANT_OPTS="-Xmx128m"
+ use amd64 && export ANT_OPTS="-Xmx256m"
eant ${ant_extra_opts} jar
}