summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-07-15 02:06:54 +0000
committerJon Hood <squinky86@gentoo.org>2004-07-15 02:06:54 +0000
commit98acd7b49bcf070efb06c63bc613713004e38aaf (patch)
tree82a0a40534c0a03d0dfdb047e6f1c4b96bee0620 /net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild
parentUpdated package app-sci/emboss (Manifest recommit) (diff)
downloadgentoo-2-98acd7b49bcf070efb06c63bc613713004e38aaf.tar.gz
gentoo-2-98acd7b49bcf070efb06c63bc613713004e38aaf.tar.bz2
gentoo-2-98acd7b49bcf070efb06c63bc613713004e38aaf.zip
readding due to problems with move
Diffstat (limited to 'net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild')
-rw-r--r--net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild
new file mode 100644
index 000000000000..b3b471841ead
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.8.11.ebuild,v 1.8 2004/07/15 02:06:54 squinky86 Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="TheShad0w's experimental BitTorrent client"
+HOMEPAGE="http://www.bittornado.com/"
+SRC_URI="http://e.scarywater.net/bt/download/BitTorrent-experimental-S-${PV}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxpython-2.2 )
+ >=dev-lang/python-2.0
+ !virtual/bittorrent"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+S="${WORKDIR}/bittorrent-CVS-shadowsclient"
+PIXMAPLOC="/usr/share/pixmaps/bittorrent"
+
+src_unpack() {
+ unpack ${A}
+ sed -i "s:os.path.abspath(os.path.dirname(sys.argv\[0\])):\"${PIXMAPLOC}/\":" ${S}/btdownloadgui.py
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ dodir ${PIXMAPLOC}
+ insinto ${PIXMAPLOC}
+ doins *.ico *.gif
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ rm ${D}/usr/bin/*gui.py
+ fi
+}