summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Dashjr <luke-jr@gentoo.org>2003-09-12 14:12:52 +0000
committerLuke Dashjr <luke-jr@gentoo.org>2003-09-12 14:12:52 +0000
commitb53523049c98c578c8ecb0f15c3df04153014672 (patch)
tree86356046b4cedc73dc7bfa42ab5d28cb787f9ca6 /net-p2p/bittorrent-theshadow
parentFixed bug 28438 (diff)
downloadgentoo-2-b53523049c98c578c8ecb0f15c3df04153014672.tar.gz
gentoo-2-b53523049c98c578c8ecb0f15c3df04153014672.tar.bz2
gentoo-2-b53523049c98c578c8ecb0f15c3df04153014672.zip
Fixed bug 28438
Diffstat (limited to 'net-p2p/bittorrent-theshadow')
-rw-r--r--net-p2p/bittorrent-theshadow/ChangeLog8
-rw-r--r--net-p2p/bittorrent-theshadow/Manifest4
-rw-r--r--net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.6-r1.ebuild74
-rw-r--r--net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7.6-r11
4 files changed, 84 insertions, 3 deletions
diff --git a/net-p2p/bittorrent-theshadow/ChangeLog b/net-p2p/bittorrent-theshadow/ChangeLog
index de1bc7e2c701..ad58c8e89b94 100644
--- a/net-p2p/bittorrent-theshadow/ChangeLog
+++ b/net-p2p/bittorrent-theshadow/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for net-p2p/bittorrent-theshadow
# Copyright 2000-2003 Gentoo Technologies, Inc. and Luke-Jr
# Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-theshadow/ChangeLog,v 1.7 2003/09/11 22:50:52 luke-jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-theshadow/ChangeLog,v 1.8 2003/09/12 14:12:41 luke-jr Exp $
+
+*bittorrent-theshadow-5.7.6-r1 (12 Sep 2003)
+
+ 12 Sep 2003; Luke-Jr <luke-jr@gentoo.org>
+ bittorrent-theshadow-5.7.6-r1.ebuild:
+ Fixed bug 28438
*bittorrent-theshadow-5.7.6 (11 Sep 2003)
diff --git a/net-p2p/bittorrent-theshadow/Manifest b/net-p2p/bittorrent-theshadow/Manifest
index 1fe6ee0459a9..83fd562348a6 100644
--- a/net-p2p/bittorrent-theshadow/Manifest
+++ b/net-p2p/bittorrent-theshadow/Manifest
@@ -1,5 +1,5 @@
-MD5 2e59b3fc2233ea1ff45e7c3721cbbb7d bittorrent-theshadow-5.7.6-r1.ebuild 2191
-MD5 8c3598dd567b3a47a686e3446f732b0a ChangeLog 1086
+MD5 21d431e5d7cd74f9ed00334c9ebbe1db bittorrent-theshadow-5.7.6-r1.ebuild 2230
+MD5 21b556e648ca7c21ab9d91631199f08f ChangeLog 1235
MD5 904bed341f701bb04706bc167dfed521 bittorrent-theshadow-5.7.ebuild 1717
MD5 db35ce269e6cf311e1417dae29154cb4 bittorrent-theshadow-5.7.6.ebuild 1850
MD5 4da0f64e13bc339ef3818a4df2c84fef files/digest-bittorrent-theshadow-5.7.6 80
diff --git a/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.6-r1.ebuild b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.6-r1.ebuild
new file mode 100644
index 000000000000..149682a048d4
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.6-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc., Okrain Genady (^Mafteah), and Luke-Jr
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent-theshadow/bittorrent-theshadow-5.7.6-r1.ebuild,v 1.1 2003/09/12 14:12:41 luke-jr Exp $
+
+inherit distutils
+
+S=${WORKDIR}/BitTorrent-CVS-shadowsclient
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://home.elp.rr.com/tur/BitTorrent-experimental-S-${PV}.zip"
+HOMEPAGE="http://bt.degreez.net/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+IUSE="X psyco nopsyco"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !net-p2p/bittorrent
+ !virtual/bittorrent
+ psyco? ( dev-python/psyco )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+
+PROVIDE="virtual/bittorrent"
+
+mydoc="FAQ.txt README.txt LICENSE.txt"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ for f in `find -name \*.txt -or -name \*.py`; do
+ tr -d '\r' < "$f" |
+ sed "s/PSYCO.psyco/$((`use nopsyco&&echo -1`+1))/g" |
+ grep -v 'import PSYCO' |
+ sed 's/basepath=os\.path\.abspath(os\.path\.dirname(sys\.argv\[0\]))/basepath="\/usr\/share\/pixmaps\/bittorrent"/' |
+ sed 's/wxConfig(\"BitTorrent\")/wxConfig(\"BitTorrent\", style=wxCONFIG_USE_LOCAL_FILE)/' \
+ > "$f".new
+ mv "$f".new "$f"
+ done
+}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ dodir /usr/share/pixmaps/bittorrent
+ for f in *.{ico,gif}; do
+ install -m 644 "$f" "${D}/usr/share/pixmaps/bittorrent/$f"
+ done
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
diff --git a/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7.6-r1 b/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7.6-r1
new file mode 100644
index 000000000000..32d1253a776b
--- /dev/null
+++ b/net-p2p/bittorrent-theshadow/files/digest-bittorrent-theshadow-5.7.6-r1
@@ -0,0 +1 @@
+MD5 38903dc0e957fb6900b20ccd2e52fb78 BitTorrent-experimental-S-5.7.6.zip 142817