summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-09-25 07:38:02 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-09-25 07:38:02 +0000
commitfdb5a74d7956586a7c5ca581019833ff60edf89c (patch)
treecfa1a31f2c68d5efe9b087aadd427019ae84d75b /net-p2p/bittorrent
parentVersion bump (diff)
downloadgentoo-2-fdb5a74d7956586a7c5ca581019833ff60edf89c.tar.gz
gentoo-2-fdb5a74d7956586a7c5ca581019833ff60edf89c.tar.bz2
gentoo-2-fdb5a74d7956586a7c5ca581019833ff60edf89c.zip
Version bump
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog8
-rw-r--r--net-p2p/bittorrent/Manifest5
-rw-r--r--net-p2p/bittorrent/bittorrent-3.3.ebuild62
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-3.31
-rw-r--r--net-p2p/bittorrent/metadata.xml9
5 files changed, 82 insertions, 3 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index ab2304e104a4..43b758c62753 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.15 2003/08/10 21:38:18 luke-jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.16 2003/09/25 07:37:56 phosphan Exp $
+
+*bittorrent-3.3 (25 Sep 2003)
+
+ 25 Sep 2003; Patrick Kursawe <phosphan@gentoo.org> bittorrent-3.3.ebuild,
+ metadata.xml:
+ Version bump as requested in bug 29556
*bittorrent-3.2.1b-r4 (10 Aug 2003)
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index c99f68344f5a..a69bd9a08451 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -2,10 +2,11 @@ MD5 78ff5f95fa1fc16340582e6793a77f62 bittorrent-3.2.1b-r2.ebuild 1441
MD5 6729b30318083966fa83daf20b6cbcd5 bittorrent-3.2.1b.ebuild 1188
MD5 6b4dd8a0972596ff8edca38823c3fdc2 bittorrent-3.2.1b-r4.ebuild 1649
MD5 93d489712317173e2b9ce797a78c3d4c bittorrent-3.2.1b-r1.ebuild 1267
-MD5 6b4dd8a0972596ff8edca38823c3fdc2 bittorrent-3.3.ebuild 1649
+MD5 7d7927f2b80b33aa4c83e2078bdc5e75 bittorrent-3.3.ebuild 1688
MD5 407711b13084d7c3b015522966b9ec5e bittorrent-3.2.1b-r3.ebuild 1598
MD5 754d49e31f71fe1da1b1774cb4ff75a9 bittorrent-3.2.1.ebuild 1186
-MD5 8950bda8f310b6f634ee56549f78b260 ChangeLog 2392
+MD5 3a54b34587841975a9c0c6076ce22970 ChangeLog 2558
+MD5 bf40bbcf5db22e1339e15d961d81ac88 metadata.xml 324
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b 69
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b-r1 69
MD5 18e4d423bad1434f67f294f131f2e181 files/digest-bittorrent-3.2.1b-r2 69
diff --git a/net-p2p/bittorrent/bittorrent-3.3.ebuild b/net-p2p/bittorrent/bittorrent-3.3.ebuild
new file mode 100644
index 000000000000..84841dee7bb2
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-3.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-3.3.ebuild,v 1.1 2003/09/25 07:37:57 phosphan Exp $
+
+inherit distutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="BitTorrent is a tool for distributing files via a distributed network of nodes"
+SRC_URI="http://bitconjurer.org/BitTorrent/${MY_P}.tar.gz"
+HOMEPAGE="http://bitconjurer.org/BitTorrent"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+
+IUSE="X"
+
+RDEPEND="X? ( >=dev-python/wxPython-2.2 )
+ >=dev-lang/python-2.1
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4.0.5"
+PROVIDE="virtual/bittorrent"
+
+
+DOCS="credits.txt"
+
+
+# Stats patch not yet available
+#src_unpack() {
+# unpack ${A}
+# cd ${S}
+# patch -p1 < ${FILESDIR}/bittorrent-stats-${PV}.patch || die "patch failed"
+#}
+
+src_install() {
+ distutils_src_install
+ if ! use X; then
+ rm ${D}/usr/bin/*gui.py
+ fi
+ dohtml redirdonate.html
+ dodir etc
+ cp -a /etc/mailcap ${D}/etc/
+
+ MAILCAP_STRING="application/x-bittorrent; /usr/bin/btdownloadgui.py '%s'; test=test -n \"\$DISPLAY\""
+
+ if use X; then
+ if [ -n "`grep 'application/x-bittorrent' ${D}/etc/mailcap`" ]; then
+ # replace bittorrent entry if it already exists
+ einfo "updating bittorrent mime info"
+ sed -i "s,application/x-bittorrent;.*,${MAILCAP_STRING}," ${D}/etc/mailcap
+ else
+ # add bittorrent entry if it doesn't exist
+ einfo "adding bittorrent mime info"
+ echo "${MAILCAP_STRING}" >> ${D}/etc/mailcap
+ fi
+ else
+ # get rid of any reference to the not-installed gui version
+ sed -i '/btdownloadgui/d' ${D}/etc/mailcap
+ fi
+}
+
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-3.3 b/net-p2p/bittorrent/files/digest-bittorrent-3.3
new file mode 100644
index 000000000000..c5ce753910fb
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-3.3
@@ -0,0 +1 @@
+MD5 1ecf1fc40b4972470313f9ae728206e8 BitTorrent-3.3.tar.gz 168628
diff --git a/net-p2p/bittorrent/metadata.xml b/net-p2p/bittorrent/metadata.xml
new file mode 100644
index 000000000000..d63121ad476f
--- /dev/null
+++ b/net-p2p/bittorrent/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>phosphan@gentoo.org</email>
+ <description>Version bumping and patching, not using. Package is free for adoption.</description>
+</maintainer>
+</pkgmetadata>