summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2005-07-13 18:03:07 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2005-07-13 18:03:07 +0000
commitc5522f19042bba9004917ec47019b18310fcb49f (patch)
tree109c55e0d63df0e82f81b62a30375f1c77f95cc2 /net-p2p/dc-qt/dc-qt-0.1.2.ebuild
parent#98736: version bump (diff)
downloadgentoo-2-c5522f19042bba9004917ec47019b18310fcb49f.tar.gz
gentoo-2-c5522f19042bba9004917ec47019b18310fcb49f.tar.bz2
gentoo-2-c5522f19042bba9004917ec47019b18310fcb49f.zip
Added xine as a optional dependency, bug #79766
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-p2p/dc-qt/dc-qt-0.1.2.ebuild')
-rw-r--r--net-p2p/dc-qt/dc-qt-0.1.2.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/net-p2p/dc-qt/dc-qt-0.1.2.ebuild b/net-p2p/dc-qt/dc-qt-0.1.2.ebuild
index cb33f7227333..60e5fb47cf3b 100644
--- a/net-p2p/dc-qt/dc-qt-0.1.2.ebuild
+++ b/net-p2p/dc-qt/dc-qt-0.1.2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-qt/dc-qt-0.1.2.ebuild,v 1.3 2004/10/18 12:34:02 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dc-qt/dc-qt-0.1.2.ebuild,v 1.4 2005/07/13 18:03:07 sekretarz Exp $
-IUSE=""
+inherit eutils
+
+IUSE="xine"
DESCRIPTION="Direct Connect Text Client, QT Gui"
HOMEPAGE="http://dc-qt.sourceforge.net/"
@@ -14,10 +16,19 @@ KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
DEPEND=">=x11-libs/qt-3.2
>=net-p2p/dctc-0.85.9
- >=media-libs/xine-lib-1_rc5"
+ xine? ( >=media-libs/xine-lib-1_rc5 )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-xine.patch
+ autoreconf
+}
src_compile() {
- econf || die
+ econf \
+ `use_with xine` || die
emake || die
}