summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2003-07-24 00:35:57 +0000
committerArcady Genkin <agenkin@gentoo.org>2003-07-24 00:35:57 +0000
commit2f9e3ea2db41bf8641847296b949870f30521692 (patch)
treeab32df32cb8793a1e9623fc0466b9c61eb88bbe2 /net-p2p/dchub/dchub-0.4.5.ebuild
parentManifest update. (diff)
downloadgentoo-2-2f9e3ea2db41bf8641847296b949870f30521692.tar.gz
gentoo-2-2f9e3ea2db41bf8641847296b949870f30521692.tar.bz2
gentoo-2-2f9e3ea2db41bf8641847296b949870f30521692.zip
Version bump.
Diffstat (limited to 'net-p2p/dchub/dchub-0.4.5.ebuild')
-rw-r--r--net-p2p/dchub/dchub-0.4.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-p2p/dchub/dchub-0.4.5.ebuild b/net-p2p/dchub/dchub-0.4.5.ebuild
new file mode 100644
index 000000000000..852dd63f6e81
--- /dev/null
+++ b/net-p2p/dchub/dchub-0.4.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dchub/dchub-0.4.5.ebuild,v 1.1 2003/07/24 00:35:56 agenkin Exp $
+
+HOMEPAGE="http://www.ac2i.tzo.com/dctc/#dchub"
+DESCRIPTION="dchub (Direct Connect Hub), a linux hub for the p2p 'direct connect'"
+SRC_URI="http://ac2i.tzo.com/dctc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+RDEPEND="virtual/glibc
+ =dev-libs/glib-1*
+ dev-lang/perl
+ dev-db/edb"
+
+src_install() {
+ einstall || die "install problem"
+
+ dodoc Documentation/*
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+
+ dodir /etc/{conf,init}.d /etc/dchub
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dchub.init.d dchub
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dchub.conf.d dchub
+}