summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2009-04-05 13:05:38 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2009-04-05 13:05:38 +0000
commitcfc080907653e35dcfd1b9aab7c0a7db22884e7d (patch)
treea285d53fc3c27a82e9c9f43c3ec8f16d3ea9e396 /net-p2p/monsoon
parentamd64/x86 stable, bug #263987 (diff)
downloadgentoo-2-cfc080907653e35dcfd1b9aab7c0a7db22884e7d.tar.gz
gentoo-2-cfc080907653e35dcfd1b9aab7c0a7db22884e7d.tar.bz2
gentoo-2-cfc080907653e35dcfd1b9aab7c0a7db22884e7d.zip
Initial commit, ebuild by me.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/monsoon')
-rw-r--r--net-p2p/monsoon/ChangeLog10
-rw-r--r--net-p2p/monsoon/files/monsoon-0.20-build.patch126
-rw-r--r--net-p2p/monsoon/metadata.xml5
-rw-r--r--net-p2p/monsoon/monsoon-0.20.ebuild44
4 files changed, 185 insertions, 0 deletions
diff --git a/net-p2p/monsoon/ChangeLog b/net-p2p/monsoon/ChangeLog
new file mode 100644
index 000000000000..6e04f2fd1c97
--- /dev/null
+++ b/net-p2p/monsoon/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/monsoon
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/monsoon/ChangeLog,v 1.1 2009/04/05 13:05:37 loki_val Exp $
+
+*monsoon-0.20 (05 Apr 2009)
+
+ 05 Apr 2009; Peter Alfredsen <loki_val@gentoo.org>
+ +files/monsoon-0.20-build.patch, +metadata.xml, +monsoon-0.20.ebuild:
+ Initial commit, ebuild by me.
+
diff --git a/net-p2p/monsoon/files/monsoon-0.20-build.patch b/net-p2p/monsoon/files/monsoon-0.20-build.patch
new file mode 100644
index 000000000000..b58a93fe7518
--- /dev/null
+++ b/net-p2p/monsoon/files/monsoon-0.20-build.patch
@@ -0,0 +1,126 @@
+diff -NrU5 monsoon-0.20.orig/Monsoon/Makefile.am monsoon-0.20/Monsoon/Makefile.am
+--- monsoon-0.20.orig/Monsoon/Makefile.am 2009-02-05 00:41:06.000000000 +0100
++++ monsoon-0.20/Monsoon/Makefile.am 2009-02-05 00:53:41.000000000 +0100
+@@ -1,7 +1,6 @@
+-
+-EXTRA_DIST = $(NLOG_DLL_SOURCE)
++EXTRA_DIST =
+
+ # Warning: This is an automatically generated file, do not edit!
+
+ if ENABLE_DEBUG
+ ASSEMBLY_COMPILER_COMMAND = gmcs
+@@ -19,11 +18,10 @@
+ RSS_PNG_SOURCE=icons/rss.png
+ LOWEST_PNG_SOURCE=icons/lowest.png
+ MONSOON_DESKTOP_SOURCE=monsoon.desktop
+ DONOTDOWNLOAD_PNG_SOURCE=icons/donotdownload.png
+ NORMAL_PNG_SOURCE=icons/normal.png
+-NLOG_DLL_SOURCE=NLog.dll
+ LOW_PNG_SOURCE=icons/low.png
+
+ endif
+
+ if ENABLE_RELEASE
+@@ -42,25 +40,19 @@
+ RSS_PNG_SOURCE=icons/rss.png
+ LOWEST_PNG_SOURCE=icons/lowest.png
+ MONSOON_DESKTOP_SOURCE=monsoon.desktop
+ DONOTDOWNLOAD_PNG_SOURCE=icons/donotdownload.png
+ NORMAL_PNG_SOURCE=icons/normal.png
+-NLOG_DLL_SOURCE=NLog.dll
+ LOW_PNG_SOURCE=icons/low.png
+
+ endif
+
+ AL=al2
+ SATELLITE_ASSEMBLY_NAME=.resources.dll
+
+-UNSTABLE_LIBS = ./libs/MonoTorrent.dll \
+- ./libs/Mono.Nat.dll
+-
+ PROGRAMFILES = \
+- $(MONSOON_EXE_CONFIG) \
+- $(NLOG_DLL) \
+- $(UNSTABLE_LIBS)
++ $(MONSOON_EXE_CONFIG)
+
+ LINUX_DESKTOPAPPLICATIONS = \
+ $(MONSOON_DESKTOP)
+
+ PROGRAMFILES_ICONS = \
+@@ -76,22 +68,11 @@
+ BINARIES = \
+ $(MONSOON)
+
+
+
+-all: update-libs $(ASSEMBLY) $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES)
+- cp ./libs/MonoTorrent.dll ./bin/Release/MonoTorrent.dll
+- cp ./libs/Mono.Nat.dll ./bin/Release/Mono.Nat.dll
+-
+-./libs/Mono.Nat.dll: update-libs
+-./libs/MonoTorrent.dll: update-libs
+-
+-update-libs:
+- mkdir -p ./libs
+- cp `pkg-config --variable=Libraries monotorrent` ./libs/MonoTorrent.dll
+- cp `pkg-config --variable=Libraries mono.nat` ./libs/Mono.Nat.dll
+-
++all: $(ASSEMBLY) $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES)
+
+ FILES = \
+ AboutDialog.cs \
+ AssemblyInfo.cs \
+ ByteConverter.cs \
+@@ -184,16 +165,11 @@
+ Mono.Posix \
+ $(GCONF_SHARP_20_LIBS) \
+ $(GTK_SHARP_20_LIBS) \
+ $(GLIB_SHARP_20_LIBS)
+
+-DLL_REFERENCES = \
+- $(NLOG_DLL) \
+- ./libs/Mono.Nat.dll \
+- ./libs/MonoTorrent.dll
+-
+-CLEANFILES = $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES) $(UNSTABLE_LIBS)
++CLEANFILES = $(PROGRAMFILES) $(LINUX_DESKTOPAPPLICATIONS) $(PROGRAMFILES_ICONS) $(BINARIES)
+
+ include $(top_srcdir)/Makefile.include
+
+ MONSOON_EXE_CONFIG = $(BUILD_DIR)/Monsoon.exe.config
+ HIGH_PNG = $(BUILD_DIR)/icons/high.png
+@@ -203,11 +179,10 @@
+ LOWEST_PNG = $(BUILD_DIR)/icons/lowest.png
+ MONSOON_DESKTOP = $(BUILD_DIR)/monsoon.desktop
+ DONOTDOWNLOAD_PNG = $(BUILD_DIR)/icons/donotdownload.png
+ MONSOON = $(BUILD_DIR)/monsoon
+ NORMAL_PNG = $(BUILD_DIR)/icons/normal.png
+-NLOG_DLL = $(BUILD_DIR)/NLog.dll
+ LOW_PNG = $(BUILD_DIR)/icons/low.png
+
+ $(eval $(call emit-deploy-target,MONSOON_EXE_CONFIG))
+ $(eval $(call emit-deploy-target,HIGH_PNG))
+ $(eval $(call emit-deploy-target,HIGHEST_PNG))
+@@ -216,18 +191,17 @@
+ $(eval $(call emit-deploy-target,LOWEST_PNG))
+ $(eval $(call emit-deploy-target,MONSOON_DESKTOP))
+ $(eval $(call emit-deploy-target,DONOTDOWNLOAD_PNG))
+ $(eval $(call emit-deploy-wrapper,MONSOON,monsoon,x))
+ $(eval $(call emit-deploy-target,NORMAL_PNG))
+-$(eval $(call emit-deploy-target,NLOG_DLL))
+ $(eval $(call emit-deploy-target,LOW_PNG))
+
+
+ $(build_xamlg_list): %.xaml.g.cs: %.xaml
+ xamlg '$<'
+
+ $(build_resx_resources) : %.resources: %.resx
+ resgen2 '$<' '$@'
+
+-$(ASSEMBLY) $(ASSEMBLY_MDB): $(build_sources) $(build_resources) $(build_datafiles) $(DLL_REFERENCES) $(PROJECT_REFERENCES) $(build_xamlg_list) $(build_satellite_assembly_list)
++$(ASSEMBLY) $(ASSEMBLY_MDB): $(build_sources) $(build_resources) $(build_datafiles) $(PROJECT_REFERENCES) $(build_xamlg_list) $(build_satellite_assembly_list)
+ mkdir -p $(dir $(ASSEMBLY))
+- $(ASSEMBLY_COMPILER_COMMAND) $(ASSEMBLY_COMPILER_FLAGS) -out:$(ASSEMBLY) -target:$(COMPILE_TARGET) $(build_sources_embed) $(build_resources_embed) $(build_references_ref)
++ $(ASSEMBLY_COMPILER_COMMAND) $(ASSEMBLY_COMPILER_FLAGS) -out:$(ASSEMBLY) -target:$(COMPILE_TARGET) $(build_sources_embed) $(build_resources_embed) $(build_references_ref) -pkg:mono.nat -pkg:monotorrent -pkg:nlog
diff --git a/net-p2p/monsoon/metadata.xml b/net-p2p/monsoon/metadata.xml
new file mode 100644
index 000000000000..e01adbb307db
--- /dev/null
+++ b/net-p2p/monsoon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/net-p2p/monsoon/monsoon-0.20.ebuild b/net-p2p/monsoon/monsoon-0.20.ebuild
new file mode 100644
index 000000000000..85d838eec038
--- /dev/null
+++ b/net-p2p/monsoon/monsoon-0.20.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/monsoon/monsoon-0.20.ebuild,v 1.1 2009/04/05 13:05:37 loki_val Exp $
+
+EAPI=2
+
+inherit mono multilib autotools
+
+DESCRIPTION="Monosoon is an open source Gtk# bittorrent client"
+HOMEPAGE="http://www.monsoon-project.org/"
+SRC_URI="http://monotorrent.com/Files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+RDEPEND=">=dev-lang/mono-2.0.1
+ >=dev-dotnet/monotorrent-0.70
+ >=dev-dotnet/mono-nat-1.0
+ >=dev-dotnet/nlog-1.0
+ >=dev-dotnet/dbus-sharp-0.6.1a
+ >=dev-dotnet/dbus-glib-sharp-0.4.1
+ >=dev-dotnet/gtk-sharp-2.12.7-r10
+ >=dev-dotnet/gdk-sharp-2.12.7-r10
+ >=dev-dotnet/glib-sharp-2.12.7-r10
+ >=dev-dotnet/gconf-sharp-2.24.0-r10"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.23"
+
+#This sucks, but the install process is screwed up if it's set.
+unset LINGUAS
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build.patch"
+ AT_M4DIR="${S}" eautoreconf
+}
+
+src_compile() {
+ emake -j1 ASSEMBLY_COMPILER_COMMAND="/usr/bin/gmcs"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+}