summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2007-09-23 12:20:22 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2007-09-23 12:20:22 +0000
commit8dfd6056466be69bd1f7d619584d1abf473535b0 (patch)
treea1f0897516ee50aa5c0d3f8a51b9634376c5ef7e /net-p2p/museek+/files
parentadd elisp-site-regen to postrm and canonicalise it in postinst; depending on ... (diff)
downloadgentoo-2-8dfd6056466be69bd1f7d619584d1abf473535b0.tar.gz
gentoo-2-8dfd6056466be69bd1f7d619584d1abf473535b0.tar.bz2
gentoo-2-8dfd6056466be69bd1f7d619584d1abf473535b0.zip
Make optional deps configurable.
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-p2p/museek+/files')
-rw-r--r--net-p2p/museek+/files/digest-museek+-0.1.13-r1 (renamed from net-p2p/museek+/files/digest-museek+-0.1.13)0
-rw-r--r--net-p2p/museek+/files/museek+-0.1.13-optional-deps.patch95
-rw-r--r--net-p2p/museek+/files/museek+-0.1.13-post_release_fixes.patch7
3 files changed, 95 insertions, 7 deletions
diff --git a/net-p2p/museek+/files/digest-museek+-0.1.13 b/net-p2p/museek+/files/digest-museek+-0.1.13-r1
index 831269f7b4d6..831269f7b4d6 100644
--- a/net-p2p/museek+/files/digest-museek+-0.1.13
+++ b/net-p2p/museek+/files/digest-museek+-0.1.13-r1
diff --git a/net-p2p/museek+/files/museek+-0.1.13-optional-deps.patch b/net-p2p/museek+/files/museek+-0.1.13-optional-deps.patch
new file mode 100644
index 000000000000..c5f282cde693
--- /dev/null
+++ b/net-p2p/museek+/files/museek+-0.1.13-optional-deps.patch
@@ -0,0 +1,95 @@
+--- CMakeLists.txt 2007-09-23 13:10:33.000000000 +0200
++++ CMakeLists.txt 2007-09-23 13:14:32.000000000 +0200
+@@ -261,7 +261,7 @@
+ endif (NOT DIR_H)
+
+ # Detect Vorbisfile library
+-if (HAVE_VORBIS_H)
++if (HAVE_VORBIS_H AND VORBIS)
+ find_library(VORBIS_LIBRARIES NAMES vorbisfile PATHS /usr/lib /usr/local/lib)
+ if (VORBIS_LIBRARIES)
+ set(HAVE_VORBIS 1)
+@@ -270,9 +270,9 @@
+ message(STATUS "Vorbisfile library wasn't found, ogg metadata will not be created")
+ set(VORBIS_LIBRARIES "")
+ endif (VORBIS_LIBRARIES)
+-else (HAVE_VORBIS_H)
++else (HAVE_VORBIS_H AND VORBIS)
+ set(VORBIS_LIBRARIES "")
+-endif (HAVE_VORBIS_H)
++endif (HAVE_VORBIS_H AND VORBIS)
+
+ set(CMAKE_REQUIRED_LIBRARIES)
+
+@@ -340,4 +340,4 @@
+ add_subdirectory(museeq)
+ else (C_MUSEEQ)
+ message("!!! museeq will NOT be installed [NO_MUSEEQ=0]")
+-endif (C_MUSEEQ)
+\ No hay ningún carácter de nueva línea al final del fichero
++endif (C_MUSEEQ)
+--- museeq/CMakeLists.txt 2007-09-23 13:10:33.000000000 +0200
++++ museeq/CMakeLists.txt 2007-09-23 13:13:58.000000000 +0200
+@@ -1,9 +1,7 @@
+ project(museeq) # the name of your project
+
+ MESSAGE("DECLARATIONS: PREFIX (/usr), MANDIR (PREFIX/man), DATADIR (PREFIX/share), BINRELOC, TRAYICON
+-Prefix declarations with -D and set them with either 1, 0 or a path.
+-QSA is detected automatically
+-")
++Prefix declarations with -D and set them with either 1, 0 or a path.")
+
+
+ cmake_minimum_required(VERSION 2.4.0)
+@@ -175,13 +173,17 @@
+ int main() {
+ QSInterpreter::defaultInterpreter()->hasFunction(\"\");
+ }
+-" QSA)
++" HAVE_QSA)
+
+ if (QSA)
+-MESSAGE(STATUS "QSA available")
+- add_definitions(-DHAVE_QSA=1 -DHAVE_QSA_DIALOG=1 )
++ if (HAVE_QSA)
++ MESSAGE(STATUS "QSA available")
++ add_definitions(-DHAVE_QSA=1 -DHAVE_QSA_DIALOG=1 )
++ else (HAVE_QSA)
++ MESSAGE(FATAL_ERROR "!!! QSA NOT available")
++ endif (HAVE_QSA)
+ else (QSA)
+-MESSAGE("!!! QSA NOT available")
++MESSAGE("!!! QSA disabled")
+ endif (QSA)
+
+ message(STATUS "moc binary:" ${QT_MOC_EXECUTABLE})
+@@ -369,4 +371,4 @@
+ MESSAGE(" * without a Trayicon.. [TRAYICON=1]")
+ else (NOT TRAYICON)
+ MESSAGE(" * with a Trayicon.. [TRAYICON=0]")
+-endif (NOT TRAYICON)
+\ No hay ningún carácter de nueva línea al final del fichero
++endif (NOT TRAYICON)
+--- Tools/CMakeLists.txt 2007-09-23 13:10:33.000000000 +0200
++++ Tools/CMakeLists.txt 2007-09-23 13:11:55.000000000 +0200
+@@ -42,7 +42,7 @@
+ )
+ MESSAGE("--> muscan (file scanner) will be installed..")
+ # To build, or not build muscand
+-if (FAM_LIBRARIES AND FAM_H)
++if (NOT NO_MUSCAND AND FAM_LIBRARIES AND FAM_H)
+
+ add_executable(muscand ${MUSCAND_SOURCES})
+
+@@ -68,9 +68,9 @@
+ DESTINATION bin
+ )
+ MESSAGE("--> muscand (FAM-based file scanning daemon) will be installed..")
+-else(FAM_LIBRARIES AND FAM_H)
++else(NOT NO_MUSCAND AND FAM_LIBRARIES AND FAM_H)
+ MESSAGE("!!! muscand will NOT be installed..")
+-endif(FAM_LIBRARIES AND FAM_H)
++endif(NOT NO_MUSCAND AND FAM_LIBRARIES AND FAM_H)
+
+ target_link_libraries(
+ muscan
diff --git a/net-p2p/museek+/files/museek+-0.1.13-post_release_fixes.patch b/net-p2p/museek+/files/museek+-0.1.13-post_release_fixes.patch
index 6dd5df3cf77c..4c5be3ff1636 100644
--- a/net-p2p/museek+/files/museek+-0.1.13-post_release_fixes.patch
+++ b/net-p2p/museek+/files/museek+-0.1.13-post_release_fixes.patch
@@ -51,13 +51,6 @@ Index: museeq/CMakeLists.txt
set(ICONS
museeq.png
-@@ -369,4 +374,4 @@
- MESSAGE(" * without a Trayicon.. [TRAYICON=1]")
- else (NOT TRAYICON)
- MESSAGE(" * with a Trayicon.. [TRAYICON=0]")
--endif (NOT TRAYICON)
-\ Sin fin-de-línea al final del archivo
-+endif (NOT TRAYICON)
Index: museeq/mainwin.cpp
===================================================================
--- museeq/mainwin.cpp (revisión: 735)