summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-08-05 01:38:42 +0000
committerTim Harder <radhermit@gentoo.org>2011-08-05 01:38:42 +0000
commit1cc4aab35d8df69122854dcb64a682591a7318ef (patch)
treeecf5aaa420988427e481b23db366c9f47e8ae3d9 /net-p2p/opendchub/opendchub-0.8.2.ebuild
parentRemove old version (diff)
downloadgentoo-2-1cc4aab35d8df69122854dcb64a682591a7318ef.tar.gz
gentoo-2-1cc4aab35d8df69122854dcb64a682591a7318ef.tar.bz2
gentoo-2-1cc4aab35d8df69122854dcb64a682591a7318ef.zip
Version bump.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/opendchub/opendchub-0.8.2.ebuild')
-rw-r--r--net-p2p/opendchub/opendchub-0.8.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-p2p/opendchub/opendchub-0.8.2.ebuild b/net-p2p/opendchub/opendchub-0.8.2.ebuild
new file mode 100644
index 000000000000..ee4c85c65304
--- /dev/null
+++ b/net-p2p/opendchub/opendchub-0.8.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/opendchub/opendchub-0.8.2.ebuild,v 1.1 2011/08/05 01:38:41 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools
+
+DESCRIPTION="hub software for Direct Connect"
+HOMEPAGE="http://opendchub.sf.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )"
+DEPEND="${RDEPEND}"
+
+DOCS="NEWS TODO README AUTHORS Documentation/*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-telnet.patch
+ eautoreconf
+}
+
+src_configure() {
+ ! use perl && myconf="--disable-perl --enable-switch_user"
+ econf $myconf
+}
+
+src_install() {
+ default
+
+ if use perl ; then
+ exeinto /usr/bin
+ doexe "${FILESDIR}"/opendchub_setup.sh
+ dodir /usr/share/opendchub/scripts
+ insinto /usr/share/opendchub/scripts
+ doins Samplescripts/*
+ fi
+}
+
+pkg_postinst() {
+ if use perl ; then
+ einfo
+ einfo "To set up perl scripts for opendchub to use, please run"
+ einfo "opendchub_setup.sh as the user you will be using opendchub as."
+ einfo
+ fi
+}