summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2014-05-24 22:53:34 +0000
committerDavide Pesavento <pesa@gentoo.org>2014-05-24 22:53:34 +0000
commit964313ee6ad95c16d25cfde45f0dd411473ede75 (patch)
tree9a4d4da912acfca86712f830ecf983f70738abeb /net-p2p/qbittorrent/qbittorrent-9999.ebuild
parentversion bump (diff)
downloadgentoo-2-964313ee6ad95c16d25cfde45f0dd411473ede75.tar.gz
gentoo-2-964313ee6ad95c16d25cfde45f0dd411473ede75.tar.bz2
gentoo-2-964313ee6ad95c16d25cfde45f0dd411473ede75.zip
Depend on latest qtsingleapplication in order to fix bug 507998. Several ebuild enhancements. Remove old versions.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'net-p2p/qbittorrent/qbittorrent-9999.ebuild')
-rw-r--r--net-p2p/qbittorrent/qbittorrent-9999.ebuild61
1 files changed, 30 insertions, 31 deletions
diff --git a/net-p2p/qbittorrent/qbittorrent-9999.ebuild b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
index ae87a95f7337..ed46c12010d6 100644
--- a/net-p2p/qbittorrent/qbittorrent-9999.ebuild
+++ b/net-p2p/qbittorrent/qbittorrent-9999.ebuild
@@ -1,56 +1,55 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.15 2014/04/19 18:54:21 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-9999.ebuild,v 1.16 2014/05/24 22:53:34 pesa Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
-EGIT_REPO_URI="git://github.com/${PN}/qBittorrent.git
-https://github.com/${PN}/qBittorrent.git"
-
-inherit python-r1 qt4-r2 git-2
+inherit python-r1 qt4-r2 git-r3
DESCRIPTION="BitTorrent client in C++ and Qt"
HOMEPAGE="http://www.qbittorrent.org/"
+EGIT_REPO_URI="https://github.com/${PN}/qBittorrent.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="dbus +X geoip"
+IUSE="dbus debug geoip +X"
-# python-2 is a runtime dep only, for the search engine (see INSTALL file)
-CDEPEND="dev-libs/boost
+# geoip and python are runtime deps only (see INSTALL file)
+CDEPEND="
+ dev-libs/boost:=
dev-qt/qtcore:4
- net-libs/rb_libtorrent
- >=dev-qt/qtsingleapplication-2.6.1_p20130904[X?]
+ >=dev-qt/qtsingleapplication-2.6.1_p20130904-r1[X?]
+ >=net-libs/rb_libtorrent-0.16.10
+ dbus? ( dev-qt/qtdbus:4 )
X? ( dev-qt/qtgui:4 )
-
- dbus? ( dev-qt/qtdbus:4 )"
+"
DEPEND="${CDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
RDEPEND="${CDEPEND}
${PYTHON_DEPS}
- geoip? ( dev-libs/geoip )"
+ geoip? ( dev-libs/geoip )
+"
-DOCS="AUTHORS Changelog NEWS README TODO"
-
-src_prepare() {
- # Respect LDFLAGS
- sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
- qt4-r2_src_prepare
-}
+DOCS=(AUTHORS Changelog README TODO)
src_configure() {
- local myconf
- use geoip || myconf+=" --disable-geoip-database"
- use dbus || myconf+=" --disable-qt-dbus"
- use X || myconf+=" --disable-gui"
-
- # econf fails, since this uses qconf
- ./configure --prefix=/usr --qtdir=/usr \
- --with-qtsingleapplication=system \
- --with-libboost-inc=/usr/include/boost \
- ${myconf} || die "configure failed"
+ # Custom configure script, econf fails
+ local myconf=(
+ ./configure
+ --prefix="${EPREFIX}/usr"
+ --with-libboost-inc="${EPREFIX}/usr/include/boost"
+ --with-qtsingleapplication=system
+ $(use dbus || echo --disable-qt-dbus)
+ $(use debug && echo --enable-debug)
+ $(use geoip || echo --disable-geoip-database)
+ $(use X || echo --disable-gui)
+ )
+
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die "configure failed"
eqmake4
}