summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-12-20 13:22:53 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-12-20 13:22:53 +0000
commit2dd3f2393499c23ac67605ef7c830825be1739cc (patch)
tree15d7251148d87db95ad9e5e8f928785f0a55fce8 /net-p2p/qbittorrent
parentMask qbittorrent beta packages (diff)
downloadgentoo-2-2dd3f2393499c23ac67605ef7c830825be1739cc.tar.gz
gentoo-2-2dd3f2393499c23ac67605ef7c830825be1739cc.tar.bz2
gentoo-2-2dd3f2393499c23ac67605ef7c830825be1739cc.zip
Version bump. New beta ebuild
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.5.2.ebuild64
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.6.0_beta1.ebuild64
3 files changed, 136 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 5e5629b5d40e..11d266bbd31c 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.127 2010/12/06 19:48:34 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.128 2010/12/20 13:22:53 hwoarang Exp $
+
+*qbittorrent-2.6.0_beta1 (20 Dec 2010)
+*qbittorrent-2.5.2 (20 Dec 2010)
+
+ 20 Dec 2010; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-2.5.2.ebuild,
+ +qbittorrent-2.6.0_beta1.ebuild:
+ Version bump. New beta ebuild
*qbittorrent-2.5.1 (06 Dec 2010)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.5.2.ebuild b/net-p2p/qbittorrent/qbittorrent-2.5.2.ebuild
new file mode 100644
index 000000000000..22f7d6d4b19f
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.5.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.5.2.ebuild,v 1.1 2010/12/20 13:22:53 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-2.6.0_beta1.ebuild b/net-p2p/qbittorrent/qbittorrent-2.6.0_beta1.ebuild
new file mode 100644
index 000000000000..1fd8e4970ce7
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.6.0_beta1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.6.0_beta1.ebuild,v 1.1 2010/12/20 13:22:53 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python confutils qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}