summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-03-14 17:04:45 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-03-14 17:04:45 +0000
commit18c5545621626a3711ee584a027a039e9b254a5d (patch)
tree0835f8d0eed7170ed8200d3634e4d857ccc7bb5f /net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild
parentadd HTML-Parser dependency, fix bug #17459 (diff)
downloadgentoo-2-18c5545621626a3711ee584a027a039e9b254a5d.tar.gz
gentoo-2-18c5545621626a3711ee584a027a039e9b254a5d.tar.bz2
gentoo-2-18c5545621626a3711ee584a027a039e9b254a5d.zip
Version bump
Diffstat (limited to 'net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild')
-rw-r--r--net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild b/net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild
new file mode 100644
index 000000000000..a3a7b2a71209
--- /dev/null
+++ b/net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qt-dcgui/qt-dcgui-0.2.7.ebuild,v 1.1 2003/03/14 17:04:45 aliz Exp $
+
+inherit kde-functions
+
+MY_P="${P/qt-/}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Qt based client for DirectConnect"
+HOMEPAGE="http://dc.ketelhot.de/"
+SRC_URI="http://download.berlios.de/dcgui/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="pic ssl"
+
+need-qt 3
+newdepend ">=dev-libs/libxml2-2.4.22
+ =net-p2p/dclib-${PV}*
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+ econf \
+ --with-gnu-ld \
+ `use_with pic` \
+ `use_with ssl` \
+ --with-libdc=/usr \
+ --with-qt-dir=/usr/qt/3 \
+ || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+}