summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-15 21:38:15 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-06-15 21:38:15 +0000
commit8ebdd1e65290583512068ec51b01b266a110241d (patch)
tree9cd8b903b5360254bdc82b52834a53c6d95b5c3d /net-p2p/rtorrent/rtorrent-0.2.5.ebuild
parentNew upstream version. (diff)
downloadgentoo-2-8ebdd1e65290583512068ec51b01b266a110241d.tar.gz
gentoo-2-8ebdd1e65290583512068ec51b01b266a110241d.tar.bz2
gentoo-2-8ebdd1e65290583512068ec51b01b266a110241d.zip
New upstream version. Also make all rtorrent version depend on the libtorrent version they are released with.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'net-p2p/rtorrent/rtorrent-0.2.5.ebuild')
-rw-r--r--net-p2p/rtorrent/rtorrent-0.2.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.2.5.ebuild b/net-p2p/rtorrent/rtorrent-0.2.5.ebuild
new file mode 100644
index 000000000000..9412ca7e0994
--- /dev/null
+++ b/net-p2p/rtorrent/rtorrent-0.2.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.2.5.ebuild,v 1.1 2005/06/15 21:38:15 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="BitTorrent Client using libtorrent"
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="~net-libs/libtorrent-0.6.5
+ >=dev-libs/libsigc++-2.0
+ >=net-misc/curl-7.12
+ sys-libs/ncurses"
+
+src_compile() {
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+pkg_postinst() {
+ einfo "rtorrent now supports a configuration file."
+ einfo "A sample configuration file for rtorrent is can be found"
+ einfo "in ${ROOT}usr/share/${PF}/rtorrent.rc.gz."
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS README TODO doc/rtorrent.rc
+}