summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-14 11:35:38 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-14 11:35:38 +0000
commit8240d4c901c04e73158022db49dee92f73f12cd5 (patch)
tree72913edbdee0db0a774c3fd6f63b0d66fd882d95 /net-p2p/syrep
parentVersion Bump to solve #320947. (diff)
downloadgentoo-2-8240d4c901c04e73158022db49dee92f73f12cd5.tar.gz
gentoo-2-8240d4c901c04e73158022db49dee92f73f12cd5.tar.bz2
gentoo-2-8240d4c901c04e73158022db49dee92f73f12cd5.zip
Fix BerkDB detection code to be compatible with 5.0 wrt #319953 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/syrep')
-rw-r--r--net-p2p/syrep/ChangeLog8
-rw-r--r--net-p2p/syrep/syrep-0.9.ebuild30
2 files changed, 20 insertions, 18 deletions
diff --git a/net-p2p/syrep/ChangeLog b/net-p2p/syrep/ChangeLog
index b90bb0060efd..0e72bf94cabc 100644
--- a/net-p2p/syrep/ChangeLog
+++ b/net-p2p/syrep/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/syrep
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/syrep/ChangeLog,v 1.4 2008/01/16 16:06:54 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/syrep/ChangeLog,v 1.5 2010/07/14 11:35:38 ssuominen Exp $
+
+ 14 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> syrep-0.9.ebuild:
+ Fix BerkDB detection code to be compatible with 5.0 wrt #319953 by Diego
+ E. Pettenò.
*syrep-0.9 (16 Jan 2008)
diff --git a/net-p2p/syrep/syrep-0.9.ebuild b/net-p2p/syrep/syrep-0.9.ebuild
index 7424b3d1e93f..a47fa2bd8718 100644
--- a/net-p2p/syrep/syrep-0.9.ebuild
+++ b/net-p2p/syrep/syrep-0.9.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/syrep/syrep-0.9.ebuild,v 1.1 2008/01/16 16:06:54 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/syrep/syrep-0.9.ebuild,v 1.2 2010/07/14 11:35:38 ssuominen Exp $
-inherit eutils autotools
+EAPI=2
+inherit autotools
DESCRIPTION="A p2p generic file repository synchronization tool that may be used to synchronize large file hierarchies bidirectionally by exchanging patch files."
HOMEPAGE="http://0pointer.de/lennart/projects/syrep/"
@@ -10,34 +11,31 @@ SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="doc"
DEPEND="sys-libs/zlib
>=sys-libs/db-4.3
doc? ( www-client/lynx )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i -e "s/#if (DB_VERSION_MAJOR != 4).*/#if (DB_VERSION_MAJOR != 4)/" configure.ac
-
+src_prepare() {
+ sed -i \
+ -e "s/#if (DB_VERSION_MAJOR != 4).*/#if (DB_VERSION_MAJOR < 4)/" \
+ configure.ac || die
eautoreconf
}
-src_compile() {
+
+src_configure() {
econf \
$(use_enable doc lynx) \
--disable-xmltoman \
--disable-subversion \
- --disable-gengetopt \
- || die "econf failed"
- emake || die "emake failed"
+ --disable-gengetopt
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- cd "${S}"/doc
+ emake DESTDIR="${D}" install || die
+ cd doc
dodoc README *.txt
use doc && dohtml *.html *.css
}