summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2008-09-04 23:51:43 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2008-09-04 23:51:43 +0000
commit745db74942eba3b646d00eee8e7f9774f521a79d (patch)
tree3eb800841fa49b5c3610f6adde646861ff8a5fca /net-p2p/transmission
parentrm (diff)
downloadgentoo-2-745db74942eba3b646d00eee8e7f9774f521a79d.tar.gz
gentoo-2-745db74942eba3b646d00eee8e7f9774f521a79d.tar.bz2
gentoo-2-745db74942eba3b646d00eee8e7f9774f521a79d.zip
version bump for transmission
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc3-git3 i686)
Diffstat (limited to 'net-p2p/transmission')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/transmission-1.33.ebuild37
2 files changed, 44 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 151a95a58fa1..1862ab870ccf 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.63 2008/07/08 03:53:13 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.64 2008/09/04 23:51:43 compnerd Exp $
+
+*transmission-1.33 (04 Sep 2008)
+
+ 04 Sep 2008; Saleem Abdulrasool <compnerd@gentoo.org>
+ +transmission-1.33.ebuild:
+ Version bump from upstream
*transmission-1.22 (08 Jul 2008)
diff --git a/net-p2p/transmission/transmission-1.33.ebuild b/net-p2p/transmission/transmission-1.33.ebuild
new file mode 100644
index 000000000000..75726e67b2e0
--- /dev/null
+++ b/net-p2p/transmission/transmission-1.33.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-1.33.ebuild,v 1.1 2008/09/04 23:51:43 compnerd Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com/"
+SRC_URI="http://download.transmissionbt.com/transmission/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk libnotify"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=net-misc/curl-7.15.0
+ >=dev-libs/openssl-0.9.8
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-libs/dbus-glib-0.72 )
+ libnotify? ( >=x11-libs/libnotify-0.4.4 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ gtk? ( >=dev-util/intltool-0.35 )"
+
+src_compile() {
+ econf $(use_enable gtk) $(use_enable libnotify) --with-wx-config=no || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS
+
+ doinitd "${FILESDIR}/transmission-daemon"
+}