summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-03-07 21:50:36 +0000
committerAlex Alexander <wired@gentoo.org>2010-03-07 21:50:36 +0000
commit028a2a056baaa16ed2e2d8802008a4b86cb1b1ba (patch)
tree640133d785c09a847170a191417fcc8880d6eee5 /net-p2p
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-028a2a056baaa16ed2e2d8802008a4b86cb1b1ba.tar.gz
gentoo-2-028a2a056baaa16ed2e2d8802008a4b86cb1b1ba.tar.bz2
gentoo-2-028a2a056baaa16ed2e2d8802008a4b86cb1b1ba.zip
version bump, bug #308125
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/qbittorrent/ChangeLog7
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index c7672c6c5125..c36c5f4960d2 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.72 2010/02/23 17:05:07 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.73 2010/03/07 21:50:36 wired Exp $
+
+*qbittorrent-2.1.6 (07 Mar 2010)
+
+ 07 Mar 2010; Alex Alexander <wired@gentoo.org> +qbittorrent-2.1.6.ebuild:
+ version bump, bug #308125
23 Feb 2010; Markos Chandras <hwoarang@gentoo.org>
qbittorrent-2.1.2.ebuild:
diff --git a/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild b/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild
new file mode 100644
index 000000000000..57da26964624
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.1.6.ebuild,v 1.1 2010/03/07 21:50:36 wired Exp $
+
+EAPI="2"
+inherit confutils qt4-r2
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X geoip libnotify"
+
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ x11-libs/qt-core:4
+ X? ( x11-libs/qt-gui:4
+ libnotify? ( x11-libs/qt-gui:4[glib] ) )
+ >=dev-libs/boost-1.34.1"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+RDEPEND="${CDEPEND}
+ >=dev-lang/python-2.3
+ geoip? ( dev-libs/geoip )
+ libnotify? ( x11-libs/libnotify )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+pkg_setup() {
+ confutils_use_depend_all libnotify X
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use libnotify || myconf+=" --disable-libnotify"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}