summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-04 02:26:38 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-04 02:26:38 +0000
commit270506d38bdfec41500494cedd51ab54e3063915 (patch)
tree0143e3d7edab01b089e0bb9e1f8259a57855eb87 /net-p2p
parentAnother version bump (diff)
downloadgentoo-2-270506d38bdfec41500494cedd51ab54e3063915.tar.gz
gentoo-2-270506d38bdfec41500494cedd51ab54e3063915.tar.bz2
gentoo-2-270506d38bdfec41500494cedd51ab54e3063915.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog9
-rw-r--r--net-p2p/bitcoind/bitcoind-0.7.2.ebuild115
2 files changed, 122 insertions, 2 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 945831999afb..2024a90de27a 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/bitcoind
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.52 2012/12/14 15:33:57 mgorny Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.53 2013/01/04 02:26:38 blueness Exp $
+
+*bitcoind-0.7.2 (04 Jan 2013)
+
+ 04 Jan 2013; Anthony G. Basile <blueness@gentoo.org> +bitcoind-0.7.2.ebuild:
+ Version bump
14 Dec 2012; Michał Górny <mgorny@gentoo.org> metadata.xml:
Remove redundant USE=upnp description; it matches the global flag meaning.
diff --git a/net-p2p/bitcoind/bitcoind-0.7.2.ebuild b/net-p2p/bitcoind/bitcoind-0.7.2.ebuild
new file mode 100644
index 000000000000..6db35c65dfe0
--- /dev/null
+++ b/net-p2p/bitcoind/bitcoind-0.7.2.ebuild
@@ -0,0 +1,115 @@
+# Copyright 2010-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.7.2.ebuild,v 1.1 2013/01/04 02:26:38 blueness Exp $
+
+EAPI="4"
+
+DB_VER="4.8"
+
+inherit db-use eutils versionator toolchain-funcs
+
+DESCRIPTION="Original Bitcoin crypto-currency wallet for automated services"
+HOMEPAGE="http://bitcoin.org/"
+SRC_URI="http://gitorious.org/bitcoin/bitcoind-stable/archive-tarball/v${PV/_/} -> bitcoin-v${PV}.tgz
+ eligius? ( http://luke.dashjr.org/programs/bitcoin/files/bitcoind/eligius/sendfee/0.7.1-eligius_sendfee.patch.xz )
+"
+
+LICENSE="MIT ISC GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+eligius examples ipv6 logrotate upnp"
+
+RDEPEND="
+ >=dev-libs/boost-1.41.0
+ dev-libs/openssl[-bindist]
+ logrotate? (
+ app-admin/logrotate
+ )
+ upnp? (
+ net-libs/miniupnpc
+ )
+ sys-libs/db:$(db_ver_to_slot "${DB_VER}")[cxx]
+"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-4.1
+"
+
+S="${WORKDIR}/bitcoin-bitcoind-stable"
+
+pkg_setup() {
+ local UG='bitcoin'
+ enewgroup "${UG}"
+ enewuser "${UG}" -1 -1 /var/lib/bitcoin "${UG}"
+}
+
+src_prepare() {
+ use eligius && epatch "${WORKDIR}/0.7.1-eligius_sendfee.patch"
+}
+
+src_compile() {
+ OPTS=()
+ local BOOST_PKG BOOST_VER BOOST_INC
+
+ OPTS+=("DEBUGFLAGS=")
+ OPTS+=("CXXFLAGS=${CXXFLAGS}")
+ OPTS+=("LDFLAGS=${LDFLAGS}")
+
+ OPTS+=("BDB_INCLUDE_PATH=$(db_includedir "${DB_VER}")")
+ OPTS+=("BDB_LIB_SUFFIX=-${DB_VER}")
+
+ BOOST_PKG="$(best_version 'dev-libs/boost')"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ BOOST_INC="/usr/include/boost-${BOOST_VER}"
+ OPTS+=("BOOST_INCLUDE_PATH=${BOOST_INC}")
+ OPTS+=("BOOST_LIB_SUFFIX=-${BOOST_VER}")
+
+ if use upnp; then
+ OPTS+=(USE_UPNP=1)
+ else
+ OPTS+=(USE_UPNP=)
+ fi
+ use ipv6 || OPTS+=("USE_IPV6=-")
+
+ # Workaround for bug #440034
+ share/genbuild.sh src/obj/build.h
+
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" ${PN}
+}
+
+src_test() {
+ cd src || die
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
+src_install() {
+ dobin src/${PN}
+
+ insinto /etc/bitcoin
+ newins "${FILESDIR}/bitcoin.conf" bitcoin.conf
+ fowners bitcoin:bitcoin /etc/bitcoin/bitcoin.conf
+ fperms 600 /etc/bitcoin/bitcoin.conf
+
+ newconfd "${FILESDIR}/bitcoin.confd" ${PN}
+ newinitd "${FILESDIR}/bitcoin.initd" ${PN}
+
+ keepdir /var/lib/bitcoin/.bitcoin
+ fperms 700 /var/lib/bitcoin
+ fowners bitcoin:bitcoin /var/lib/bitcoin/
+ fowners bitcoin:bitcoin /var/lib/bitcoin/.bitcoin
+ dosym /etc/bitcoin/bitcoin.conf /var/lib/bitcoin/.bitcoin/bitcoin.conf
+
+ dodoc doc/README
+
+ if use examples; then
+ docinto examples
+ dodoc -r contrib/{bitrpc,pyminer,wallettools}
+ fi
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/bitcoind.logrotate" bitcoind
+ fi
+}