summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@gentoo.org>2007-07-04 05:20:04 +0000
committerSaleem Abdulrasool <compnerd@gentoo.org>2007-07-04 05:20:04 +0000
commit27cf900e20328be642094d3c0964df5ad13686d5 (patch)
treed2f159e4674a4f00ad3198c6f6169e749e060178 /net-p2p
parentRemove redundant src_install. (diff)
downloadgentoo-2-27cf900e20328be642094d3c0964df5ad13686d5.tar.gz
gentoo-2-27cf900e20328be642094d3c0964df5ad13686d5.tar.bz2
gentoo-2-27cf900e20328be642094d3c0964df5ad13686d5.zip
rev bump to deal with upstreams random update
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog8
-rw-r--r--net-p2p/transmission/files/digest-transmission-0.72-r13
-rw-r--r--net-p2p/transmission/transmission-0.72-r1.ebuild44
3 files changed, 54 insertions, 1 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index f1bfc7b1b49c..c64ec099d5bc 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.25 2007/06/02 21:27:00 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.26 2007/07/04 05:20:04 compnerd Exp $
+
+*transmission-0.72-r1 (04 Jul 2007)
+
+ 04 Jul 2007; Saleem Abdulrasool <compnerd@gentoo.org>
+ +transmission-0.72-r1.ebuild:
+ Revision bump for upsate from upstream without a release.
02 Jun 2007; René Nussbaumer <killerfox@gentoo.org>
transmission-0.72.ebuild:
diff --git a/net-p2p/transmission/files/digest-transmission-0.72-r1 b/net-p2p/transmission/files/digest-transmission-0.72-r1
new file mode 100644
index 000000000000..e56177369011
--- /dev/null
+++ b/net-p2p/transmission/files/digest-transmission-0.72-r1
@@ -0,0 +1,3 @@
+MD5 4b0746b71612a2ac9ca7f145855967e3 Transmission-0.72.tar.gz 1390102
+RMD160 efec6a4604aa35bcf32430cf4cc026c1975b7bac Transmission-0.72.tar.gz 1390102
+SHA256 77b8982da2ae807128943581eb01a73bf0f40ccf78cd132e0d5c70203f5b092a Transmission-0.72.tar.gz 1390102
diff --git a/net-p2p/transmission/transmission-0.72-r1.ebuild b/net-p2p/transmission/transmission-0.72-r1.ebuild
new file mode 100644
index 000000000000..1343f166955a
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.72-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.72-r1.ebuild,v 1.1 2007/07/04 05:20:04 compnerd Exp $
+
+inherit eutils
+
+MY_PN="Transmission"
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://transmission.m0k.org/"
+SRC_URI="http://download.m0k.org/transmission/files/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="daemon gtk"
+
+RDEPEND="sys-devel/gettext
+ dev-libs/openssl
+ daemon? ( dev-libs/libevent )
+ gtk? ( >=x11-libs/gtk+-2.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix man page install location
+ sed -i -e 's|/man/man1|/share/man/man1|' mk/common.mk
+}
+
+src_compile() {
+ econf $(use_enable daemon) $(use_enable gtk) || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS README
+}