summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2007-07-23 21:33:37 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2007-07-23 21:33:37 +0000
commit38abd47819e7cd78824fd8c45b77c307827bb945 (patch)
treeab18002272864d8c56f3e2843c7a998dc255d895 /net-p2p
parentImport 0.9.20 from php-experimental overlay, proxy-committing for Christian H... (diff)
downloadgentoo-2-38abd47819e7cd78824fd8c45b77c307827bb945.tar.gz
gentoo-2-38abd47819e7cd78824fd8c45b77c307827bb945.tar.bz2
gentoo-2-38abd47819e7cd78824fd8c45b77c307827bb945.zip
Version bump
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog8
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.2.13
-rw-r--r--net-p2p/ktorrent/ktorrent-2.2.1.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index f49477c60593..deb04f778e7b 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.52 2007/07/06 23:51:05 keytoaster Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.53 2007/07/23 21:33:37 keytoaster Exp $
+
+*ktorrent-2.2.1 (23 Jul 2007)
+
+ 23 Jul 2007; Tobias Heinlein <keytoaster@gentoo.org>
+ +ktorrent-2.2.1.ebuild:
+ Version bump
*ktorrent-2.2 (06 Jul 2007)
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.2.1 b/net-p2p/ktorrent/files/digest-ktorrent-2.2.1
new file mode 100644
index 000000000000..95d70a1cf841
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.2.1
@@ -0,0 +1,3 @@
+MD5 229a0615d9252510d9387079dd5bd86d ktorrent-2.2.1.tar.gz 3763678
+RMD160 329b6e0556a11875d7ce36d669c5c25370552936 ktorrent-2.2.1.tar.gz 3763678
+SHA256 cd5f7ca8d9a06a317c4adf6336328dc79bdf6c7f7d31588af691ba202ef267f3 ktorrent-2.2.1.tar.gz 3763678
diff --git a/net-p2p/ktorrent/ktorrent-2.2.1.ebuild b/net-p2p/ktorrent/ktorrent-2.2.1.ebuild
new file mode 100644
index 000000000000..1f62c378f4eb
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.2.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.2.1.ebuild,v 1.1 2007/07/23 21:33:37 keytoaster Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="ar bg br ca cs cy da de el en_GB es et fa fr gl hu it ja ka lt
+ms nds nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}